OVH Community, your new community space.

Debian Sarge Image / Kernel


dennisda
30.12.06, 13:54
Tom wenn nix in den Logs steht kann ich die auch nicht Posten
über Telnet geht es sprich local. Jedoch von außen geht es nicht da kann ich machen was ich will. Senden geht aber wie geflutscht

*edit* sprich ich komme raus aber nicht rein

Tom
30.12.06, 13:31
Zitat Zitat von dennisda
@Tom

Trodzdem geht bei mir der Mail Empfang nicht hmmm

Also bei mir rennt das System nun 1a. und alles wird überspielt alle domains auf den server verwiesen.

Senden Empfangen kein problem.

Vielleicht einfach mal die fehler log posten ?

LabSen
28.12.06, 12:00
Also VHCS bringe ich ohne Probleme zum laufen unter PHP5 und MySQL5. Nun aber SysCP will nicht laufen. Bzw. ich kann es installieren und konfiguriere es so wie es im AdminCP steht. Aber wenn ich einen Kunden anlege, geht die Domain nicht bzw. domain.de die mit VHCS funktioniert hat, leitet einfach auf domain.de/apache2-default/ und domain.ksXXXXX.kimsufi.com funktioniert überhaupt nicht.

Kann mir da mal vielleicht jemand die Bind9, Cron.d und Apache2 Konfigurationen zukommen lassen?

dennisda
28.12.06, 11:01
@Tom

Trodzdem geht bei mir der Mail Empfang nicht hmmm

Tom
28.12.06, 10:22
so fehler liegt in der komischen hosts datei warum postfix nicht rennt.
# Do not remove the following line, or various programs
# that require network functionality will fail.
127.0.0.1 localhost.localdomain localhost
XXXX XXX.ovh.net
# The following lines are desirable for IPv6 capable hosts
#(added automatically by netbase upgrade)
::1 ip6-localhost ip6-loopback
feo0::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
ff02::3 ip6-allhosts
war die alte.


127.0.0.1 localhost ns23257

# The following lines are desirable for IPv6 capable hosts

::1 ip6-localhost ip6-loopback
feo0::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
ff02::3 ip6-allhosts
In die ersetzt für die Postfix geplagten leute.

Tom
28.12.06, 10:04
Wirklich?
Dachte ich jetzt garnicht
Ist ja schön das die anderen beiden bei Hetzner und Star-Hosting ohne eine DB rennen

mika
28.12.06, 00:51
Bei der syscp installation musst du zuerst eine eigene datenbank und datenbankbenutzer für syscp einrichten.
siehe:
einmal hier und einmal da

Tom
27.12.06, 22:02
Tja ich weiss nichtmehr weiter.

Habe nun bei meinem Hetzner SH und home server alles ausprobiert.
Dort klappt es auf anhieb mit einer Syscp installation mit Postfix.

Auf den OHV will er nicht wegen.
Dec 27 23:00:58 ns23257 postfix/trivial-rewrite[18029]: warning: connect to mysql server localhost: Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2)
Dec 27 23:00:58 ns23257 postfix/trivial-rewrite[18029]: fatal: mysql:/etc/postfix/mysql-virtual_mailbox_domains.cf(0,100): table lookup problem
Dec 27 23:00:59 ns23257 postfix/qmgr[28128]: warning: premature end-of-input on private/rewrite socket while reading input attribute name
Dec 27 23:00:59 ns23257 postfix/qmgr[28128]: warning: problem talking to service rewrite: Success
Dec 27 23:00:59 ns23257 postfix/master[25634]: warning: process /usr/lib/postfix/trivial-rewrite pid 18029 exit status 1
Dec 27 23:00:59 ns23257 postfix/master[25634]: warning: /usr/lib/postfix/trivial-rewrite: bad command startup -- throttling
Sowas hatte ich bisher nicht gehabt und habe aus spass die Installation auf allen 3 server gleichzeitig gemacht.
Nur der OHV stellt sich quer.

mika
27.12.06, 20:55
Zitat Zitat von charli
@mika:

Hallo,

Du kannst die verstellte SSH-Konfiguration im Rescue reparieren, dann brauchst Du nicht neuinstallieren.

Hey, danke..
Aber ich wollte sowieso mal ausprobieren, ob ich ISPConfig auf suse oder eventuell Gentoo install bekomme.
Für die Installation auf Gentoo gibts kein Howto , deshalb wäre es mal interessannt zum probieren..

charli
27.12.06, 19:09
@mika:

Hallo,

Du kannst die verstellte SSH-Konfiguration im Rescue reparieren, dann brauchst Du nicht neuinstallieren.

mika
27.12.06, 18:17
Lach..
Und soeben hat der Müdigkeitsteufel zugeschlagen.
Hab an der ssh.conf rumgefummelt und irgendwie gepennt..
Erfolg:
Kann kein https mehr aufrufen, komme nicht mehr über webmin auf den server und kann mich nicht mehr über Putty einloggen, weil ich den port geändert hab und dem root die Rechte zum direkten einloggen entzogen hab.
Den neuen user und sein PW will mein Isgenug nicht akzeptieren...

Aber der Rest wie mysql, http usw funkt..LOL

Lach Lach...
Mal wieder neuinstallen...
Aber dann werde ich erst im neuen Jahr weiterprobieren.ich fahre morgen in Urlaub...
Also guten Rutsch Leute

mika
27.12.06, 17:11
Zitat Zitat von LabSen
Hast du ISP Config mit PHP 4 oder PHP 5 laufen und Apache1 oder Apache2? Bei mir will es sich nicht installieren lassen mit PHP5 und Apache2
So..
Ich hab das mit Apache2 und php4 laufen.
Apache/2.0.54 (Debian GNU/Linux) PHP/4.3.10-18 mod_ssl/2.0.54 OpenSSL/0.9.7e mod_perl/1.999.21 Perl/v5.8.4
PHP Version 4.3.10-18
mysql 4.0.24

Eben halt genau nach Anleitung, die ich vorher gepostet hatte..

Und das ist der Kernel:
Linux ks33906.kimsufi.com 2.4.33grs-bipiv-ipv4-32 #1 SMP lun oct 23 19:00:07 CEST 2006 i686

sledge0303
27.12.06, 16:19
@Labsen

Welche Debian Version, dien aus dem OVH Images?
Es sollte problemlos klappen, wie der andere Kollege bereits geschrieben hat.

Ich hab mir meine selbst per Debootstrap installiert, sowie OVH 2.6.18 als 2.6.16 Kernel installiert, es funktioniert mit allem. PHP5+Apache2 kein Problem. Muss aber auch zugeben, alles wurde manuell gebaut und erfolgreich getestet.
Was mir manchmal noch Sorgen macht ist der Kernel im Zusammenhang mit GRUB.
Aus dem Rescue hat es nicht immer funktioniert GRUB auf der Platte zu installieren. Musste zuerst den Server mit einem OVH Kernel oder LILO konfigurieren und nach erfolgreichem hochfahren konnte GRUB installiert werden.
Es geht auch anders, hab aber momentan nicht die Zeit alle anderen Möglichkeiten auszutesten!

Normalerweise ist es mir egal welcher Bootloader, aber LILO kann nicht mit XEN.
Bei mir laufen 4 XEN Images/VMs mit Apache2+PHP5 (chrooted), MySQL, Postfix und PgSQL.

LabSen
27.12.06, 15:58
Zitat Zitat von mika
Komisch..
wie schon gesagt.
Bei mir läuft der Server optimal mit ISPConfig.
Postfix geht auch.hab nur festgestellt, das vom Anlegen einer mailadresse bis zu dem Zeitpunkt wo man sie entweder per Webmail oder Outlook nutzen kann , gerne so ca 20 Minuten vergehen können.
Keine Ahnung worann das nu liegt...
Aber ich werde meinen Isgenug mal ne weile so laufen lassen .
Der bekommt nu noch nen TS verpasst und nen Shoutcast.
Mal sehen, wie der dann reagiert bzw Einbricht.
256 mb Ram mehr währen doch schon ganz net..
Hast du ISP Config mit PHP 4 oder PHP 5 laufen und Apache1 oder Apache2? Bei mir will es sich nicht installieren lassen mit PHP5 und Apache2

mika
27.12.06, 15:35
Komisch..
wie schon gesagt.
Bei mir läuft der Server optimal mit ISPConfig.
Postfix geht auch.hab nur festgestellt, das vom Anlegen einer mailadresse bis zu dem Zeitpunkt wo man sie entweder per Webmail oder Outlook nutzen kann , gerne so ca 20 Minuten vergehen können.
Keine Ahnung worann das nu liegt...
Aber ich werde meinen Isgenug mal ne weile so laufen lassen .
Der bekommt nu noch nen TS verpasst und nen Shoutcast.
Mal sehen, wie der dann reagiert bzw Einbricht.
256 mb Ram mehr wären doch schon ganz net, dafür würde ich auch 5 EUR monatlich mehr zahlen..

mic
27.12.06, 15:06
Sehr schön, danke.

Briese
27.12.06, 15:02
Tjo, wie schon gesagt, ich kann nicht klagen

dennisda
27.12.06, 14:53
So, habe es so wie du es gepostet hast Installiert. jedoch kann ich immer noch keine Mails empfangen *g* die Logs sind leer.

*edit* ftp geht auch nicht. Vhcs halt

dennisda
27.12.06, 14:18
jap genauso so habe ich es auch gemacht. Installiere ehh debian gerade neu werde es dann nochmal installieren und hier ein report geben.

Briese
27.12.06, 14:15
Installation auf ein frisch Reinstallierten Debian Server, kein apt-get update vorher !


OK, mal ein HowTo

Per apt-get
apt-get install apache2 apache2-common apache2-mpm-prefork bind9 bzip2 courier-authdaemon courier-base courier-imap courier-maildrop courier-pop dialog diff gzip iptables libapache2-mod-php4 libberkeleydb-perl libcrypt-blowfish-perl libcrypt-cbc-perl libcrypt-passwdmd5-perl libdate-calc-perl libdate-manip-perl libdbd-mysql-perl libdbi-perl libio-stringy-perl libmail-sendmail-perl libmailtools-perl libmcrypt4 libmd5-perl libmime-perl libnet-dns-perl libnet-netmask-perl libnet-perl libnet-smtp-server-perl libperl5.8 libsasl2-modules libsasl2 libsnmp-session-perl libterm-readkey-perl libterm-readpassword-perl libtimedate-perl make mysql-client-4.1 mysql-common-4.1 mysql-server-4.1 original-awk patch perl perl-base perl-modules php4 php4-mcrypt php4-mysql php4-pear postfix postfix-tls procmail proftpd-mysql sasl2-bin tar wget
mysql Root P.w. setzen
/usr/bin/mysqladmin -u root password 'DeinPasswort'
cd /root

VHCS per wget ziehen
tar -xjf vhcs2-2.4.7.1.tar.bz2
cd vhcs2-2.4.7.1
make install
cd /tmp/vhcs-2.4.7.1
cp -R * /
cd /var/www/vhcs2/engine/setup/
./vhcs2-setup

Dann unbedingt noch das "login" Fix drauf !!!

und schick ist

.:Nachtrag:.
Danach hatte ich die "sources.list" mit den Dotdep Verz. bestückt und erst dann den Server per "update" und "upgrade" aktualisiert.

dennisda
27.12.06, 14:07
hmm wie ist das Vhcs installiert bzw die ganzen Dienste per APT-Get oder selber configuriert ?

Briese
27.12.06, 13:52
Hm,
ich kann nicht klagen.

Mein Testserver läuft mit folgender Config:


OS = Debian/Sarge
-VHCS
-PHP 4.4.4
-apache 2.0.54
-mySQL 4.1.15
-eAccelerator
-Suhosin Patch 0.9.6
-Denyhost

Das zu den wichtigsten Daten.

dennisda
27.12.06, 13:46
bei Vhcs hatte ich das Problem das ich verschicken konnte jedoch nicht empfangen. Najut im moment bin ich hier bei: http://www.postfix-howto.de/index.htm

Briese
27.12.06, 13:41
VHCS+Fix nutzen

dennisda
27.12.06, 13:30
@mika,

genau nach dieser Anleitung hatte ich es auch gemacht und auch ISPconfig installiert. Jedoch ging es nicht bzw nicht richtig.

mika
27.12.06, 13:25
Hm..
Ikke hab auch den Isgenug. Hab aus dem Manager die debian Distri mit besagtem kernel installed und bin dann einfach mal nach dieser Anleitung vorgegangen. Danach habe ich ISPConfig installiert und muss feststellen, das postfix ohne Probs läuft.

domi
27.12.06, 12:35
Zitat Zitat von Tom
Also ich mag die Kernel überhaupt nicht.
Ich bekomme dort kein Postfix und co. zum Rennen.
Ich wüsste nicht, wie das in direktem Zusammenhang stehen kann.

Domi.

dennisda
27.12.06, 12:02
kannst ja mal berichten wenn du es zum laufen bekommen hast -_-

Tom
27.12.06, 12:01
Ist etwas ärgerlich nun wenn man den Prodoktiv nutzen will und der alte server am 31.12 down geht

dennisda
27.12.06, 11:42
Ich bekomme dort kein Postfix und co. zum Rennen.
Ditooo

Tom
27.12.06, 11:38
Also ich mag die Kernel überhaupt nicht.

Ich bekomme dort kein Postfix und co. zum Rennen.

Und nein Kein Testserver sondern Bezahl Server.

Michael
27.12.06, 01:03
Zitat Zitat von Angie
...
Wir haben:
2.4. mit grsec und ohne grsec für ipv4 und ipv6 und diese dann nochmal mit und ohne Hyperthreading
2.6 dann wie oben mit dem 64 bit Support usw.

Der 2.6. default, wenn ich mich genau erinnere, wurde nicht installiert weil die eth0 und eth1 bei den Servern mit zwei Netzwekkarten einfach umdreht und so der Server nicht mehr pingt...
Nutzen eigentlich noch viele 2.4 Kernel ?

Hat vielleicht hat eine Anleitung / Howto geschrieben wie man per debootstrap Sarge oder Etch auf nem OVH Server installiert (Standarddebiankernel). Habe es selbst schon mal versucht, aber nicht erfolgreich

dennisda
19.12.06, 22:43
Danke das war es
ich sollte auch mal richtig lesen lernen *g*

domi
19.12.06, 22:42
Das war auch nicht die Lösung

Die Fehlermeldung sagt, dass du sämtliche Einträge mit SMTP aus der inetd.conf entfernen sollst, sogar die, die auskommentiert sind.

Warum auch immer das preconfigure-script von qmail das will, will es nichts von smtp in der Konfig des inetd sehen. Sinn macht das zwar nicht, aber vielleicht hat sich der Maintainer doch etwas dabei gedacht...

Gruß Domi.

dennisda
19.12.06, 22:25
Danke habe die Raute ma wech gemacht, Meldung bleib aber bestehen.
Langsam zweifel ich an meinem Verstand.

domi
19.12.06, 22:21
Zitat Zitat von dennisda
in der etc/inetd.conf steht zwar was von smtp aber davor ist ein Raute.
Deswegen steht in der Fehlermeldung ja auch "(even those commented out)"

Domi.

dennisda
19.12.06, 22:15
zum Thema Kerne und Debian, kann das sein das man kein Vernünftiges MTA installieren kann. Postfix mit Antivir und spamfilter ging nicht.
qmail auch nicht. bei Qmail kommt zum beispiel:

Your /etc/inetd.conf already containts entries for the SMTP service.
Please remove all SMTP entries from /etc/inetd.conf (even those commented out)
and reinstall the qmail package.

dpkg: Fehler beim Bearbeiten von /tmp/qmail/qmail_1.03-38_i386.deb (--install):
Unterprozess pre-installation script gab den Fehlerwert 1 zurück
Fehler traten auf beim Bearbeiten von:
/tmp/qmail/qmail_1.03-38_i386.deb
in der etc/inetd.conf steht zwar was von smtp aber davor ist ein Raute.
Apache, mysql etc läufen einwandfrei.

Angie
19.12.06, 22:02
Hallo,

der Grund ist die Hardware und die grosse Auswahl an Servern und deren so sehr verschiedenen Konfigurationen.

Deshalb machen wir einen Allroundkernel der mit allen Maschinen funktioniert.
Obwohl hier 'einer' nicht das richtige Wort ist.
Wir haben:
2.4. mit grsec und ohne grsec für ipv4 und ipv6 und diese dann nochmal mit und ohne Hyperthreading
2.6 dann wie oben mit dem 64 bit Support usw.

Der 2.6. default, wenn ich mich genau erinnere, wurde nicht installiert weil die eth0 und eth1 bei den Servern mit zwei Netzwekkarten einfach umdreht und so der Server nicht mehr pingt.


Grüsse,
Angie

Michael
19.12.06, 13:24
Hallo,
hatte das Debian Sarge Image bei mir auf dem Server installiert und festgestellt das es noch ein 2.4 Kernel ist. Wollte dann per apt-get auf einen 2.6 umsteigen. Aber so wie es scheint ist ein selbst gemachter Kernel drauf. Wenn der Standard Debiankernel drauf wär würde man ja über apt-get auch die Sicherheitsupdates bekommen .
Hat das einen bestimmten Grund das ein Kernel von OVH drauf ist ?