We are in the process of migrating this forum. A new space will be available soon. We are sorry for the inconvenience.

pptpd


deiszner
01.01.11, 16:32
Dieser Hinweis

iptables -t nat -A POSTROUTING -o eth0 -s 192.168.0.0/24 -j SNAT --to meineserverip

hat mir sehr geholfen - danke :-)


AAABER: das ganze ist ja nicht verschlüsselt - wie sorge ich für eine verschlüsselte Verbindung?

gruß

Sebastian

Jusic
14.04.10, 06:31
Es funktioniert! Die merkwürdige Gateway scheint normal zu sein der Fehler lag woanders:

iptables -t nat -A POSTROUTING -o eth0 -s 192.168.0.0/24 -j SNAT --to failoverIP

Jusic
14.04.10, 05:46
Hallo,

ich habe auf meinem Debian Server pptpd installiert und eingerichtet. Meine configs sehen folgengermaßen aus:

# Dies ist die IP des Servers. Diese IP erhält der Client als Standard Gateway.
localip 192.168.0.5

# Hier kann der IP Adressbereich für die Clients angegeben werden. Diese IP Adressen erhalten die Clients.
remoteip 192.168.0.10-23

Ich kann von meinem Windows XP auch problemlos zum Server verbinden jedoch richtet Windows seine eigene IP als Gateway ein sprich:

route print

Aktive Routen:
Netzwerkziel Netzwerkmaske Gateway Schnittstelle Anzahl
0.0.0.0 0.0.0.0 192.168.0.10 192.168.0.10 1

Weshalb selbstverständlich nichts funtioniert. An Services die auf dem Server laufen also z.B. lighttpd komme ich ran http://192.168.0.5:81. Die DNS Namesauflösung funktioniert auch. Das manuelle Änderung der Route schlägt fehl.

route CHANGE 0.0.0.0 MASK 0.0.0.0 192.168.0.5 METRIC 1 IF 3
Die angegebene Route wurde nicht gefunden.

Was ist da los?

Gruß
Jusic