We are in the process of migrating this forum. A new space will be available soon. We are sorry for the inconvenience.

PHPBB3 + SEO = Ich werde Wahnsinnig!


mallefix
27.12.09, 22:32
Problem hat sich geklärt. Ich hätte von anfang an eine premodded version nehmen müssen. Nachträglich gibt es probleme mit den mods.
Somit ist das Problem wohl gelöst.

wirt
27.12.09, 22:23
In deinem Forum Verzeichnis ist auch eine .htaccess Datei mit Folgendem Inhalt

--------------------------------------

Order Allow,Deny
Deny from All



Order Allow,Deny
Deny from All


RewriteEngine on
#if your forum is in http://www.domain.tld/forum/ replace with RewriteBase /forum/
RewriteBase / -->WENN DEIN ORDNER FORUM IST DANN /FORUM/ HIER HINTER UND ES KLAPPT<--

RewriteRule ^(.*)-f([0-9]*)/(.*)-t([0-9]*)-s([0-9]*).html viewtopic.php?f=$2&t=$4&start=$5&%{QUERY_STRING} [L]
RewriteRule ^(.*)-f([0-9]*)/(.*)-t([0-9]*).html viewtopic.php?f=$2&t=$4&%{QUERY_STRING} [L]
RewriteRule global/(.*)-t([0-9]*).html ./viewtopic.php?f=1&t=$2&%{QUERY_STRING} [L]
RewriteRule ^(.*)-f([0-9]*)/index-s([0-9]*).html viewforum.php?f=$2&start=$3&%{QUERY_STRING} [L]
RewriteRule ^(.*)-f([0-9]*)/ viewforum.php?f=$2&%{QUERY_STRING} [L]
RewriteRule ^(.*)-f([0-9]*) viewforum.php?f=$2&%{QUERY_STRING} [L]
------------------------------------

So habe ich vor paar Stunden noch das Problem gelöst.

mallefix
27.12.09, 16:33
Hallo liebe Gemeinde.

Ich hoffe sehr, dass es hier jemanden gibt, der sich mit SEO auskennt?

Ich habe bei mir auf dem Basis-Paket (shared hosting), PHPBB 3.0.6 und (u.a.) SEO-Mod erfolgreich installiert.
Diesen habe ich hiervon bezogen:
phpBB SEO Ultimate SEO URL

Inzwischen kann man sagen, ich darf bald in's Irrenhaus gehen.
Denn egal wie ich was in welcher Reihenfolge mache:
Ich bekomme ständig einen 403 Forbidden Seitenfehler, sowie ich das Mod-Rewrite aktiviere.

Ja gut dachte ich, wird wohl CHMOD-Mäßig irgendwas falsch eingestellt sein. Kann aber nicht, da ich alles exakt wie hier habe:
CHMOD Permissions.

Dann hieß es, wie ich gestern nachlas, man solle paar Stunden warten, nachdem man die .htaccess hochlud.
Auch dass machte ich.
Mit dem Erfolg dass ich auf einmal gar keinen Link mehr im Forum anklicken konnte. (Irgendwas mit "leitet die Anfrage so um, dass sie nie beendet werden kann"...)

OVH macht mir Angst ehrlich gesagt. Also entweder kann die (Website-) Anfrage nicht bearbeitet werden oder ich bekomme einen 403 Forbidden Fehler.


Ich brauche echt Hilfe und hoffe sie hier zu finden.

Support von beiden Seiten (seo-url/ovh) schrieb ich bereits an und beide können mir nicht viel dazu schreiben. -.-"

Wäre für jeden Tipp/Hinweis sehr dankbar!

LG mallefix


EDIT:
Kann es vielleicht wirklich so sein, dass OVH lange braucht um die .htaccess zu aktualisieren bei solchen heftigen Umstellungen?
Und wenn es so ist, wie lange muss ich denn jedesmal warten bis die Änderungen aktiv werden?
Denn wenn ich den benötigten Sourcecode entferne wird es ja sofort wieder aktiv (das forum also anklickbar etc pp).
Alles seeehr komisch. ^^