We are in the process of migrating this forum. A new space will be available soon. We are sorry for the inconvenience.

pptpd (VPN) Debian Howto


Kingpin90
11.10.09, 14:03
kannst du die denn von deinem server aus anpingen oder mal eine datei mit wget ziehen? vieleicht ist das nur ein internes routing problem bei ovh.

schlueti
11.10.09, 12:44
der Witz ist, der Link oben geht und einige andere Server bei OVH die ich so kenne gehn auch, blos einige halt nicht...

Total komisch Das irgendwie^^

Kingpin90
11.10.09, 12:33
http://link.wieder.entfernt

die liegt auch bei ovh, kannst du die auch nicht aufrufen?

schlueti
11.10.09, 02:33
z.B. Forum.ovh.de^^

Halt alle Pages die im OVH Netz sind lassen sich nicht per VPN öffnen

Kingpin90
11.10.09, 02:10
also ich habe die seiten getestet die auf dem server von meinem arbeitgeber liegen und die funktionieren. welche seiten gehen denn nicht?

schlueti
11.10.09, 02:00
Ja, als Telekom Kunde geht Youtube sogar um einiges schneller über OVH, blos sind doch schon recht viele Seiten bei OVH gehostet, die alle nicht gehen...
Das Port forwarding kannst einfach mit IPTables machen, funktioniert prima

MfG

Kingpin90
11.10.09, 01:40
Zitat Zitat von schlueti
Es geht komischerweise echt gar nicht das Forum über den VPN Tunnel zu öffnen, hab da nun schon so ziemlich alles versucht... :-(
Habe nun zusätzlich noch einen Proxy installiert der nur über VPN zu erreichen ist, aber ist dadurch dann noch viel lahmer...
Hat einer ne Idee wie man das lösen kann? Komme da einfach nicht weiter....
das seint sich aber nur auf das forum und die seiten von ovh zu beschränken. bei ovh gehostete seiten lassen sich aufrufen. was die geschwindigkeit betrifft habe ich keinen grund zu klagen. sogar youtube funktioniert bei mir.

mein einziges problem ist, das ich ports per nat an den client weiterleiten möchte...

schlueti
11.10.09, 01:16
Es geht komischerweise echt gar nicht das Forum über den VPN Tunnel zu öffnen, hab da nun schon so ziemlich alles versucht... :-(
Habe nun zusätzlich noch einen Proxy installiert der nur über VPN zu erreichen ist, aber ist dadurch dann noch viel lahmer...
Hat einer ne Idee wie man das lösen kann? Komme da einfach nicht weiter....

Gulaschkanone
10.10.09, 20:26
kann einer bitte noch mal die links zu den configs posten, die gehen nimmer

Kingpin90
10.10.09, 16:20
Wie kann ich denn einen Port an den Client weiterleiten? Müsste doch sicherlich irgendwie mit "ip route add" gehen, nur wie....

deiszner
24.08.09, 21:05
ok - es geht.

aber:

* es ist schweinelangsam
* er nörgelnt herum, dass nicht genug IP-Adressen verfügbar sind
* z.b. http://forum.ovh.de kann er nicht aufrufen -es dauert ewig und passiert nix

Wie kann ich dort das Logging anschalten ?

deiszner
24.08.09, 21:01
Welche Einstellungen verwendest Du bei Windows für das VPN ?

sebo1990
20.08.09, 11:11
Code:
apt-get install pptpd
Danach Configs bearbeiten:

Code:
/etc/ppp/pptpd-options
Beispiel: http://nopaste.com/p/a217Xu47X

und

Code:
/etc/pptpd.conf
Beispiel: http://nopaste.com/p/ayyZzfbcl

Benutzer hinzufügen
Code:
/etc/ppp/chap-secrets
user1 pptpd pwuser1 *

statt dem * kann auch eine bestimmte ip für den Client verwendet werden.

pptpd neustarten:
Code:
/etc/init.d/pptpd restart
ipforwarding aktivieren:
Code:
echo 1 > /proc/sys/net/ipv4/ip_forward
und noch ein paar Befehle für die Firewall
Code:
iptables -A FORWARD -m state --state ESTABLISHED,RELATED,NEW -j ACCEPT
iptables -t nat -A POSTROUTING -o eth0 -j MASQUERADE
iptables -P OUTPUT ACCEPT
Das sollte alles sein