We are in the process of migrating this forum. A new space will be available soon. We are sorry for the inconvenience.

PHP Update


DReffects
18.02.10, 18:25
Ok problem behoben.

Ich hab einfach mit
Code:
yum remove php-sqlite2
php-sqlite entfernt. Dadurch entfernt man zwar gleichzeitig auch den Plesk 9 Sitebuilder aber der ist ohnehin für mich müll

Ich bin auf einem Centos 5 Plesk 9 gerät

Hoffe geholfen zu haben

DReffects
18.02.10, 17:40
bist du hier weitergekommen?

ich hab genau den gleichen fehler:

Code:
--> Finished Dependency Resolution
php-sqlite2-5.1.6-200705230938.i386 from installed has depsolving problems
  --> Missing Dependency: php <= 5.2.0 is needed by package php-sqlite2-5.1.6-200705230938.i386 (installed)
Error: Missing Dependency: php <= 5.2.0 is needed by package php-sqlite2-5.1.6-200705230938.i386 (installed)

chibisuke
12.08.09, 10:38
it looks like caching-nameserver is expecting a specific bind version to be installed.

maybe try updating caching-nameserver instead of bind could resolve the problem.

Code:
yum update caching-nameserver
-------------

Sieht aus als erwartet "caching-nameserver" eine spezifische version von bind.

Ich würde mal versuchen caching-nameserver anstatt bind zu upgraden. bind müsste er ja dann theoretisch automatisch mitziehen

Code:
yum update caching-nameserver

JanoschG
04.08.09, 16:27
dort kommt ebenfalls diese meldung:

[root@ks37576 ~]# yum update bind
Loading "installonlyn" plugin
Setting up Update Process
Setting up repositories
Reading repository metadata in from local files
Excluding Packages in global exclude list
Finished
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package bind.i386 30:9.3.4-10.P1.el5_3.3 set to be updated
--> Running transaction check
--> Processing Dependency: bind-libs = 30:9.3.4-10.P1.el5_3.3 for package: bind
--> Processing Dependency: bind = 30:9.3.3-10.el5 for package: caching-nameserver
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package bind-libs.i386 30:9.3.4-10.P1.el5_3.3 set to be updated
--> Running transaction check
--> Processing Dependency: bind = 30:9.3.3-10.el5 for package: caching-nameserver
--> Processing Dependency: bind-libs = 30:9.3.3-10.el5 for package: bind-utils
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package bind-utils.i386 30:9.3.4-10.P1.el5_3.3 set to be updated
--> Running transaction check
--> Processing Dependency: bind = 30:9.3.3-10.el5 for package: caching-nameserver
--> Finished Dependency Resolution
Error: Missing Dependency: bind = 30:9.3.3-10.el5 is needed by package caching-nameserver

mathias
04.08.09, 15:53
Hallo,

yum update bind bringt auch nichts?
Muss mich aber über die Fehlermeldung wundern, da BIND auf jeden Fall schon installiert ist... sonst würde Plesk nicht funzen.

Mathias

JanoschG
04.08.09, 14:48
ok, ich hab nun nur noch folgenden fehler :

Error: Missing Dependency: bind = 30:9.3.3-10.el5 is needed by package caching-nameserver


Da die andere meldung nur für den Sitebuiler ist, den ich eh nicht nutzte.

mathias
04.08.09, 14:47
Hallo,

mit
yum update paketname
kann man einzelne Pakete updaten...

Mathias

JanoschG
04.08.09, 14:36
also wenn ich nun nach der anleitung von Panels gehe steht dort :

wget -q -O - http://www.atomicorp.com/installers/atomic |sh

and then just run:

yum update

schön und gut, das hat auch geklappt, wenn ich nun allerdings yum update mache, bekomme ich den fehler:

Error: Missing Dependency: bind = 30:9.3.3-10.el5 is needed by package caching-nameserver
Error: Missing Dependency: php <= 5.2.0 is needed by package php-sqlite2

mathias
04.08.09, 14:28
Hallo,

wenn du die Paketquellen wie hier beschrieben updatest:
http://www.atomicorp.com/channels/plesk/ (Readme öffnen) und
yum update
absetzt, könnte das zum Erfolg führen.
Angaben wie immer ohne Gewähr

Mathias

JanoschG
04.08.09, 13:55
Weil ich hab direkt auf der Plesk seite auch gesehen, das das Plesk 8.6 auf jeden fall mit der PHP Version 5.2.6 läuft. Dieses würde mir auch reichen.

JanoschG
04.08.09, 13:50
In meinem fall ist das Centos 5.2 mit Plesk 8.6 installiert.

Leider brauch mein CMS Update die PHP Version 5.2 bis aufwärts, und ich komme da nicht wirklich weiter im moment.

mathias
04.08.09, 13:45
Hallo,

teils abhängig ist die Vorgehensweise auch von dem installierten OS. Um welches handelt es sich in Deinem Fall?

Mathias

JanoschG
03.08.09, 15:41
Hallo ihr lieben,

vielleicht könnt ihr mir helfen.
Ich hab nen Isgenug Server, allerdings die PHP Version 5.1.6. Ich möchte nun auf eine Aktuellere Version updaten, allerdings, irgendwie will das ganze noch nicht so wirklich.

Ich bin in sachen php update nun etwas überfragt, und vielleicht kann mir hier jemand helfen, oder erklären, wie genau ich dieses update durchführen muss.

Ich habe das ganze schon einmal mit
# wget ftp://xmlsoft.org/libxml2/libxml2-2.7.3.tar.gz
# tar xzvf libxml2-2.7.3.tar.gz
# cd libxml2-2.7.3
# ./configure
# make
# su -c “make install”

# wget http://uk2.php.net/get/php-5.2.9.tar...php.net/mirror
# tar zxvf php-5.2.9.tar.gz
# cd php-5.2.9
# ./configure –enable-soap
# make
# su -c “make install”

versucht, doch leider hat dieses nicht wirklich funktioniert. Die 5.1.6 ist auch nach Server neustart noch weiter vorhanden.

Vielleicht kann mir jemand helfen.

Mit freundlichen Grüßen,
Janosch Goerke