We are in the process of migrating this forum. A new space will be available soon. We are sorry for the inconvenience.

2 Domains auf RPS schicken + ReverseDNS


kenshin
30.09.09, 00:03
im Manager und im Zonecheck der DENIC sieht nun alles gut aus, dasselbe eben nochmal mit ner .eu Domain gemacht und scheint nun soweit zu klappen, jedenfalls wenn die üblichen Wartezeiten durch sind und die Domains von überall erreichbar.

Danke an Felix und Mathias

kenshin
29.09.09, 19:45
stimmt, da war was, gestern noch strikt nach Anleitung vorgegangen und heute schon wieder vergessen das die Serial auch nen Zweck hatte ... ich und mein Siebhirn

ok @ durch . ersetzt und serial um 1 erhöht, gespeichert, bind neugestartet.

kro
29.09.09, 19:32
kenshin wrote:
>> @ 86400 in soa r28606.ovh.net. admin@newhope-ev.de. (


der SOA darf kein "@" enthalten, bitte durch einen "." ersetzen

>> 2009092801 ; serial, todays date+todays


Die serial muss bei jeder änderung der Zonendatei erhöht werden, damit bind
weiss dass es änderungen gab. Falls du die Zone also von hand editierst, musst
du auch die serial erhöhen (einfach +1 machen)
--
Felix
OVH Team

mathias
29.09.09, 19:28
Hallo,

alles klar, das ist in Ordnung, da bisher unter "Sekundärer-DNS" immer noch nicht die Domain eingetragen war. Das habe ich jetzt für Dich nachgeholt und eigentlich sollten die neuen DNS in ca. 1/2 Stunde ohne Fehlermeldung eingetragen werden können... nachdem sich sdns1.ovh.net die Zone von Deinem Server kopiert hat.

Mathias

kenshin
29.09.09, 19:25
nur damit wir nicht aneinander vorbeireden oder ich nicht was grundlegendes übersehen/vergessen hab, das Zonenfile sieht aktuell so aus:
$TTL 14400
@ 86400 IN SOA r28606.ovh.net. admin@newhope-ev.de. (
2009092801 ; serial, todays date+todays
86400 ; refresh, seconds
7200 ; retry, seconds
3600000 ; expire, seconds
86400 ) ; minimum, seconds
newhope-ev.de. 86400 IN NS r28606.ovh.net.
newhope-ev.de. 86400 IN NS sdns1.ovh.net.
ns1 IN A 87.98.186.239
ns2 IN A 213.251.188.140
newhope-ev.de. IN A 87.98.186.239
newhope-ev.de. IN MX 0 newhope-ev.de.
mail IN CNAME newhope-ev.de.
www IN CNAME newhope-ev.de.
also letzlich ns1.newhope-ev.de durch den Bezeichner des Servers ersetzt und bind9 neugestartet. Scheinbar cached der aber noch, ein dig newhope-ev.de lokal aufm server bringt mir immer noch ns1.newhope-ev.de raus.

Der Vorgang im Manager lief nun auf den bereits bekannten Fehler hinaus:

Derzeitiger Zustand: Fehler
Nachricht: Fehler beim Updaten des Domainnamens: ERROR: No SOA record found on server (sdns1.ovh.net./213.251.188.140)

mathias
29.09.09, 19:04
Hallo,

jepp, nach einer Änderung der Zone ist immer ein Neustart des BIND-Nameservers notwendig.
Das liest sich also schonmal besser

Mathias

kenshin
29.09.09, 18:39
ok hab im zonenfile umgestellt auf den Namen des Servers , scheinbar braucht er auch nach nem bind-restart nen Moment bis er das kapiert hat. Allerdings funktioniert nun im Manager im Menü der Domain das Ändern der DNS der Domain auf r28606.ovh.net und sdns1.ovh.net beziehungsweise er hat den Vorgang gestartet, was vorher nicht ging

mal abwarten...

Mühsam nährt sich das Eichhörnchen ...

mathias
29.09.09, 18:11
Hallo,

die Denic-Fehlermeldung ist darauf zurückzuführen, dass der sekundäre DNS die Domain noch nicht kennt.
Aber bevor du die Domain unter "Dienstleistungen" -> "Sekundär-DNS" einträgst, muss die Zone korrekt sein. So lange aber ns1.newhope-ev.de nicht existiert/pingt/auf Deinen Server zeigt, ist das nicht der Fall.
Zuerst müsste man also das Problem "Warum funktioniert ns1.newhope-ev.de nicht" angehen.
Aber einfacher wäre es, als primären DNS zunächst den Namen des Servers zu verwenden.

Mathias

kenshin
29.09.09, 16:07
zeigt er laut dem Zonefile nicht bereits auf den Server bzw dessen MainIP? oder liegt ein Logikfehler von mir vor?

e: also zunächstmal ns1.newhope-ev.de durch den hostnamen des rps servers ersetzen?

E2:
Zonecheck Denic sagt aktuell:

ZoneCheck: newhope-ev.de.
Zoneninformation
Zone newhope-ev.de.
Primary ns1.newhope-ev.de. 87.98.186.239
Secondary sdns1.ovh.net. 213.251.188.140
Testresultate
---- schwerer Fehler ----
f: Kein SOA Eintrag auf dem Server gefunden
* sdns1.ovh.net./213.251.188.140
Endresultat
FEHLER

mathias
29.09.09, 15:47
Hallo,

die Zone sieht jetzt anders aus, aber der gewünschte primäre NS funktioniert nicht:

$ host ns1.newhope-ev.de
Host ns1.newhope-ev.de not found: 3(NXDOMAIN)

$ ping ns1.newhope-ev.de
ping: unknown host $

Besser mal zunächst den Servernamen verwenden und eine kurze Rückmeldung geben... oder schauen, dass ns1.newhope-ev.de auf den Server zeigt.

Mathias

kenshin
29.09.09, 15:38
die Zone aufm Server ist korrigiert, danach wollte ichs im Manager auf das von dir beschriebene ändern, dann kommt dieser Fehler.

wie gesagt "newhope-ev.de" ist aktuell noch an ein Start1M gekoppelt (was ich ja nicht mehr will deswegen solls auf den RPS), da kann ich zwar über "DNS Server ändern" dann zwar die Server abändern, werde aber mit dem DENIC Zonecheck konfrontiert der nicht durchläuft.

Zonenfile (auf dem RPS):
$TTL 14400
@ 86400 IN SOA ns1.newhope-ev.de. admin@newhope-ev.de. (
2009092801 ; serial, todays date+todays
86400 ; refresh, seconds
7200 ; retry, seconds
3600000 ; expire, seconds
86400 ) ; minimum, seconds
newhope-ev.de. 86400 IN NS ns1.newhope-ev.de.
newhope-ev.de. 86400 IN NS sdns1.ovh.net.
ns1 IN A 87.98.186.239
ns2 IN A 213.251.188.140
newhope-ev.de. IN A 87.98.186.239
newhope-ev.de. IN MX 0 newhope-ev.de.
mail IN CNAME newhope-ev.de.
www IN CNAME newhope-ev.de.
Screen aus dem "DNS Server ändern" Menü bei der Domain im Manager:
http://demo.ovh.net/de/4c67203ec236e...792e7e48fb424/
Screen aus DNS Server Menü beim RPS:
http://demo.ovh.net/de/bf17aeed456b8...6000e189afa2c/

Die Domain "hängt" auf ns15 und dns15 durch das Start1M und ich bekomm se da auch grade nicht weg.

Stefan
29.09.09, 14:41
Willst du die DNS-Server ändern oder die Domain unter Sekundär-DNS eintragen und bekommst den Fehler ?
Als erstes die Zone berichtigen mit den NS-Einträgen.

Stefan

kenshin
29.09.09, 14:22
newhope-ev.de existiert bereits in unseren primären DNS, Sie dürfen 87.98.186.239 nicht als primär parametrieren und der richtige Nameserver lautet nicht r28606.ovh.net
kommt dann wenn ichs im Menü des Servers mache.

die Domain "hängt" quasi noch in der Verwaltung fest und läuft auf ns15 und dns15 ... ich kann via Menü die Zone zwar resetten aber im Gegensatz zu einer .eu Domain kann ich die Zone nicht löschen, der Menübutton "Zone löschen" taucht nicht auf.

Muss ich jetzt erst das vorhandene Start1M komplett deaktivieren/kündigen damit ich die Domain via dem neuen RPS verwalten kann?

Stefan
29.09.09, 13:06
Nutze als 2 NS den sdns1.ovh.net -> Aktivierung: Server auswählen -> Dienstleistungen -> Sekundär-DNS ... Domain ohne www eintragen...

Dies entsprechend in der Zone ändern und den Server direkt als NS eintragen:
NS1: r28606.ovh.net
NS2: sdns1.ovh.net

Stefan

kenshin
28.09.09, 21:23
ich klinke mich hier mal ein in den etwas älteren erledigten Thread, allerdings liegt der Fall bei mir etwas anders, bisher war die Domain einfach im Manager verwaltbar (nen Start1M), nun soll das ganze über den RPS laufen.

Zonenfile sieht wie folgt aus:


$TTL 14400
@ 86400 IN SOA ns1.newhope-ev.de. admin@newhope-ev.de. (
2009092801 ; serial, todays date+todays
86400 ; refresh, seconds
7200 ; retry, seconds
3600000 ; expire, seconds
86400 ) ; minimum, seconds
newhope-ev.de. 86400 IN NS ns1.newhope-ev.de.
newhope-ev.de. 86400 IN NS ns15.ovh.net.
ns1 IN A 87.98.186.239
ns2 IN A 213.251.128.134
newhope-ev.de. IN A 87.98.186.239
localhost.newhope-ev.de. IN A 127.0.0.1
newhope-ev.de. IN MX 0 newhope-ev.de.
mail IN CNAME newhope-ev.de.
www IN CNAME newhope-ev.de.
von lokal
:# nslookup newhope-ev.de
Server: 127.0.0.1
Address: 127.0.0.1#53
Name: newhope-ev.de
Address: 87.98.186.239


r28606:# dig newhope-ev.de

; <<>> DiG 9.5.1-P3 <<>> newhope-ev.de
;; global options: printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 13405
;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 2, ADDITIONAL: 3

;; QUESTION SECTION:
;newhope-ev.de. IN A

;; ANSWER SECTION:
newhope-ev.de. 14400 IN A 87.98.186.239

;; AUTHORITY SECTION:
newhope-ev.de. 86400 IN NS ns15.ovh.net.
newhope-ev.de. 86400 IN NS ns1.newhope-ev.de.

;; ADDITIONAL SECTION:
ns1.newhope-ev.de. 14400 IN A 87.98.186.239
ns15.ovh.net. 172681 IN A 213.251.128.134
ns15.ovh.net. 172681 IN AAAA 2001:41d0:1:1986::1

;; Query time: 0 msec
;; SERVER: 127.0.0.1#53(127.0.0.1)
;; WHEN: Mon Sep 28 21:16:35 2009
;; MSG SIZE rcvd: 151
dann jedoch:

r28606:# dig newhope-ev.de @ns15.ovh.net

; <<>> DiG 9.5.1-P3 <<>> newhope-ev.de @ns15.ovh.net
;; global options: printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 33893
;; flags: qr aa rd; QUERY: 1, ANSWER: 1, AUTHORITY: 2, ADDITIONAL: 4
;; WARNING: recursion requested but not available

;; QUESTION SECTION:
;newhope-ev.de. IN A

;; ANSWER SECTION:
newhope-ev.de. 86400 IN A 213.186.33.5

;; AUTHORITY SECTION:
newhope-ev.de. 86400 IN NS ns15.ovh.net.
newhope-ev.de. 86400 IN NS dns15.ovh.net.

;; ADDITIONAL SECTION:
ns15.ovh.net. 86400 IN A 213.251.128.134
ns15.ovh.net. 86400 IN AAAA 2001:41d0:1:1986::1
dns15.ovh.net. 86400 IN A 213.251.188.134
dns15.ovh.net. 86400 IN AAAA 2001:41d0:1:4a86::1

;; Query time: 0 msec
;; SERVER: 213.251.128.134#53(213.251.128.134)
;; WHEN: Mon Sep 28 21:22:30 2009
;; MSG SIZE rcvd: 181
jetzt heissts einfach warten bis das ganze bei ns15.ovh.net und sonstigen angekommen oder ist bei mir noch ein Fehler in der Konfiguration?

Denn im Manager bei "Shared Hosting > Domains & DNS > DNS-Server" auf ns1.newhope-ev.de und ns15.ovh.net umstellen geht ja auch nicht solange der Denic-Zonecheck noch nicht durchläuft.

ZoneCheck sagt:

ZoneCheck: newhope-ev.de.
Zoneninformation
Zone newhope-ev.de.
Primary r28606.ovh.net. 87.98.186.239
Secondary ns15.ovh.net. 213.251.128.134
Fortschritt
Fortschritt Tests Geschwindigkeit Zeit
13 --.-- N/A

Stimmigkeit der Serialnummer mit dem Primary Nameserver (IP=213.251.128.134)
Testresultate
---- schwerer Fehler ----
f: [TEST SOA Eintrag verfügbar]: DNS Timeout

* r28606.ovh.net./87.98.186.239

coresec
04.05.09, 20:38
Zur Info : läuft alles, danke für Hilfe!

coresec
04.05.09, 18:03
Eine Frage noch :

Wielange dauert es, bis Nameserverchanges global verbreitet sind (alter->neuer Nameserver)

Wielange dauert es, bis CNAME Records geupdated wurden.

0x33:~# dig www.0x33.de @dns15.ovh.net

; <<>> DiG 9.5.1-P1 <<>> www.0x33.de @dns15.ovh.net
;; global options: printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 38186
;; flags: qr aa rd; QUERY: 1, ANSWER: 2, AUTHORITY: 2, ADDITIONAL: 4
;; WARNING: recursion requested but not available

;; QUESTION SECTION:
;www.0x33.de. IN A

;; ANSWER SECTION:
www.0x33.de. 86400 IN CNAME 0x33.de.
0x33.de. 86400 IN A 94.23.50.102
Natürlich auf den NS von ovh schon da, Domain noch auf alter IP erreichbar.

Ebenso www.silkroad2.de :

0x33:~# dig www.silkroad2.de @dns15.ovh.net

; <<>> DiG 9.5.1-P1 <<>> www.silkroad2.de @dns15.ovh.net
;; global options: printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 22144
;; flags: qr aa rd; QUERY: 1, ANSWER: 2, AUTHORITY: 2, ADDITIONAL: 4
;; WARNING: recursion requested but not available

;; QUESTION SECTION:
;www.silkroad2.de. IN A

;; ANSWER SECTION:
www.silkroad2.de. 86400 IN CNAME silkroad2.de.
silkroad2.de. 86400 IN A 94.23.50.102
silkroad2.de ist bereits auf neuer IP erreichbar, www.silkroad2.de noch net.

Regards

coresec
04.05.09, 17:44
Ok, sorry, läuft nun alles. Musste die Zone-Records noch anpassen, dies hatte ich bei der ganzen Umzieherei heute vergessen. Läuft nun alles wie gewünscht, danke !

Jenstheclown
04.05.09, 17:33
bind9 überhaupt installiert? .. Glaskugel ist in reperatur, etwas mehr informationen, logfiles etc. wären durchaus passend..

Stefan
04.05.09, 17:15
Hast du die Domains auf deinem Server installiert, SOA.. Zone.. ?
Antworten die 2 NS bei Abfrage mit dig oder nslookup ?

Fehler beim zoneCheck der DENIC = das die Zone nicht richtig funktioniert, du kannst den Zonecheck selbst mal ausführen, um genauere Informationen zu sehen.

Stefan

coresec
04.05.09, 17:07
Hallo,

ich habe Domains bei OVH :

0x33.de
silkroad2.de

Diese beiden Domains möchte ich jetzt auf meinem RPS nutzen, habe dafür im Manager versucht die Nameserver zu ändern :

NS1 : r2XYTX.ovh.net
NS2 : sdns1.ovh.net

Ich bekomme aber immer den Fehler : Fehler beim zoneCheck der DENIC

Was mache ich falsch ?