OVH Community, your new community space.

Re: Debian 5.0 Lenny


Bobs
14.03.09, 07:14
danke, klappt

Felix
13.03.09, 16:57
Zitat Zitat von Bobs
Es kann sein das vor dem Lenny upgrade und dem damit verbundenen reboot noch ein älterer netboot kernel lief, ob dieser mit nfs4 konfiguriert war weiß ich nicht nur das cp -a oder -p keine Probleme machten.
Ist nicht vom kernel abhängig, schuld ist die fehlende noacl-Option, die anscheinend noch nicht bis zu allen rps durchgedrungen ist.
Ich habe die Übernahme des parameters für deinen rps mal etwas forciert, nach einem neuerlichen reboot sollte es nun klappen.

Bobs
13.03.09, 16:28
schon passiert

kro
13.03.09, 16:20
Bobs wrote:
> leider nein


dmesg |grep root=

kannst du mir mal die Ausgabe dieses Befehls posten?
--
Felix
OVH Team

Bobs
13.03.09, 16:10
leider nein

~# touch test
~# cp -p test test2
cp: Erhalten der Zugriffsrechte für »test2«: Die Operation wird nicht unterstützt
~# ls test*
test test2
~# uname -a
Linux 2.6.28.4-xxxx-std-ipv4-32 #2 SMP Wed Feb 18 16:34:04 UTC 2009 i686 GNU/Linux
~# uptime
17:13:47 up 9 min, 1 user, load average: 0.03, 0.09, 0.08


Bin jetzt auch erst dazu gekommen es mir nochmal anzuschauen. In der Tat nfs3:

Kernel command line: root=/dev/nfs nfsroot=91.121.191.xx:/filerzxx/rxxxxx,v3,tcp,rsize=8196,wsize=8196,hard,intr,nocto,ac,acre gmin=900,acregmax=900,acdirmin=900,acdirmax=900,re trans=10,timeo=10 rw ip=:::::eth0:dhcp libusual.bias=ub console=tty0 BOOT_IMAGE=rps/bzImage-2.6-xxxx-std-ipv4-32

Es kann sein das vor dem Lenny upgrade und dem damit verbundenen reboot noch ein älterer netboot kernel lief, ob dieser mit nfs4 konfiguriert war weiß ich nicht nur das cp -a oder -p keine Probleme machten.

kro
13.03.09, 14:58
Bobs wrote:
> cp: Erhalten der Zugriffsrechte für »aptitude.pkgstates«: Die Operation
> wird nicht unterstützt


Sollte (nach einem reboot) nun klappen.
--
Felix
OVH Team

Bobs
07.03.09, 08:08
Danke, dann vermute ich bei dem etch image von ovh wurde nfs4 benutzt, durch das upgrade läuft nun aber nfs3. Ich schaus mit später mal an aber anders kann ich es mir im moment nicht erklären denn unter etch lief es.

Enn
07.03.09, 08:00
http://www.bitingbytes.de/cms/?p=30
Dieses Problem hatte ich mit Etch und NFS, vielleicht ist die Ursache die selbe.

Der Umstieg auf Ubuntu hat leider nicht funktoniert, da hier das Image kaputt ist (war?).

Bobs
07.03.09, 07:27
Bei dem update einer rps mit nfs hatte ich ein paar Probleme welche sich aber übers rescue System lösen ließen (mount konnte wegen dem gemounteten nfs root nicht geupdatet werden).
Danach war eigentlich alles in Ordnung bis grade eben per mail dies ankam:

/etc/cron.daily/aptitude:
cp: Erhalten der Zugriffsrechte für »aptitude.pkgstates«: Die Operation wird nicht unterstützt
/etc/cron.daily/standard:
cp: Erhalten der Zugriffsrechte für »passwd.bak«: Die Operation wird nicht unterstützt
cp: Erhalten der Zugriffsrechte für »group.bak«: Die Operation wird nicht unterstützt
cp: Erhalten der Zugriffsrechte für »shadow.bak«: Die Operation wird nicht unterstützt
cp: Erhalten der Zugriffsrechte für »gshadow.bak«: Die Operation wird nicht unterstützt
cp: Erhalten der Zugriffsrechte für »dpkg.status«: Die Operation wird nicht unterstützt

Soweit ich weiß liegt das am Solaris Filer/zfs, unter etch lief ein cp -a jedoch ohne Fehlermeldung durch. Kann mir da jemand einen Tip geben was in etch anders war?

chems
28.02.09, 14:56
update hat perfekt gefunzt wäre sicher auch für neukunden interessant, gleich den lenny zu haben

kro
16.02.09, 15:18
Computerbastler wrote:
> Debian 5.0 Lenny wan komt die offizelle OVH relase (image) raus xd ^^


in -15 Minuten.

(oder andersrum: seit einer Viertelstunde ist es verfügbar)
http://forum.ovh.de/showthread.php?t=5859
--
Felix
OVH Team

Computerbastler
16.02.09, 12:23
wan komt die offizelle OVH relase (image) von Debian 5.0 raus ?

MoD.666
15.02.09, 18:12
Also, Upgrade ist komplett durch, nur bei Ruby gibt es ein paar Probleme (in Verbindung mit Passenger). Weiss zwar noch nicht genau, weshalb, da Ruby in der 1.8 beibehalten wird. Allerdings scheint es irgendwo bei "rake radiant:update" Schwierigkeiten zu geben.

Ansonsten:
- Apache2
- php5
- mysql
- exim, courier
- bind9
etc.

Alles läuft!

kro
15.02.09, 14:50
MoD.666 wrote:
> alle Einträge von etch in lenny. Danach ein
>
> apt-get update && apt-get dist-upgrade


Zur Sicherheit sollten am besten vorher noch apt, dpkg und aptitude selbst
aktualisiert werden:

# vim /etc/apt/sources.list
# aptitude update
# aptitude install aptitude dpkg apt
# aptitude dist-upgrade
--
Felix
OVH Team

schwarzlicht
15.02.09, 14:42
Kommt morgen (siehe MailingListe)

deiszner
15.02.09, 14:37
Zitat Zitat von MoD.666
Moinsen,
OVH war ja so frei und hat seine Mirrors auch schon synchronisiert. Deshalb nutze ich mal den Sonntag (sic!) und tu mir mal ein apt-get dist-upgrade an.

Dazu ändert Ihr per

vi /etc/apt/sources.list

alle Einträge von etch in lenny. Danach ein

apt-get update && apt-get dist-upgrade

und apt legt los. Allerdings sind ein paar händische Bestätigungen erforderlich, da einige Dienste neu gestartet werden müssen.

Bisher alles top und Upgrade läuft!

hmm - ich warte lieber auf ein offizielles image von ovh

MoD.666
15.02.09, 13:38
Moinsen,
OVH war ja so frei und hat seine Mirrors auch schon synchronisiert. Deshalb nutze ich mal den Sonntag (sic!) und tu mir mal ein apt-get dist-upgrade an.

Dazu ändert Ihr per

vi /etc/apt/sources.list

alle Einträge von etch in lenny. Danach ein

apt-get update && apt-get dist-upgrade

und apt legt los. Allerdings sind ein paar händische Bestätigungen erforderlich, da einige Dienste neu gestartet werden müssen.

Bisher alles top und Upgrade läuft!