OVH Community, your new community space.

eigenes os.


echoslider
27.08.07, 17:42
klar.. ich versuche das schon seit mindestens 3 wochen. und ich gebe nie so schnell auf.

ich habe sogar versucht normal über den manager zu installieren. dann im rescue modus nur die /dev/sda... partitionen zu mounten... und dann da zu installen... aber es hat net gefunzt... lag wohl an dem raid0.

und die /dev/md platten konnte ich irgendwie nicht alle mounten in ein verzeichnis . das war ganz komisch. ich probiere das nun nochmal.. vielleicht lassen die sich ja mounten wenn ich nach dem formatieren(nich löschen) reboote.

sledge0303
27.08.07, 08:58
Hallo,

das Howto beschreibt die Installation eines OS OHNE RAID System, ich selbst hab keinen Server wo RAID in der Form möglich ist und aus dem Grund werde ich mich hüten etwas in einem Howto aufzunehmen was nicht selbst getestet werden kann. Normalerweise ist es kein Problem es aufzunehmen, doch das Rescue von OVH entspricht nicht dem was vorher genutzt wurde bei anderen/eigenen Systemen --> siehe GRUB im REscue nicht möglich

Einem anderen User hab ich stichwortartig beschrieben wie er vorgehen musste bei der Installation und es hat geklappt. Mir wurde auch zugesagt bei einer evtl. Abweichunge von meiner Erklärung die Vorgehensweise per Mail zu unterrichten, was leider bis heute nicht passiert ist.

Dementsprechend schwebt die Angelegenheit weiter im Raum. Sorry, deswegen musst mit den Beiträgen in diesem Thread zurecht kommen. Von der Logik kann man nichts falsch machen. Wenn möchtest können wir das hier online, nachvollziehbar für alle, machen und anschließend zusammenfassend in das Howto übernehmen. Muss mich dann darauf verlassen können, dass das dann auch bis zum (bitteren) Ende durchziehst

echoslider
27.08.07, 05:14
also. bei meinem letzten test:ich habe alle partitionen von /dev/sda und /dev/sdb gelöscht. und neu geboot. weil davor kamen dann immer fehler... weil die noch irgendwie mit raid verbunden waren durch /dev/md
naja. danach habe ich alles paritioniert. 3 partitionen. /boot;swap;/

gut dannach habe ich die platten über den rescue modus formatiert mit

mkfs.ext3 sda1
mkfs.ext3 sda3
mkswap /dev/sda2
sync; sync; sync; sync; sync
swapon /dev/sda2
export LC_ALL=C
export LANG=C


danach alles gemountet...(vorher als ich das gemacht habe als die raid platten waren konnte /dev/sda3 nie nach /mnt gemountet werden.

dann das ganze mit debootstrap.. hat funktioniert ohne fehler nach /mnt.
dann proc und devpts ohne fehler gemountet und dann in chroot rein.
da dann auch alles ohne fehler installiert.

dann diese netzwerkdaten verwendet:

Code:
root@ns351587:/home/admin# hostname

ns351587.ovh.net

root@ns351587:/home/admin# cat /etc/network/interfaces

# This file describes the network interfaces available on your system

# and how to activate them. For more information, see interfaces(5).



# The loopback network interface

auto lo

iface lo inet loopback



auto eth0

iface eth0 inet static

        address 91.121.73.63

        netmask 255.255.255.0

        network 91.121.73.0

        broadcast 91.121.73.255

  gateway 91.121.73.254
>>mit deinem letzten BOOTLOGD_ENABLE=Yes natürlich


root@ns351587:/home/admin# cat /etc/resolv.conf

nameserver 127.0.0.1

nameserver 91.121.73.63

nameserver 213.186.33.99

beim kernel nen simbolischen link erzeugt(automatisch) und abfrage ob ich kernel install abbrechen will mit nein beantwortet.

update-grub funzt auch... menu.lst wird neu angelegt und alls auto eingetragen.
der rest geht auch. nur a dem reboot mit netzwerk kernel nicht mehr. bootet nix mehr

sledge0303
26.08.07, 19:54
Das Howto beschreibt jeden Schritt der für die Installation notwendig ist. Wichtig sind vor allen die Netzwerkdaten. Bei der Partitionierung muss darauf geachtet werden, dass das Verzeichnis /boot auf der Partition liegt die als Bootpartition aktiviert wurde. 'update-grub' ist ebenfalls sehr wichtig, muss noch im chroot ausgeführt werden, sonst fährt die Kiste nicht hoch.
Danach mit dem Netzwerkbootkernel den Server hochfahren, GRUB installieren, Boot von HD im Kundenzenter einstellen und danach dürfte es klappen.

Napster
26.08.07, 17:48
hast du das mal so partioniert wie ich beschrieben habe? und dann mit dem howto und damit meine ich ausschliesslich nur mit dem howto von sledge gemacht? hast du vorher die netzwerkdaten gesichert wie im howto beschrieben? wenn du da irgendwas falsch machst oder übersiehst wird es sofort bestraft. welches server angebot hast du? rein informativ. ich weis fragen, fragen und fragen
mfg

echoslider
26.08.07, 15:40
ne also ich habe es den ganzen tag mehrere male versucht. immer das gleiche. alles installiert bla bla... und dann wenn ich reboote (vorher natürlich netboot kernel gewählt) ... oO kein root online. nix. da kommt nix mehr.


hast du icq?

meine nummer is 272401947

Napster
26.08.07, 10:54
Hi echoslider,

Wenn Du genau nach dem Howto von ledge vorgehst, wird es Dir gelingen das OS zu installieren und zum laufen zu bringen. Das kannste mir glauben, weil ich es ein paar mal ausprobiert hatte. Du musst nur jeden kleinen Punkt beachten, sonst wird das nix, bis vll auf die partitionen.
Du kannst deine Platte auch im manager partionieren, wenn es dir damit leichter fällt. d.h. du installierst erstmal irgendein os im manager und partionierst dir dort deine hdd. Im rescue kannst du grub nicht ausführen, das ist aber im howto auch eindeutig beschrieben wie man es macht.
also install dir deine partitionen im manager wie folgt z.b.:
1.) debian 4.0 etch installen
sda1 = XXXXMB / linux (bei mir 5000MB)
sda2 = XXXXMB /home1 free
sda3 = 2000MB swap (sollte immer das doppelte sein wie du ram hast)

wenn es fertig ist gehste genau nach dem howto vor, bis auf dem teil wo die platten partitioniert werden.

Ist der kernel installiert machste nur ein: update-grub
mehr nicht! danach musst du dein system mit diesem kernel booten: 2.6.22.1 x86 &SMP << und keinen anderen. Wenn dann rebootet worden ist mit dem Netbootkernel dann kannste grub erst installieren mit: grub-install /dev/sda

mfg

echoslider
26.08.07, 10:19
hallo. ich möchte gerne ein eigenes os installieren. ein eigenes os weil ich bestimmte sachen im kernel brauche(z.b was für hdd verschlüsseln, module,..) und wenn ich selber einen kernel baue dann wird dieser nicht gebootet sondern der standart kernel. ich habe auch andere zur hilfe gezogen die mehr davon verstehen als ich. auch die haben es nicht geschafft. außerdem habe ich hier irgendwoe gelesen das es besser wäre ein eigenes os remote zu intallieren... weil da der kernel "normal" ist. naja ich habe mich an verschiednee tuts gehalten und die ggf. kombiniert:

http://forum.ovh.de/showthread.php?t=389
http://www.linuxserverforum.de/vb/showthread.php?t=30
http://www.schirmacher.de/display/IN...r+installieren

ich denke ich bin sehr weit gekommen. aber wie ich
Code:
grub-install /dev/sda
ausführen soll weiß ich nicht. denn im rescue modus ist grub ja nicht verfügbar und installieren kann ich das wegen "ro" auch nicht.
und ein reboot brachte den server auch nicht online. die partitionierung habe ich nach schirmacher.de... ca übernommen.
beim kernel bauen tauchen ein paar fehler auf wie das qt nicht gefunden wird. alle versuche qt zu installieren schlagen fehl. ein fertiger kernel.. (hat mal funktioniert das builden) wurde nicht gebootet sondern immer der der schon bei ovh standart war.


meine frage:

>>
wie installiere ich ein eigenes os oder wie "aktiviere" ich einen "normalen" kernel?
<<

ich bin nicht doof. und andere auch nicht die das auf dem root versucht haben. aber alle sind gescheitert und ich weiß nicht weiter. ich sitze schon ca 3 wochen daran und letzte woche am wochenend ohne pause fast 48 stunden.