We are in the process of migrating this forum. A new space will be available soon. We are sorry for the inconvenience.

Bind9 Domain konfigurieren


mathias
18.12.08, 09:33
Danke auch für die Rückmeldung, ebenfalls schöne Feiertage

Mathias

ReduX08
17.12.08, 19:02
Abend,
Der Support hat sich gemeldet (Ist toll das man hier so gut unterstützt wird).

Jetzt habe ich aber eine Frage:
Also der Fehler ist, das ich die falschen IP Adressen für allow-transfer und forwarders drinn habe (habe die default drinn).
Ist die IP: 213.186.33.199 für allow-transfer als auch forwarders zuständig, oder muss ich da noch eine zusätzliche von ovh eintragen?
EDIT:
Habe es gerade selber herausgefunden
Das ist die richtige.
Falls jemand das Problem auch hat: Es lag an der Datei /etc/bind/named.conf.options dort muss bei allow-transfer und forwarders die ip 213.186.33.199 eingetragen sein.

Bedanke mich hier auch nochmal für die nette Hilfe des Supports (auch wenn es etwas länger gedauert hat) und wünsche dem OVH Team ein schönes Weihnachtsfest.

MFG ReduX08

mathias
16.12.08, 09:35
Hallo,

merkwürdig. Wir klären das ab jetzt besser per Mail. Die zur Korrektur notwendigen Schritte wurden eingeleitet. Bitte noch den Supportschlüssel installieren wie hier beschrieben: http://hilfe.ovh.de/DedizierteOvhSchluessel

Mathias

ReduX08
15.12.08, 18:43
Tag,
Aber so steht es ja in meiner Datei drinn, habe auch schon die Seriennummer ein paar mal nach oben gestellt, hier der genaue Eintrag:
$ttl 38400
timo-klein-web.de. IN SOA timo-klein-web.de. account.timo-klein-web.de. (
2008121502
10800
3600
604800
86400 )
timo-klein-web.de. IN NS ks357805.kimsufi.com.
timo-klein-web.de. IN NS ns.kimsufi.com.
timo-klein-web.de. IN A 91.121.146.208
timo-klein-web.de. IN MX 1 ks357805.kimsufi.com.
Dannach gehe ich in den Manager und trage dort die Domain auch noch ein.
Aber beim Zoen Check kommt ja immernoch der Fehler.

MFG ReduX08

mathias
15.12.08, 14:06
Hallo,

ein "dig" liefert folgendes Ergebnis:
----
dig soa timo-klein-web.de @ks357805.kimsufi.com

; <<>> DiG 9.3.4-P1.1 <<>> soa timo-klein-web.de @ks357805.kimsufi.com
; (1 server found)
;; global options: printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 4016
;; flags: qr aa rd; QUERY: 1, ANSWER: 1, AUTHORITY: 2, ADDITIONAL: 0

;; QUESTION SECTION:
;timo-klein-web.de. IN SOA

;; ANSWER SECTION:
timo-klein-web.de. 38400 IN SOA timo-klein-web.de. postmaster.ti
mo-klein-web.de. 2008121101 21600 3600 604800 86400

;; AUTHORITY SECTION:
timo-klein-web.de. 38400 IN NS ns.kimsufi.com.
timo-klein-web.de. 38400 IN NS ks357805.kimsufi.com.

;; Query time: 58 msec
;; SERVER: 91.121.146.208#53(91.121.146.208)
;; WHEN: Mon Dec 15 13:53:57 2008
;; MSG SIZE rcvd: 133
----

Da ich den Inhalt Deiner .hosts-Datei nicht kenne, passe diese bitte einfach wiefolgt an:
----
$ttl 38400
domainname.tld. IN SOA domainname. account.domainname.tld. (
2008121501 <- Den Wert an dieser Stelle so eintragen
10800
3600
604800
38400 )
domainname.tld. IN NS servername.
domainname.tld. IN NS ns.kimsufi.com.
domainname.tld. IN A IP-SERVER
domainname.tld. IN MX 1 servername.
----

Mathias

ReduX08
12.12.08, 21:43
Abend,
Wenn ich sie wieder eintrage und ne Stude warte steht wieder SERVERFAIL.
Habe aber bind9 so konfiguriert wie mir der Support geschrieben hat, igrendwie verstehe ich da jetzt garnichtsmehr

MFG ReduX08

Stefan
12.12.08, 13:37
Ist die Domain noch bei Sekundär-DNS eingetragen im Manager v3 ?

Stefan

ReduX08
12.12.08, 13:25
Tag,
Mit Hilfe des Supports habe ich es nun hinbekommen (Scheinbar war der MX wert nicht richtig).
ns.kimsufi.com kennt jetzt meine Domain und gibt NOERROR aus.

Aber bei Denic heißt es immernoch kein SOA Eintrag vorhanden auf ns.kimsufi.com.

Aber die Domain kennt er doch (laut dig), warum will das ganze dann nicht?

MFG ReduX08

ReduX08
10.12.08, 19:12
Tag,
E-Mail ist raus, danke für die Hilfe.

MFG ReduX08

mathias
10.12.08, 15:33
Hallo,

falls noch nicht geschehen, bitte einmal per Mail den Server/- bzw. Domainnamen mitteilen. Ist wohl am Einfachsten.

Mathias

ReduX08
10.12.08, 15:20
Tag,
Ja die Domain ist im Manager unter Sekundär-DNS eingetragen, bei dem Befehl kommt:
; <<>> DiG 9.3.4-P1.1 <<>> any domain @ns.kimsufi.com
; (1 server found)
;; global options: printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 19532
;; flags: qr rd; QUERY: 1, ANSWER: 0, AUTHORITY: 13, ADDITIONAL: 14

;; QUESTION SECTION:
;domain. IN ANY

;; AUTHORITY SECTION:
. 474866 IN NS c.root-servers.net.
. 474866 IN NS d.root-servers.net.
. 474866 IN NS e.root-servers.net.
. 474866 IN NS f.root-servers.net.
. 474866 IN NS g.root-servers.net.
. 474866 IN NS h.root-servers.net.
. 474866 IN NS i.root-servers.net.
. 474866 IN NS j.root-servers.net.
. 474866 IN NS k.root-servers.net.
. 474866 IN NS l.root-servers.net.
. 474866 IN NS m.root-servers.net.
. 474866 IN NS a.root-servers.net.
. 474866 IN NS b.root-servers.net.

;; ADDITIONAL SECTION:
a.root-servers.net. 603916 IN A 198.41.0.4
a.root-servers.net. 603916 IN AAAA 2001:503:ba3e::2:30
b.root-servers.net. 603916 IN A 192.228.79.201
c.root-servers.net. 603916 IN A 192.33.4.12
d.root-servers.net. 603916 IN A 128.8.10.90
e.root-servers.net. 603916 IN A 192.203.230.10
f.root-servers.net. 603916 IN A 192.5.5.241
f.root-servers.net. 603916 IN AAAA 2001:500:2f::f
g.root-servers.net. 603916 IN A 192.112.36.4
h.root-servers.net. 603916 IN A 128.63.2.53
h.root-servers.net. 603916 IN AAAA 2001:500:1::803f:235
i.root-servers.net. 603916 IN A 192.36.148.17
j.root-servers.net. 474866 IN A 192.58.128.30
j.root-servers.net. 474866 IN AAAA 2001:503:c27::2:30

;; Query time: 4 msec
;; SERVER: 213.186.33.199#53(213.186.33.199)
;; WHEN: Wed Dec 10 15:16:28 2008
;; MSG SIZE rcvd: 507
raus.

MFG ReduX08

Stefan
09.12.08, 22:13
Hast du deine Domain im Manager v3 unter Sekundär-DNS anlegt?

Was gibt dir dig any domain @ns.kimsufi.com aus?

Stefan

ReduX08
09.12.08, 17:58
Tag,
Irgendwas ist da glaube ich falsch eingestellt.
Wenn ich dig MEINEDOMAIN @MEINSERVER eingebe, kommt:
; <<>> DiG 9.3.4-P1.1 <<>> MEINEDOMAIN @ksxxxxxx.kimsufi.com
; (1 server found)
;; global options: printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 20289
;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 2, ADDITIONAL: 1

;; QUESTION SECTION:
;MEINEDOMAIN. IN A

;; ANSWER SECTION:
MEINEDOMAIN. 38400 IN A 91.xxx.xxx.xxx

;; AUTHORITY SECTION:
MEINEDOMAIN. 38400 IN NS ns.kimsufi.com.
MEINEDOMAIN. 38400 IN NS ksxxxxxx.kimsufi.com.

;; ADDITIONAL SECTION:
ns.kimsufi.com. 161339 IN A 213.186.33.199

;; Query time: 0 msec
;; SERVER: 91.xxx.xxx.xxx#53(91.xxx.xxx.xxx)
;; WHEN: Tue Dec 9 17:51:22 2008
;; MSG SIZE rcvd: 118
Nach 10Minütigem warten weiß aber ns.kimsufi.com immernoch nichts davon.
Im Manager muss ich ja nur bei dem ded. Server die Sek. DNS mit meiner Domain eintragen?

MFG ReduX08

mathias
09.12.08, 15:18
Hallo,

es wurde nicht unbedingt etwas falsch gemacht.
MOMENTAN kennt ns.kimsufi.com die Domain einfach noch nicht. Wenn du diesen erst vor einigen Minuten im Manager V3 aktiviert hast, ist das auch nicht verwunderlich.
Wichtig ist, dass die Zone auf dem primären DNS (auf deinem Kimsufi) angelegt wurde und dass der Nameserver auch antwortet, wenn er bzgl. der Domain gefragt wird. Testen kann man das z.B. mit
"dig domainname.tld @deinserver"
Dann wird der kürzliche aktivierte sekundäre DNS (ns.kimsufi.com) die Zone von dem Primären übernehmen und der Zonecheck erfolgreich sein.

Mathias

ReduX08
09.12.08, 14:59
Hi,
Danke für deine Hilfe.

Beim Denice Zone Check kommt:
---- schwerer Fehler ----
f: [TEST SOA Eintrag verfügbar]: Server Fehler (IN/SOA: MEINEDOMAIN.)

* ns.kimsufi.com./213.186.33.199
Heißt das, dass es einfach noch ein paar Std. geht (wegen Update) oder habe ich da was falsch gemacht?

MFG ReduX08

mathias
08.12.08, 12:27
In der named.conf hast du mit folgendem Eintrag:

file "/etc/bind/www.MEINEDOMAIN.de";

das Ziel für die Zonen-Verwaltungsdatei deiner Domain angegeben. Aber wahrscheinlich existiert die Datei /etc/bind/www.MEINEDOMAIN.de nicht.

Deren Inhalt müsste so oder so ähnlich aussehen:

$ttl 38400
domainname.tld. IN SOA domainname. account.domainname.tld. (
2008120801 <- Den Wert an dieser Stelle so eintragen, bzw. aktuelles Datum
10800
3600
604800
38400 )
domainname.tld. IN NS servername.
domainname.tld. IN NS ns.kimsufi.com. <- oder sdns1.ovh.net, je nachdem
domainname.tld. IN A IP-SERVER
domainname.tld. IN MX 1 servername.

Mathias

ReduX08
06.12.08, 22:54
Tag,
Ich möchte ein DNS Server aufsetzen (habe es bisher noch nie gemacht).
Habe mehrere Domains (bei OVH und anderen), deshalb ist es meiner Meinung nach besser dies auf einem eigenen DNS Server zu verwalten.

Bind9 zu installieren ist ja kein Problem aber die Konfiguration:

in der named.conf habe ich alles belassen und:
Code:
zone "MEINEDOMAIN.de" in {
type master;
file "/etc/bind/www.MEINEDOMAIN.de";
allow-query { any; };
};
hinzugefügt.

named.conf.local habe ich ebenfalls belassen.
In named.conf.options steh folgendes:
Code:
options {
        directory "/var/cache/bind";
        pid-file "/var/run/bind/named.pid";
        notify yes;
        allow-transfer { 195.20.224.97; 195.20.225.34; };
        forwarders { 195.20.224.234; 195.20.224.99; };
        forward first;
        listen-on port 53 { 127.0.0.1; MEINEIP; };
        listen-on-v6 { none; };
        allow-query { 127.0.0.1; MEINEIP; };
        allow-recursion { 127.0.0.1; MEINEIP; };
        auth-nxdomain no;    # conform to RFC1035


        // If there is a firewall between you and nameservers you want
        // to talk to, you might need to uncomment the query-source
        // directive below.  Previous versions of BIND always asked
        // questions using port 53, but BIND 8.1 and later use an unprivileged
        // port by default.

        // query-source address * port 53;

        // If your ISP provided one or more IP addresses for stable
        // nameservers, you probably want to use them as forwarders.
        // Uncomment the following block, and insert the addresses replacing
        // the all-0's placeholder.

        // forwarders {
        //      0.0.0.0;
        // };

        // auth-nxdomain no;   # conform to RFC1035

};
Soweit habe ich es aus einem HowTo und hoffe das es so richtig ist.
Nur wie richte ich jetzt die Datei für meine Domain ein? Das verstehe ich garnicht.

Für die Domains bei OVH muss ich ja dann noch Sekundär Domain im Manager umstellen?

MFG ReduX