OVH Community, your new community space.

Nach Reboot ssh nich verfügbar


Anom
04.09.08, 16:10
so sry an alle leute das ich hier so ne panic verbreite..^^

Hab das prob gelöst....und zwar....
Hab ich die ssh conf nich in mnt/etc/ssh angeguckt....sondern nur in etc/ssh ^^


da frag ich mich aber wieso der port verstellt wurde ??? hab doch nur normalen reboot gemacht Oo

Nightfalcon
04.09.08, 14:33
Poste doch einfach mal die Ausgabe von:

fdisk -l /dev/sda

Anom
04.09.08, 13:30
so also in der config steht port 22

das prob ist (weiß nich ob ich die brauche ) aber die partition home ist gecryptet und lässt sich iwie nich mounten... der schreibt mir immer das er den point nich findet...

das einzige das sich booten lässt ist sda1 aber das hab ich ohne /boot angegeben... wenn ich zb mount" /dev/sda2 /mnt/home "
mache schreibt der mit
mount: you must specify the filesystem type
ABer wie gesagt ...das home dürfte ja nich essentiel sein..da ja die wichtigen sachen in etc usw sind oder ?

so und telnet sprocht ja auch nich an ...wie gesagt ...putty ist tod ^^

im anhang ma meine config. wäre nett wenn ihr mir weiterhelfen könnt will das ja auch iwann alleine können ^^

# Package generated configuration file
# See the sshd(8) manpage for defails

# What ports, IPs and protocols we listen for
Port 22
# Use these options to restrict which interfaces/protocols sshd will bind to
#ListenAddress ::
#ListenAddress 0.0.0.0
Protocol 2
# HostKeys for protocol version 2
HostKey /etc/ssh/ssh_host_rsa_key
HostKey /etc/ssh/ssh_host_dsa_key
#Privilege Separation is turned on for security
UsePrivilegeSeparation yes

# ...but breaks Pam auth via kbdint, so we have to turn it off
# Use PAM authentication via keyboard-interactive so PAM modules can
# properly interface with the user (off due to PrivSep)
#PAMAuthenticationViaKbdInt no
# Lifetime and size of ephemeral version 1 server key
KeyRegenerationInterval 3600
ServerKeyBits 768
.......

so also wie gesagt bis auf sda1 (ohne boot angeben) konnte ich nichts mounten..hier ma n putty auszug

rescue:~# mount /dev/sda3 /mnt
/dev/sda3 looks like swapspace - not mounted
mount: you must specify the filesystem type
rescue:~#



aso ja und btw.... weiß das ja nich mehr sogenau aber soviel ich noch aus nem kurs weiß ist telnet 23 oder irr ich da ??

Nightfalcon
04.09.08, 10:44
Habe mich vertippt.

Natürlich shutdown -r now

Danke

Enn
04.09.08, 10:33
shutdown -h now
sollte "shutdown -r now" sein, sonst kommt die Kiste erst recht nicht wieder hoch.

Nightfalcon
04.09.08, 09:21
Hallo,

zuerst lässt du den Server im Normatzustand.
1. telnet domain.de 22 aufrufen
domain.de ist deine domain mit der du dich immer verbindest. Port 22 ist überlicherweise der ssh-port, hast du den verlegt z.b. auf 1022 so musst du das hier entsprechend ändern. Danach sollte sowas wie:
Escape character is '^]'.
SSH-2.0-OpenSSH_4.3p2 Debian-9etch2

kommen. Das heisst, der ssh spricht mit dir.

Sollte dem nicht so sein, dann:

2. Server mittels netboot in den rescue-modus versetzen

Dazu musst du wissen, wie die verschiedenen Partitionen vorher gemountet wurden. Als kleine Hilfestellung dient im Rescue-Modus
fdisk -l /dev/sda

Dann mountest du die Partitionen:

z.B..
mount /dev/sda3 /mnt
mount /dev/sda1 /mnt/boot
mount /dev/sda4 /mnt/usr
usw.

zur Vorsicht würde ich auch noch

mount -t proc /proc /mnt/proc

danach

chroot /mnt

erst dann macht ein apt-get überhaupt Sinn.....

vorher würde ich aber mal die
/etc/ssh/sshd_config
ansehen. Schau mal bei Port an, was da steht... Hoffentlich 22
Dann machst du
/etc/init.d/ssh restart

Startet er ohne Fehler durch?

Dann machst du

passwd "Hier gibst du dann dein Rootpasswort ein"
Das Passwort will er nochmals bestätigt haben.

Hat auch das funktioniert?

Dann

apt-get install rcconf

nach Beendigung

rcconf aufrufen

Bitte kontrollieren, ob bei ssh ein Sternchen ist, wenn nicht, bitte setzen.

Ist das alles erledigt worden:
dann
exit
eingeben
dann
umount /mnt/boot
umount /mnt/usr
usw

zum Schluss mittels mount kontrollieren, ob alle devices unmountet sind.

Dann
netboot auf hd umstelllen

reboot oder shutdown -h now

eingeben

Hoffen......

sw@wit
04.09.08, 07:29
Auf welchem Port versuchst du denn laut Putty zu connecten und mit welchem Protokoll? Was steht in der /etc/ssh/sshd_config (bezüglich Port)?

Enn
04.09.08, 07:16
logs durchschauen / ssh purge'n und neuinstallieren / schauen an welches Interface ssh horcht (und welcher port)

Anom
04.09.08, 04:50
Habe jetzt mit apt-get uninstall ssh deinstalliert und dann wieder neu installiert.... geht aber noch immer nich


wenn ich dann in hd mode wechsle geht ssh immer noch nicht!!

was kann ich denn noch probieren bevor ich den kundendienst damit behelle

Anom
04.09.08, 02:14
k dh einfach nur ma im rescue modus connecten und dann einfach wieder umstellen ??
oder muss ich vorher was eintipseln um iwas zu überprüfen ?


omg der schreibt mir pw falsch obwohl es richtig ist oO

aso für rescue gibts andere daten^^

also muss ich da noch iwas machen ??
Edit: wer lesen kann ist klar im vorteil
ssh mit apt-get install ssh ?
oder nur sys updaten und upgraden ?

Stefan
04.09.08, 02:07
Netboot auf HD stellen und einen Hard Reboot, dann bootet der Server wieder von der Festplatte.

Stefan

Anom
04.09.08, 02:05
DANGESCHÖÖÖÖN werds gleich mal probieren.... und wenn da dann das ssh funzt einfacj wieder aus dem rescue modus rausnehmen or wie...

Stefan
04.09.08, 01:57
Server auswählen > Dienstleistungen > Netboot

dann auf Rescue stellen und einen Hard Reboot ausführen.

Der Server startet im Rescue-Modus.

Stefan

Anom
04.09.08, 01:54
Also ssh war vor reboot verfügbar....nur wie mach ich n rescue hab schon überall gesucht unter dienstleistungen usw. Wo ist das denn genau bzw wie starte ich das ?

Stefan
04.09.08, 01:48
mal scan machen ob der ssh Port offen ist
bzw ssh über den rescue neuinstallieren.

nebenbei kannst du auch den Support anschreiben, damit man schauen kann wo das Problem genau liegt.

Stefan

Anom
04.09.08, 01:34
Also moin erstma ^^

Folgendes : hab meinen server neu gebootet...danach war ssh nich erreichbar obwohl ich ihn pingen konnte.....
Dann hab ich nen hartboot gemacht..und ca . 20 min. gewartet und nu lässt er sich noch immer pingen aber putty sagt mir immer das die connection refused sei ....

BITTE DRINGEND UM HILFE