We are in the process of migrating this forum. A new space will be available soon. We are sorry for the inconvenience.

CPU Takt festsetzen


Laxity
02.08.08, 01:27
Also.. wenn das Verhalten nicht im BIOS aktiviert wurde (da kannste dann wohl wenig gegen tun denke ich - aber gewiss weiss ich das nicht)

Installiere Dir mal die "cpufreq" Utils.
Ich kenns nur von Debian, da gibts Pakete für, einfach über aptitude installieren..


Habe die auf meinem "uralt" server laufen. Das ist ein

Code:
model name	: AMD Athlon(tm) 64 Processor 3500+
Momentan hab ich ihn im "ondemand" Modus.. Also nur dann full speed wenns auch gebraucht wird - so wie bei Dir?


Code:
isengard:~# cpufreq-info 
cpufrequtils 002: cpufreq-info (C) Dominik Brodowski 2004-2006
Bitte melden Sie Fehler an linux@brodo.de.
analysiere CPU 0:
  Treiber: powernow-k8
  Folgende CPUs k?nnen nur gleichzeitig ihre Frequenz variieren: 0
  Hardwarebedingte Grenzen der Taktfrequenz: 1000 MHz - 2.20 GHz
  m?gliche Taktfrequenzen: 1000 MHz, 1.80 GHz, 2.00 GHz, 2.20 GHz
  m?gliche Regler: userspace, ondemand, powersave, performance
  momentane Taktik: die Frequenz soll innerhalb 1000 MHz und 2.20 GHz.
                    liegen. Der Regler "ondemand" kann frei entscheiden,
                    welche Taktfrequenz innerhalb dieser Grenze verwendet wird.
  momentane Taktfrequenz ist 1000 MHz  (verifiziert durch Nachfrage bei der Hardware).

Dann führst Du ein:
Code:
isengard:~# cpufreq-set -g performance
aus und es sieht dann gleich anders aus:

Code:
sengard:~# cpufreq-info 
cpufrequtils 002: cpufreq-info (C) Dominik Brodowski 2004-2006
Bitte melden Sie Fehler an linux@brodo.de.
analysiere CPU 0:
  Treiber: powernow-k8
  Folgende CPUs k?nnen nur gleichzeitig ihre Frequenz variieren: 0
  Hardwarebedingte Grenzen der Taktfrequenz: 1000 MHz - 2.20 GHz
  m?gliche Taktfrequenzen: 1000 MHz, 1.80 GHz, 2.00 GHz, 2.20 GHz
  m?gliche Regler: userspace, ondemand, powersave, performance
  momentane Taktik: die Frequenz soll innerhalb 1000 MHz und 2.20 GHz.
                    liegen. Der Regler "performance" kann frei entscheiden,
                    welche Taktfrequenz innerhalb dieser Grenze verwendet wird.
  momentane Taktfrequenz ist 2.20 GHz  (verifiziert durch Nachfrage bei der Hardware).
In dem Setting läuft er immer auf Vollgas..
Aber vielleicht lebt mein alter Midi-Tower "Server" seit 5 Jahren auch immernoch weil ich den Regler auf "ondemand" habe *g*

Hope it helps

R3bOrN
01.08.08, 23:04
Ich habe zwar nicht direkt einen Server von ovh aber ich hoffe das mir trotzdem geholfen wird.

Als CPU läuft bei mir der AMD Athlon(tm) 64 X2 Dual Core Processor 5600+.
Naja wenn kein Load da ist läuft er auf nur 1000MHZ.

Ist es möglich , ohne groß alles neueinzurichten dieses Verhalten zu deaktivieren?

Ich möchte erreichen das er sich nicht runtertaktet.

Ich hab gehört das es möglich ist aber ich dafür den Kernel neu builden müsste.
Gibt es vielleicht auch noch andere Wege ?


Mir gehts einfach nur darum das die CPU zu spät hochgetaktet wird und es zu lags kommt. Deswegen wollte ich sofort die volle Power haben.

Danke