OVH Community, your new community space.

Problem beim Kernelerstellen


strex
12.01.08, 12:04
Noch nen Tipp von mir, aktiviere den Kernel Module Support sowie grsec (Patch: http://www.grsecurity.net/~spender/g...101800.patch);)

sledge0303
12.01.08, 08:25
Wer sein OS per OVH Image erstellt hat, dem steht auch keine .config zur Verfügung und daher wäre ein 'make oldconfig' absolut sinnlos. Woher soll das Menu des Kernels die notwendigen Informationen herbekommen?
Nimm diese .config aus dem Link von Strex, umbenennen in .config und dann hast erstmal eine Grundlage.
Welche NIC hast du denn drin? Es gibt Server die haben eine Realtek bzw Intel Karte Pro mit 1Gbit max drin, diese wurde auf 100Mbit konfiguriert. In dem Fall muss gepatcht bzw. im Fall Realtek die 1Gbit Karte aktiviert werden OHNE NAPI!

strex
12.01.08, 00:52
Hmm seltsam, liegt das an der Config...

Ich habe wunderbar mit der Config "wget ftp://ftp.ovh.net/made-in-ovh/bzImage/config-2.6.22-xxxx-std-ipv4-32" sämtliche Kernels gebacken. Derzeit läuft der 2.6.23.9 mit grsec wunderbar Aber aufpassen das du den richtige Prozessor auswählst...

Einfach mal versuchen, sollte es wieder den Fehler bringen, müssen wir das an einer anderen Stelle suchen.

Grüße strex

MO2k4
11.01.08, 21:22
Hi ich möchte mir gerne einen eigenen Kernel auf meinen ISGENUG aufsetzen, aber irgendwie will er nicht so richtig laufen.

Ich habe heute nun schon mehrfach probiert aber leider nichts. Ich vermute den Fehler laut SYSLOG an folgender Stelle

Code:
Jan 11 20:11:07 ks353682 named[2259]: hint zone "" (IN) loaded (serial 0)
Jan 11 20:11:07 ks353682 named[2259]: master zone "localhost" (IN) loaded (serial 1)
Jan 11 20:11:07 ks353682 named[2259]: master zone "127.in-addr.arpa" (IN) loaded (serial 1)
Jan 11 20:11:07 ks353682 named[2259]: master zone "0.in-addr.arpa" (IN) loaded (serial 1)
Jan 11 20:11:07 ks353682 named[2259]: master zone "255.in-addr.arpa" (IN) loaded (serial 1)
Jan 11 20:11:07 ks353682 named[2259]: listening on [127.0.0.1].53 (lo)
Jan 11 20:11:07 ks353682 named[2259]: Forwarding source address is [::].32768
Jan 11 20:11:07 ks353682 named[2259]: Forwarding source address is [0.0.0.0].32769
Jan 11 20:11:07 ks353682 named[2260]: Ready to answer queries.
Jan 11 20:11:07 ks353682 named[2260]: sysquery: sendto([128.63.2.53].53): Network is unreachable
also irgendwie hat er keine netzwerkverbindung aber leider weiss ich nicht warum

ich bin wie folgt vorgegangen:

kernelsource 2.6.22.10 runtergeladen entpackt und dann

1. make oldconfig
2. make && make modules_install
3. make install
4. lilo.conf angepasst
5. /sbin/lilo
6. /sbin/reboot

und dann ist schluss, kann mir vielleicht jemand aus dem Forum weiterhelfen bzw hat noch ein paar Tips für mich?

Vielen Dank schon mal im voraus