OVH Community, your new community space.

Rescue Mode


mathias
23.01.08, 10:27
Hi,

wir sollten besser per Mail in Kontakt bleiben. Wenn die Befehle wie in meiner letzten Nachricht beschrieben abgesetzt wurden, wovon wohl 3 nicht klappen dürften, sollte der Inhalt der Festplatte unter /mnt sichtbar sein.

Mathias

finn
22.01.08, 18:59
ich nehme an das der Techniker sich gut bezahlen lässt. mal grob zusammengefasst...

nach einem neustart hatte ich keinen zugriff mehr auf den server. via putty kann ich die platte nicht mounten um an die daten heranzukommen. vKVM haut nicht hin.

mir fällt zu der problematik nichts mehr ein... was wird ein techniker kosten ? 60 euro die stunde oder wieviel ? es wird doch irgendwie möglich sein den kasten wieder zum laufen zu bringen.

sledge0303
22.01.08, 18:42
Zitat Zitat von finn
ok, dann weiss ich es nicht. vielleicht hat ja jemand eine idee wie ich die platte mounten kann um an die daten ranzukommen. ich habe schon gegoogelt aber nichts gefunden.
Du hast Windows. Ich selbst hab auch Windows produktiv eingesetzt, doch kann ich mich lokal vor dessen VM setzen wenn was 'klemmt'.
In dem Sinn, wenn vKVM nicht funzt, musst du den Techniker bemühen. Er kann den Server notfalls im abgesicherten Modus hochfahren und anschließend die Fehlerquelle zu lokalisieren und ggf zu beheben - sofern der Kasten nicht kompromittiert wurde.

finn
22.01.08, 18:08
ok, dann weiss ich es nicht. vielleicht hat ja jemand eine idee wie ich die platte mounten kann um an die daten ranzukommen. ich habe schon gegoogelt aber nichts gefunden.

F4RR3LL
22.01.08, 17:28
Zitat Zitat von finn
danke erstmal für den guten support.

ich bekomme die platte nicht gemountet. ich gehe wie nach der Beschreibung vor http://hilfe.ovh.de/AdministrationRescueModus:

rescue:~# mount /dev/hda1 /mnt/
rescue:~# mount /dev/hda2 /mnt/home/

rauskommt: No such file or directory

mit sda1 habe ich es auch versucht. wie soll ich es nun machen ? die befehle habe ich richtig eingegeben, das ist nun wirklich keine kunst und was sie bedeuten und bewirken ist mir auch klar.
Wie der Fehler schon sagt existiert das Directory nicht. Diese Beschreibung ist für die Linux Kisten. Da Du allerdings wie ich oben las einen Windows Server hast wirst Du anders vorgehen müssen. Wie kann ich dir allerdings ned sagen da ich noch nie einen Winpc im rescue hatte.

Gruß Sven

finn
22.01.08, 17:11
danke erstmal für den guten support.

ich bekomme die platte nicht gemountet. ich gehe wie nach der Beschreibung vor http://hilfe.ovh.de/AdministrationRescueModus:

rescue:~# mount /dev/hda1 /mnt/
rescue:~# mount /dev/hda2 /mnt/home/

rauskommt: No such file or directory

mit sda1 habe ich es auch versucht. wie soll ich es nun machen ? die befehle habe ich richtig eingegeben, das ist nun wirklich keine kunst und was sie bedeuten und bewirken ist mir auch klar.

mathias
22.01.08, 14:49
Alles klar, Mail ist raus.

Wenn die Lösung des Problems interessant sein sollte, werden wir hier antworten

Mathias

finn
22.01.08, 14:40
putty klappt immer noch nicht. bis jetzt habe ich jede mail bekommen ! ohne ausnahmen.

mathias
22.01.08, 14:32
Ok, ich würde jetzt gerne eine Anleitung per Mail schicken.
Dafür muss ich aber sicher gehen, dass die Nachricht auch ankommt. Die andere Mail wurde empfangen?
Putty Zugang klappt jetzt? Wenn nicht, dann versuchen wir besser, das Problem komplett per Mail zu lösen da in diesem Fall sensible Daten ausgetauscht werden müssen.

Mathias

finn
22.01.08, 14:09
die Putty Benutzung habe ich mir sowieso erst durchgelesen bevor versucht habe mich anzumelden.

Viel muss nicht gesichert werden (dafür aber sehr wichtige Dateien), ca. 1 GB bzw. ein Ordner in dem sich die Dateien befinden.

mathias
22.01.08, 14:03
http://hilfe.ovh.net/PuttyBenutzung
Bei der Eingabe des Passwortes ändert sich die Cursorposition nicht.

Ein Techniker muss dann eingreifen, wenn die Hardware Probleme macht. Hier ist es anscheinend "nur" das Betriebssystem, welches nicht mehr gestartet werden kann.

Wie viele Daten müssen gesichert werden?

Mathias

finn
22.01.08, 13:59
nein ,vkvm geht nicht. ich habe versucht mich mit den letzten zugangsdaten die mir zugeschickt wurden anzumelden. Und bei putty kann ich zwar connecten, aber ein Passwort kann ich nicht eingeben. Eine Fehlermeldung bekomme ich nicht (schön wärs). und nun ? muss jetzt ein techniker ran ?

edit: ja die mail habe ich bekommen.

mathias
22.01.08, 13:56
Achtung, ist ein Windows Server.

finn, die Mail von uns ist vorhin angekommen?

Mathias

sledge0303
22.01.08, 13:46
Hallo.

wenn du die Daten vom Rescuesystem bekommen hast, dann loggst dich damit erstmal ein. Das klappt immer, da dieses System unabhängig von deinem installierten OS arbeitet.

Dann mountest du deine Festplatten. Wenn du ein OVH Image hast:

sda1 = /
sda2 = /home
sda3 = swap

du mountest mit

Code:
mount /dev/sda1 /mnt
mkdir -p /mnt/home 
mount /dev/sda2 /mnt/home
Danach loggst dich in dein installiertes System ein

Code:
chroot /mnt /bin/bash
als erstes schaust du dir die Logeinträge ein.

Code:
cd /var/log
Darin befinden sich all deine Logfiles. Jetzt durchsuchst du die Logfiles nach Auffälligkeiten. Wichtig sind

syslog
dmesg
dmesg.0
dmesg.1.gz
...

Wenn du soweit bist, poste diese Ausgaben

Code:
cat dmesg | egrep 'eth|seg'
cat dmesg.0 | egrep 'eth|seg'
zcat dmesg.1.gz | egrep 'error|eth|seg'
Wenn dort keine Auffälligkeiten sind, die dmesg.0 komplett posten. Wenn wir dort keine Auffälligkeiten finden, dann sehen wir woanders nach. Aber mach bitte erstmal das was ich dir geschrieben habe.

mathias
22.01.08, 13:42
Hi,

vKVM geht auch nicht? Der Bootscreen sollte nach dem Start durch Klick auf "den Server starten" im Browser eigentlich sichtbar sein... bis zu einem bestimmten Punkt jedenfalls, wenn das System abschmiert.

Wenn sich der Server im Rescue Modus befindet, kann in jedem Fall via Putty darauf zugegriffen werden. Wenn das Passwort hier tatsächlich nicht eingegeben werden könnte, wäre das recht ungewöhnlich Erscheint eine Fehlermeldung?

Mathias

finn
22.01.08, 13:33
Direkte Worte sind besser als keine. Der Server ist wieder online. Es funktioniert jedoch kein vkvm, Remotedesktop und mit Putty hauts auch nicht hin.

"Was haut denn genau nicht hin ?" Das Connecten jeglicher Art funktioniert nicht. Was nützt mir da Wissen oder nicht Wissen wenn ich keinen Zugriff habe. Das schlimmste ist, das ich an meine sensiblen Daten nicht herankomme. Was kann ich jetzt in dem Falle tun ? Wie kann es sein das nach einem Neustart nichts mehr funktioniert ? Ich habe seit dem letzten neustart weder Programme installiert noch irgendeine andere andere einstellung vorgenommen.

sledge0303
22.01.08, 12:58
Hallo,

wenn der Server down geht, kann es sehr viele Ursachen haben. Ein Hardwareschaden oder ein Dienst der Amok läuft und den Server zum absturz bringen kann. Auch eine Kompromittierung ist nicht vollkommen ausgeschlossen.
Sorry für meine direkten Worte, doch scheinst du kein Grundlagenwissen in der Administration mitzubringen, daher ist es schwierig dir direkt mit Kommandos oder irgendwelchen Hinweisen zu helfen.

finn
22.01.08, 12:09
Ich habe eine mail an den Kundendienst geschickt. Laut VMS ist der Server down. ich bekomme auch weiterhin mail das ein Fehler aufgetreten ist. Zwischendurch bekam ich eine mail das kein Fehler mehr aufgetreten ist. Zu guterletzt, gehts mit Putty auch nicht vorran. Ich kann zwar mit meiner IP connencten aber das Passwort nicht eingeben. Ich warte jetzt erstmal die Reaktion von meiner mail ab. ich hoffe mir kann geholfen werden. Ich bin nemlich gerade sehr ratlos.

mathias
22.01.08, 11:43
Hallo,

hier noch ein vielleicht hilfreicher Link: http://hilfe.ovh.net/AdministrationRescueModus

Im Rescue Modus wird ein Server hochgefahren, wenn das installierte OS nicht gestartet werden kann.

Falls sich das Problem noch nicht geklärt hat, bitte eine Mail mit dem Servernamen an uns schicken.

Mathias

F4RR3LL
22.01.08, 11:28
Na da gehste mal mit Putty und dem rescue Pass auf den Server, mountest die Platte/-n und schaust wo es hängt. Wenn alles passt wieder reboot und alles ist wölkchen.
Gruß Sven

finn
22.01.08, 09:48
Hallo,

ich habe gestern Nacht meinen Server neugestartet und seit dem läuft er nicht mehr. Ich komme per Remote nicht mehr drauf, soll laut email aber laufen.

In der mail stand am Anfang dies:

"Ihr Server wurde im 'Rescue'-Modus neu gestartet; diesbedeutet, daß ein Linux/BSD vom Netzwerk aus auf IhrenServer gesendet wird. Es handelt sich nicht um das System,das normalerweise auf Ihrem Server installiert ist, keine Ihrer Partitionen ist übrigens installiert."

Wie soll ich weiter vorgehen ? Und warum treten plötzlich Probleme auf ? Ich habe den Server noch nicht lange, bin mir aber 100% sicher das ich ihn nicht mit Schädlicher Software oder falschen Anwendungen "vermurkst" habe. Sind meine daten jetzt futsch ? Immerhin liegen dort Daten drauf an in denen ich mehrere hundert Stunden Arveit investiert habe.

Wie muss ich jetzt vorgehen das alles wieder normal funktioniert ?

Die andere Sache ist, warum funktioniert der Server nach einem Neustart plötzlich nicht mehr ? Das kann doch nicht sein. Es wird doch wohl möglich sein das ich einen ganz normalen Remotezugriff nutzen kann oder nicht ?

Peter
10.01.08, 09:59
Hallo,

mit den Rescue-Mails sollte nun wieder alles normal funktionieren. Wenn noch Probleme bestehen bitte kurz beim Kundendienst Bescheid sagen.

Peter

schwarzlicht
09.01.08, 23:28
Habe eben den Server im Rescue-Pro gestartet, Kennwort war nach 5min da.
Alles OK.

Daniel

sledge0303
09.01.08, 20:21
Ich hab heute Zuwachs in der Serverfarm erhalten, doch dieser steht im Kundenmenu ebenfalls noch nicht drin, bzw. hab diesbezüglich keine Mail erhalten. Da scheint irgendwie der Wurm drin zu sein. Mal sehen wann es klappt, evtl. bin ich in dem Fall auch selbst etwas ungeduldig.

baldi
09.01.08, 20:04
ich warte schon seit mittag auf die rescue-login-daten bei einen kimsufi.
und jetzt bei einen anderen server seit ~2 stunden...*gähn*
habe auch verschiedene mail-adressen probiert -> keine veränderung.

email an kundendienst ist bereits raus.

lg

schwarzlicht
09.01.08, 19:26
Schwarzlicht, hast du deine Mail erhalten? Wenn nicht, kurze Mail mit Servernamen an den Kundendienst bitte, wir schauen uns das dann an.
Hallo Herr Peter,

nein, eine Mail mit den Zugangsdaten für den Rescue-modus habe ich nicht erhalten. Den Server habe ich um 01:23 Hard-Booten lassen und die Neuinstallation (from Scratch) auf heute Nacht verschoben.

Daniel

Peter
09.01.08, 13:47
Hallo,

es kam gestern und heute Morgen zu Verspätungen von mehreren Stunden beim Versand der Installations- und Rescuemails, siehe dazu auch folgende Meldung:
http://forum.ovh.de/showthread.php?t=2981
Die ausstehenden Mails wurden mittlerweile versandt.

Peter

Problem-User
09.01.08, 12:14
Da sollte ja auch eine Email drin sein , aber da ist leider nichts , mache ich irgendwas falsch ? Ich habe Netboot auf Rescue-pro stehen und habe dann anschliessend einen Hardware reset gemacht. Ich bekomme aber nur eine Mail das der Server wieder erreichbar ist und keine Zugangsdaten für den Resue Mode zugesendet.
Ich habe es auch mit einem Softboot probiert aber auch kein erfolg.

normal von Festplatte booten einloggen
im Kundenmanager umstellen auf Netboot Rescue-Pro
reboote über console und nach 2 min hab ich dann wieder nen ping könnte mich einloggen , jedoch habe ich kein Passwort zugesedet bekommen weder in der Historie im Kundenmanager unter einstellungen noch auf meine bei mir angegebene Emailadresse.


UPDATE:

Gerade nochmal Probiert und wie durch ein wunder habe ich Rescue-Mode zugangsdaten bekommen

Angie
09.01.08, 12:05
Hallo,

ihr wisst das ihr auf jeden Fall die Kopie dieser Email in eurem Manager findet?
Einfach auf 'Meine Einstellungen' klicken und dann auf E-Mail-Historie.
Meistens liegen die Mails dort schon im Interpop. So braucht man weniger lange zu warten.


Gruss,
Angie

Peter
09.01.08, 11:30
Hallo,

Problem-User, ich denke du bist der Kunde dessen Server sich gestern nach einem Eingriff im Rechenzentrum im (internen) Rescue Modus von OVH befand. Bei diesem wird keine Mail an den Kunden versandt. Der Server wurde dann von uns in den normalen Rescue Modus versetzt und 5 Minuten später vom Kunden auf Boot von HDD umgestellt. Der Server ist seitdem von der Festplatte gestartet, pingt und ist online, die Ports sind offen; um sich zu verbinden werden die normalen Zugangsdaten zum Server verwendet.

Schwarzlicht, hast du deine Mail erhalten? Wenn nicht, kurze Mail mit Servernamen an den Kundendienst bitte, wir schauen uns das dann an.

Peter

schwarzlicht
09.01.08, 01:19
Ja, ich habe das Problem im Moment auch, ich warte seit 30min.
Sonst dauert das max 5 min bis die Mail mit den Zugangsdaten eintrifft.

Naja, zum Glück ist es nicht SO wichtig, allerdings mache ich mir gerade Gedanken darüber welchen Sinn dieser RescueModus hat wenn ich ihn im "Notfall" nicht nutzen kann.

Daniel

//Edit: Hard-Reboot funzt, Mail kam auch dass der Reboot durchgeführt wurde.

Problem-User
09.01.08, 00:23
Der Tipp war schonmal gut , doch leider steht keine Email in der History mit dem PW für den Rescue Mode.

Hardware reboot XXXXXX.ovh.net [OK]

Zustand des Netboot: Kernel: Rescue-Modus aktiviert

bekommenur eine mail das der Reboot erfolgreich war , Console geht auch auf , mit meinen normalen login daten komme ich dann aber net rein , schon klar er hat das Rescue Sysetm gebootet und mir fehlt das PW.
Leider bekomme ich keine zweite email mit den Zugangsdaten und in der Historie steht auch nix drin.

sledge0303
08.01.08, 23:47
Zitat Zitat von Problem-User
Wie kome ich sonst noch daran ?
Das Problem ist bekannt, am besten schaust du in der Mailhistorie im Kundenzenter nach, dort liegen in der Regel alle Mails drin.

HTH

Problem-User
08.01.08, 23:23
Hallo ,

Ich versuche schon seid ca 5 Stunden in den Resue Mode zu gelangen , die Console ist auch da nur leider bekomme ich nach einem Reboot keine Email mit dem Passwort für den Resue Mode zugesedet. gibt es da vielleicht Probleme bei OVH mit den Emails ? Ich habe verschiedene Emailadressen probiert , meine funktioniert auch , bekomme schön die Mitteilung ein Hardware reset wurde ausgeführt und ihr Server ist erreichbar aber leider keine Email mit dem Passwort für den Resue Modus.


Wie kome ich sonst noch daran ?