OVH Community, your new community space.

register_globals


Angie
15.01.07, 21:14
Hallo,

vielleicht kann Ihnen diese Hilfe nützlich sein :
http://hilfe.ovh.de/ConfigPhp

Um von ihrem Shared-Hostingpaket aus das php.ini zu ändern, müssen die in der Hilfe angegebenen Parameter verwendet werden.


Mit freundlichem Gruss,
Angie

Borges
12.01.07, 06:55
Danke für den Hinweis, scheint aber leider so bei dieser Konfiguration nicht möglich zu sein: führt zum Server Error 500.

Briese
11.01.07, 14:46
Erstelle mal eine ".htaccess" mit folgendem Inhalt :

# schaltet Register globals auf OFF
php_flag register_globals off
aber k.a. ob das so funzt.

Zum Test schieb eine phpinfo hoch und schau nach.

Borges
11.01.07, 14:35
Hallo zusammen,

im Zusammenhang mit der aktuellen Wordpress-Sicherheitslücke wird vor der Einstellung "register-globals=on" gewarnt. Keine sauber programmierte Anwendung würde das benötigen. Ich kann das nicht beurteilen, vielleicht kann mich jemand aufklären ;-)
Phpinfo sagt mir, daß der entsprechende Parameter für mein Paket 1000gp auf "on" steht. Da ich nicht weiß, ob ich überhaupt Einfluß auf die php.ini bei diesem Shared-Hosting-Paket habe, habe ich die betroffene Wordpress-Funktion (Trackback) vorsichtshalber lahmgelegt. Aber gibt es vielleicht auch eine Möglichkeit, den Eintrag in der php.ini für das eigene Paket zu überschreiben?

Gruß,
Michael