OVH Community, your new community space.

htaccess will nicht


Christian_renamed
03.01.07, 19:22
Zitat Zitat von Philipp
Danke Christian.
Ich habe meinen den Fehler gefunden.
In meiner Apache conf stand zweimal AllowOverride und der zweite Eintrag hat wohl einfach den ersten überschrieben.
gern geschehen.

Philipp
03.01.07, 13:36
Danke Christian.
Ich habe meinen den Fehler gefunden.
In meiner Apache conf stand zweimal AllowOverride und der zweite Eintrag hat wohl einfach den ersten überschrieben.

Christian_renamed
03.01.07, 13:04
Zitat Zitat von Philipp
Wieso verweist du mich auf die HowTo von Apache2 ?
Eigeninitiative zeigen?!

http://httpd.apache.org/docs/1.3/howto/auth.html

Will aber nicht so sein:

htpasswd -cmd /pfad/zum/passfile username

Require valid-user in htaccess

AuthConfig statt All bei AllowOverride

Philipp
03.01.07, 12:43
Wieso verweist du mich auf die HowTo von Apache2 ?

sledge0303
03.01.07, 12:29
http://httpd.apache.org/docs/2.0/howto/auth.html

Philipp
03.01.07, 11:32
Ja ich würde gerne ein paar Dateien absichern.
Ein How To habe ich nicht erwartet.
Das System ist Debian
Was ich bisher gemacht habe:
-Apache1 installiert
-In der httpd.conf AllowOverride auf All gesetzt
-/home/www/domain/public_html/.htaccess erstellt
Code:
AuthType Basic
AuthName "Service-Bereich"
AuthUserFile /home/www/domain/.htusers

require user Philipp
-/home/www/domain/.htusers erstellt
Code:
Philipp:tFwlp........
Scheinbar hab ich irgendetwas vergessen oder mir fehlt ein Modul in der Apache conf? Was meint ihr?

LabSen
03.01.07, 10:52
Zitat Zitat von dennisda
@LabSen

was für ein OS ? und musstest du was zuinstallieren ?
Habe das ganze auf Debian mit VHCS2 dazu halt den Apache2 konfiguriert

ThorstenS
03.01.07, 10:24
Zitat Zitat von Philipp
Irgendwie scheint htaccess bei mir nicht zu funktionieren. Funktioniert es bei euch?
Wie wäre es, wenn du die einzelnen Schritte, die du unternommen hast aufzählst und deine config preis gibst?
Oder erwartest du mit deine Frage oben, dass dir jemand ein kleines Howto schreibt?
Bei mir funktioniert jedenfalls eine .htaccess zum Absichern eines Ordners.

sledge0303
03.01.07, 10:23
Du musst den Apachen entsprechend konfigurieren...

dennisda
03.01.07, 10:02
@LabSen

was für ein OS ? und musstest du was zuinstallieren ?

LabSen
03.01.07, 09:48
Also ich habe auf dem Test-Server ein Forum bei dem ne .htaccess für mod_rewirte eingesetzt wird und funktioniert ohne Probleme

Philipp
03.01.07, 09:23
Irgendwie scheint htaccess bei mir nicht zu funktionieren. Funktioniert es bei euch?