We are in the process of migrating this forum. A new space will be available soon. We are sorry for the inconvenience.

KVM zweites Interface, FO IP nicht erreichbar


chris12
26.10.16, 19:37
Hab jetzt centos lxc (geht) ubuntu 16 lxc (geht) probiert. Scheint also ne Ubuntu 14.04 Sache zu sein

Achja und 12.04 geht ebenfalls nicht

chris12
26.10.16, 18:31
Vielleicht noch zusätzliche Informationen. Kiste wurde mit dem standard OVH Proxmox Image betankt.

Ich habe via LXC mit einem Ubuntu Container genau das gleiche Problem. Zweite IP nicht pingbar.
Kurioserweise ist in einem debian lxc Container die zweite IP pingbar.
D.h. dachte ich, lets switch to kvm - doch Hier gleiches Problem. Debian via KVM habe ich noch nicht versucht

chris12
26.10.16, 18:25
Vmacs habe ich korrekt gesetzt - gelöscht und frisch angelegt.
Die Konfiguration ist analog der Bridge Client Seite - allerdings behandelt diese immer nur eine eth, also eth0. eth0 funktioniert auch, jedoch kein eth1. Siehe mein Post oben.

Lukkid
26.10.16, 09:19
Guten Morgen ,
schau dir am besten mal den OVH Artikel an: http://hilfe.ovh.de/BridgeClient
PS: MAC Adresse nicht vergessen. Entweder in die VM eintragen in Proxmox oder in der interfaces Datei des KVM mit hwaddress ether 00:00:...

Der sollte dir dabei helfen.

Gruß

maxs97
26.10.16, 08:39
OK, dann habe ich das falsch verstanden:
Die vMacs sind korrekt gesetzt?

chris12
25.10.16, 21:52
Das ist die Interfaces der VM, nicht des Hosts - oder verstehe Ich deinen Post falsch?

maxs97
25.10.16, 21:16
137.74.9.xxx ist die IP für die VM?
Dann konfiguriere doch einfach eine Bridge, eth1 fällt im Host dann ganz weg.
Auf die IP setzt du dann im Kundencenter eine vMAC und konfigurierst die VM entsprechend.

chris12
24.10.16, 22:48
Hallo zusammen,

ich versuche seit einigen Stunden einen KWM Gast zum laufen zu kriegen. Host ist ein Proxmox 4 - der Gast ein Ubuntu 14.04.

Meine intferfaces sieht wir folgt aus:
Code:
auto eth0
iface eth0 inet static
        address 94.23.160.xxx
        netmask 255.255.255.255
        network 94.23.160.0

auto eth1
iface eth1 inet static
        address 137.74.9.xxx
        netmask 255.255.255.255
        broadcast 137.74.9.xxx
        network 137.74.9.0

post-up ip route add [IP Hardware].254 dev eth0
post-up ip route add default via [IP Hardware].254 dev eth0
pre-down ip route del default via [IP Hardware].254 dev eth0
pre-down ip route del [IP Hardware].254 dev eth0
dns-nameservers 8.8.8.8
eth0 funktioniert und ist erreichbar, jedoch eth1 nicht. Welche Settings muss ich sonst noch setzen?

Grüße