We are in the process of migrating this forum. A new space will be available soon. We are sorry for the inconvenience.

CoreOS bootet nicht


givas
04.08.16, 10:04
Das ist über die Weboberfläche nicht möglich. Man kann zwar die Partitionen einstellen aber am Ende hat man doch nur eine einzige große Root-Partition. Bei der manuellen Installation übers offizielle Skript kann ich das zwar nach der Installation theoretiscch so einrichten aber der Boot klappt trotzdem nicht. Irgendwas ist bei der Kombination SyS und CoreOS inkompatibel.

EvilMoe
03.08.16, 19:40
Warum die Partition nicht einfach gleich richtig installieren?

givas
03.08.16, 16:27
Hi, ich habe CoreOS über die SyS Weboberfläche auf einem Dedicated Server installiert und dies funktioniert erstmal problemlos. Jedoch habe ich dann über das Rescue-System die Root-Partition (sda9) auf 100GB reduziert, weil ich ein btrfs RAID1 aufsetzen möchte. Nachdem ich mit parted und resize2fs die Partition verkleinert habe, kann ich die Partition im Rescue-System einwandfrei mounten. Wenn ich jedoch ins normale System reboote, startet das System einfach nicht.

Alternativ habe ich versucht den offiziellen CoreOS Installer aus dem Rescue-System heraus zu verwenden, jedoch klappt das Booten in diesem Fall auch nicht. Früher konnte ich, nach Telefonat mit dem SyS Support-Team, das Problem umgehen indem ich sda1 mounte und den EFI Ordner lösche. Jedoch funktioniert dieser Workaround ebenfalls nicht mehr.

Wie kann ich die Partition verkleinern und dann weiterhin ins System booten? Alternativ, wie kriege ich eine ganz saubere CoreOS Installation aufs System (ohne den SyS/OVH Anpassungen)?