We are in the process of migrating this forum. A new space will be available soon. We are sorry for the inconvenience.

Proxmox 4 KVM Subnet IPs


Cyberman
16.01.16, 10:36
Hallo Janko

Da ich aktuell auch mit einem Proxmox4 Problem am kämpfen bin und mit dem Support im Kontakt sehe und eine Lösung bekommen habe die aber für VM ist, glaube ich das es genau das ist was dein Problem ist.


Antwort Support
Auf meinem Proxmox Server funktioniert nun alles.

Beim Anlegen der VM muss vmbr1 gewählt, der IP Block, oder die Failover IP eingetragen und die Gateway IP gesetzt werden. Die Gateway IP ist dabei die Server IP selbst.

Bei DNS habe ich cdns.ovh.net mit der IP 213.186.33.99 angegeben.

Auf dem Hauptserver müssen die Routen hinzugefügt werden.

Das würde dann beispielsweise so aussehen:

ip route add Fa.il.ov.er/32 dev vmbr1 (Einzelne IP)
ip route add IP.ad.re.sse/30 dev vmbr1 (4er IP Block)

Auf der VM variiert dann die Netzmaske

4er Block = 255.255.255.252
Einzelne IP = 255.255.255.255

Das sind alle wichtigen Punkte die zu beachten sind, damit es funktioniert, nach der Installation.

Janko
21.11.15, 02:54
Zitat Zitat von Felix
Hallo,

die gateway-Zeile kannst/sollst/darfst du nur einmal angeben.

"Gateway" heißt "Default-Route", und eine solche kann es per definition nur einmal auf dem system geben. Da das gateway (151.80.199.254) über eth0 erreicht werden kann, solltest du diese Zeile bei eth1 deswegen löschen.

MfG,
Felix
Hi Felix,

das hatte ich auch schon probiert weil man es ja so "von Zuhause" kennt. Leider brachte es aber nicht den gewünschten Erfolg.
Die IPs sind danach von außen nicht erreichbar.

Hast du evtl. sonst noch einen Lösungsansatz?

Felix
17.11.15, 18:25
Zitat Zitat von Janko
Code:
iface eth0 inet static
	address 151.80.199.196
	netmask 255.255.255.0
	network 151.80.199.0
	broadcast 151.80.199.255
	gateway 151.80.199.254
[...]
auto eth1
iface eth1 inet static
	address 151.80.199.197
	netmask 255.255.255.0
	gateway 151.80.199.254
Hallo,

die gateway-Zeile kannst/sollst/darfst du nur einmal angeben.

"Gateway" heißt "Default-Route", und eine solche kann es per definition nur einmal auf dem system geben. Da das gateway (151.80.199.254) über eth0 erreicht werden kann, solltest du diese Zeile bei eth1 deswegen löschen.

MfG,
Felix

ChoosenEye
14.11.15, 15:31
Moin,

wenn du möchtest können wir uns das mal angucken erreichbar bin ich unter Skype oder per Mail an ivo@ivodohl.de

Gruß
ChoosenEye

Janko
14.11.15, 02:18
Na ja im Grunde hab ich nicht viel..... hab etliches ausprobiert

leider ist immer nur eine IP erreichbar. Mein Verständniss vom BridgeSetup ist doch das die Clients quasi direkt am Net sind.

Code:
# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
auto eth0
iface eth0 inet static
	address 151.80.199.196
	netmask 255.255.255.0
	network 151.80.199.0
	broadcast 151.80.199.255
	gateway 151.80.199.254
	# dns-* options are implemented by the resolvconf package, if installed
	dns-nameservers 8.8.8.8 8.8.4.4
	dns-search ohv.com


auto eth1
iface eth1 inet static
	address 151.80.199.197
	netmask 255.255.255.0
	gateway 151.80.199.254
#	# dns-* options are implemented by the resolvconf package, if installed
#	dns-nameservers 8.8.8.8 8.8.4.4
#	dns-search ovh.com
Mit einzelnen IPs klappt alles wunderbar und bisher hab ich nie mehr als eine gebraucht in einer VM

Tibain
13.11.15, 13:18
Oder du postest uns mal deine Konfiguration.

Janko
13.11.15, 03:52
Hi Leute,

bisher habe ich fast immer VZ und/oder LXC genutzt.
Gelegentlich auch KVM Gäste mit einer IP.
Nun stehe ich hier allerdings gerade auf dem Schlauch... Habe das Proxmox4 Template von Soyo genommen.
MACs beantrag und bei den Einstellungen wie gewohnt angegeben. Sobald ich nun eine weitere Netzwerkarte adde und dort die MAC eintrage, passiert ersteinmal nichts. Sobald ich dann aber die Config innerhalb des Gastes erstelle, ist der ganze Gast nicht merh erreichbar.

Kann mir daher hier gerade jemand seine Config einmal kurz posten? Vermutlich hab ich eh nur einen kleinen Denkfehler.