We are in the process of migrating this forum. A new space will be available soon. We are sorry for the inconvenience.

Proxmox KVM


maxpower
09.09.15, 11:39
Na dann hab ich ja glück gehabt das der Support für Fehler in seiner Konfiguration verantwortlich ist.

ZeuS
06.09.15, 15:06
Zitat Zitat von maxpower
Ich warte jetzt mal ob sich der Support irgendwann nochmal bewegt ansonsten kommt die Kiste weg.
Der Support ist für Bedienungsfehler und/oder Software nicht zuständig...

maxpower
05.09.15, 15:10
Ich warte jetzt mal ob sich der Support irgendwann nochmal bewegt ansonsten kommt die Kiste weg.

Server4pro
05.09.15, 12:16
Dann evt. Mal noch die Netzwerkkarte säubern, evt. ist es notwendig wenn du diese gar wechselst zu der et oder e1000. Hatte das Problem auch schon nach einer falschen Konfig.

maxpower
05.09.15, 12:05
Danke für den Tipp, bringt aber leider keinen Erfolg.

Server4pro
05.09.15, 10:26
virtio=00:50:56:04:42:73,bridge=vmbr0
Du hast eine VMWare MAC generiert und solltest eigentlich OVH wählen... schliesslich ist Proxmox nicht VMWare. Probiers damit Mal. Proxmox von Haus aus mit KVM ist lauffähig sofern man die korrekte MAC, Netzwerkadapter und Netzwerkkonfig bei der VM hat

Im übrigen richten wir auf Wunsch dies kostenlos ein sofern die Server über uns bezogen werden.

Gruss

maxpower
04.09.15, 14:06
Aktuell 2.6.32-40-pve, ich habe aber auch diesen schon probiert 3.10.0-9-pve

Hannobal
04.09.15, 13:52
Ich weiß nicht, ob es daran liegen kann, aber welchen Kernel hast du denn installiert? Den Kernel, den OVH sonst immer mit ausliefert, oder den Proxmox Kernel?

Poste mal die Ausgabe von
Code:
uname -a

maxpower
04.09.15, 13:46
Nein damit tut es leider nicht, wie gesagt das einzige was möglich ist, ist beim Routed Setup zum Host und zurück pingen aber mehr auch nicht.

chris12
04.09.15, 13:33
Damit tuts, nehme ich an?

maxpower
04.09.15, 13:03
Das ist mittlerweile so.
Code:
# The loopback network interface
auto lo
iface lo inet loopback

# for Routing
auto vmbr1
iface vmbr1 inet manual
        post-up /etc/pve/kvm-networking.sh
        #bridge_ports dummy0
        bridge_ports none
        bridge_stp off
        bridge_fd 0


# vmbr0: Bridging. Make sure to use only MAC adresses that were assigned to you.
auto vmbr0
iface vmbr0 inet static
        address 188.165.212.185
        netmask 255.255.255.0
        network 188.165.212.0
        broadcast 188.165.212.255
        gateway 188.165.212.254
        bridge_ports eth0
        bridge_stp off
        bridge_fd 0

chris12
04.09.15, 12:49
eth0 auf deinem Grundsystem darf keine Adressen enhalten, sondern nur die bridge. Schließlich soll diese stellvertretend dies übernehmen.

maxpower
04.09.15, 11:44
Ja das Problem besteht noch. Die Module sind geladen. Fehlermeldungen gibt es keine. Das Problem ist einfach nach wie vor das keine VM von außen erreichbar ist, und ich von den VM auch nicht raus komme.

Ich habe jetzt eine VM mit dem Bridge Setup (vmbr0), und ein Routet Setup (vmbr1)
http://hilfe.ovh.de/proxmox

Beim Routed Setup kann ich zum Host und zurück pingen aber mehr auch nicht.

Hannobal
04.09.15, 09:22
Zitat Zitat von maxpower
Genau es handelt sich um KVM, die VMac ist zugewiesen und eingetragen.

virtio=00:50:56:04:42:73,bridge=vmbr0

Interface vom Host:
Code:
# The primary network interface
# auto eth0
iface eth0 inet manual

# vmbr0: Bridging. Make sure to use only MAC adresses that were assigned to you.
auto vmbr0
iface vmbr0 inet static
        address 188.165.212.185
        netmask 255.255.255.0
        network 188.165.212.0
        broadcast 188.165.212.255
        gateway 188.165.212.254
        bridge_ports eth0
        bridge_stp off
        bridge_fd 0
Besteht das Problem noch? Wie äußert sich das Problem? Bringt Proxmox irgendeine Fehlermeldung?

Die letzte Netzwerk Config, die du für den Host gepostet hast, passt (allerdings fehlt dort auch das lo Interface, weiß nicht ob das zulässig ist). Das davor nicht. Dann der VM einfach ein Ethernetport mit Link auf vmbr0 erstellen, die vMac einfügen (hast du ja gemacht) und das System installieren.

Ich habe meinen Server durch debootstrap im Rescue System installiert (verwende also nicht das Standardsystem von OVH) und das habe ich ebenfalls mal reingehauen (sicherheitshalber :P):
/etc/modules:
Code:
kvm
kvm_intel
Außerdem nutze ich den Proxmox Kernel 3.10. Läuft sehr stabil, muss aber manuell nachinstalliert werden.

Nach der Installation, am Beispiel von Ubuntu:

/etc/network/interfaces:
Code:
auto lo eth0
iface lo inet loopback

auto eth0
iface eth0 inet static
      address 176.yy.207.201
      netmask 255.255.255.255
      broadcast 176.yy.207.201
      post-up route add 188.xxx.212.254 dev eth0
      post-up route add default gw 188.xxx.212.254
      pre-down route del 188.xxx.212.254 dev eth0
      pre-down route del default gw 188.xxx.212.254
/etc/resolvconf/resolv.conf.d/base (Nach editieren dieser Datei die VM restarten):
Code:
nameserver 208.67.222.222
nameserver 208.67.220.220

maxpower
03.09.15, 18:29
Genau es handelt sich um KVM, die VMac ist zugewiesen und eingetragen.

virtio=00:50:56:04:42:73,bridge=vmbr0

Interface vom Host:
Code:
# The primary network interface
# auto eth0
iface eth0 inet manual

# vmbr0: Bridging. Make sure to use only MAC adresses that were assigned to you.
auto vmbr0
iface vmbr0 inet static
        address 188.165.212.185
        netmask 255.255.255.0
        network 188.165.212.0
        broadcast 188.165.212.255
        gateway 188.165.212.254
        bridge_ports eth0
        bridge_stp off
        bridge_fd 0

maxs97
03.09.15, 17:53
Anhand deiner Config gehe ich mal davon aus das es sich hier um KVM Virtualisierung handelt, richtig?
Die Configs sehen in diesem Fall gut aus. Hast du im OVH Manager den IPs eine vMac zugewiesen und diese in Proxmox eingetragen?
Wie ist Proxmox konfiguriert? (Insbesondere die Netzwerkkarte der VM)

maxpower
03.09.15, 14:38
Hallo,

ich versuche jetzt seid 2 Tagen Proxmox zum laufen zu bekommen, aktuell bekomme ich keine VM online. Ich habe für die Virtuellen Maschinen einen /30 Block gemietet. Irgendwie finde ich den Fehler nicht. Es wäre nett wenn da mal jemand rüber schauen kann.

Betriebssystem: VPS Proxmox VE 3.4 (64bits)
Konfiguriert ist das ganze nach: http://hilfe.ovh.de/BridgeClient

Host:
sysctl.conf
Code:
# Disable IPv6 autoconf
#net.ipv6.conf.all.autoconf = 0
#net.ipv6.conf.default.autoconf = 0
#net.ipv6.conf.vmbr0.autoconf = 0
#net.ipv6.conf.all.accept_ra = 0
#net.ipv6.conf.default.accept_ra = 0               
#net.ipv6.conf.vmbr0.accept_ra = 0    
#net.ipv6.conf.vmbr0.accept_ra = 0
#net.ipv6.conf.vmbr0.autoconf = 0

# ipv4 settings
net.ipv4.ip_forward = 1
net.ipv4.conf.default.forwarding = 1
net.ipv4.conf.all.forwarding = 1
net.ipv4.conf.default.send_redirects = 1
kernel.sysrq = 1

# ipv6 settings
net.ipv6.conf.all.forwarding = 1
net.ipv6.conf.default.forwarding = 1
net.ipv6.conf.default.accept_redirects = 1

net.ipv6.conf.eth0.autoconf = 0
net.ipv6.conf.eth0.accept_ra = 0
net.ipv6.conf.all.accept_redirects = 0                
net.ipv6.conf.all.router_solicitations = 1
net.ipv6.conf.default.proxy_ndp = 1          
net.ipv6.conf.all.proxy_ndp = 1
interfaces:
Code:
# device: eth0
auto  eth0
iface eth0 inet static
        address 188.xxx.212.185
        netmask 255.255.255.0
        network 188.xxx.212.0
        broadcast 188.xxx.212.255
        gateway 188.xxx.212.254

# vmbr0: Bridging. Make sure to use only MAC adresses that were assigned to you.
auto vmbr0
iface vmbr0 inet static
        address 188.xxx.212.185
        netmask 255.255.255.0
        network 188.xxx.212.0
        broadcast 188.xxx.212.255
        gateway 188.xxx.212.254
        bridge_ports eth0
        bridge_stp off
        bridge_fd 0
#       up ip route add 176.yy.207.200 dev vmbr0
#       up ip route add 176.yy.207.201 dev vmbr0
#       up ip route add 176.yy.207.202 dev vmbr0
Client:
Code:
auto lo eth0
iface lo inet loopback
iface eth0 inet static
address 176.yy.207.201
netmask 255.255.255.255
broadcast 176.yy.207.201
post-up route add 188.xxx.212.254 dev eth0
post-up route add default gw 188.xxx.212.254
pre-down route del 188.xxx.212.254 dev eth0
pre-down route del default gw 188.xxx.212.254