We are in the process of migrating this forum. A new space will be available soon. We are sorry for the inconvenience.

Error 503 und massive slow downs


dabla
29.06.15, 20:03
generelle auslastung des servers mit top oder htop checken

Janko
29.06.15, 17:25
Größe der Logfiles? Zugriffszahlen? LoadWerte?

king72
28.06.15, 19:50
Hallo liebe Gemeinde,

ich derzeit ein Problem mit meinem Debian Linux 7.5 Server in Verbindung mit i-MSCP 1.1.11, Build: 20140608, Codename: Eagle.
Im Prinzp läuft nur eine Domain mit zwei Subdomains auf dem Server.
Eine der Subdomains mit SSL für bisschen OwnCloud.
Die andere Subdomain für einen Imageservice zum Bilder uploaden usw.

Jedoch hab ich das Problem, daß der Server bzw. die Seite nach einiger Zeit 'stehen' bleibt und nur noch Error 503 ausgibt.
In der Errorlogs, die ich auch gerne zeigen kann, wenn gewünscht, sehe ich nichts, was auf dieses Verhalten schliessen lässt.
Es seinn angemerkt, daß ich jetzt nicht der Profi bin, was Errorlogs angeht, aber Google ist dein Freund.

Eine Sache konnte ich auch auf das Lograte zurückführen. Also probierte ich nach kurzer Suche hier, einen kleinen Befehl via SSH aus:

Code:
logrotate -f /etc/logrotate.d/apache2
Die Seite lief danach wieder wie geschmiert!
Also legte ich einen Cronjob an, der diesen Befehl alle Stunde ausführte. Reichte aber nicht!
Slow downs passierten dazwischen immer noch. Also alle 30 Minuten. Immer noch zu wenig!
Jetzt alle 20 Minuten! Geht grad so.....

Leider weiss ich nicht weiter, und kann mir das auch nicht erklären.
Vlt. kann mir einer etwas auf die Sprünge helfen?
An was kann es liegen?
Welche Logs sind denn wirklich wichtig? Apache2 oder auch andere?

Achja, eigentlich mache ich nicht wirklich viel mit Servern. Jedoch wurde mir das ganze einfach aufs Auge gedrückt.
Und jetzt soll ich wissen woher das kommt

Aber evtl. kann mir einer von hier sagen, was da schief läuft.
Sollten Logs benötigt werden, einfach sagen.

Bin über jede Hilfe sehr dankbar!!