We are in the process of migrating this forum. A new space will be available soon. We are sorry for the inconvenience.

Virtualisierung Failover-IP


Varity
09.06.15, 20:04
Ich danke dir nochmal, der fehler lag leider in der /etc/network/interfaces. (Ein einfacher Rechtschreibfehler)
Anschließend networking neugestartet und es funzt. Ich danke dir noch einmal. Hast mir echt viel Zeit gespart und wünsche dir noch einen schönen Abend :-)

EvilMoe
09.06.15, 19:48
Es muss eine IPv4 Adresse angezeigt werden. OVH sollte ausgewählt werden bei der vMAC.


EDIT: Warum KVM? Wenn du keinen speziellen Kernel benötigst ist OpenVZ schneller einzurichten und performanter.

Varity
09.06.15, 19:37
Unter ifconfig wird mir inet6 addr angezeigt aber die ipv4 Adresse nicht, fehlkonfiguration, oder soweit in Ordnung? Und ich probiere auch direkt mal das Szenario mit der neuen vMAC. Und noch einmal danke ich dir.

Edit: Bei der erstellung der virtuellen Mac Adresse gibt es die auswahl zwischen ovh und vmware. Vorher hatte ich vmware ausgewählt, war das soweit korrekt?

EvilMoe
09.06.15, 19:26
Wenn du sich bist das deine config richtig ist (ifconfig), würde ich die vMAC löschen und eine neue erstellen lassen.

Varity
09.06.15, 19:17
Ich habe die Option gewählt, wo ich die Konfiguration später manuell ändern würde. vMac überprüfe ich wie am bestem? Und schonmal danke für deine Zeit

Edit: Hab direkt im Bridge Modus installiert.

EvilMoe
09.06.15, 19:12
Hast du jetzt mit NAT installiert bzw. die NIC Konfig nachträglich geändert? Dann musst du den vServer runterfahren und dann hochfahren (kein neustart).
vMAC ggf. überprüfen.

Varity
09.06.15, 19:11
Leider kein Erfolg. Scheint beides zu sein also DNS und die normale Verbindung. Hat debian standartmäßig irgendwie Firewall regeln aktiv, die das unterbinden könnten?

EvilMoe
09.06.15, 19:04
Versuch mal
ifconfig eth0 down && ifconfig eth0 up
Nur DNS geht nicht?

Varity
09.06.15, 19:00
Habe nun die /etc/network/interfaces bearbeitet. Anschließend wie in der Anleitung noch die /etc/resolv.conf.
Dann folgendes ausgeführt:

Code:
systemctl enable systemd-networkd.service
systemctl start systemd-networkd.service
Warum, weshalb gibt es hierzu noch keinen Erfolg(Ein einfacher Ping www.google.de brachte kein Erfolg)?
Bin etwas eingerostet was Linux/Debian angeht. Bräuchtet ihr noch weitere Infos, oder habt ihr hierzu auch noch eine Idee?

EvilMoe
09.06.15, 18:52
Weil bei der Installation die Konfiguration nach Schema F überprüft wird. OVH nutzt hier aber eine "sehr spezielle" Konfiguration. (gibts dafür einen Namen?)

Bei der Subnetzmaske 255.255.255.255 (/32) kann bei der IP 149.202.x.x das Gateway nicht 94.24.x.254 sein.
Da diese in unterschiedlichen Netzen liegen und können sich somit gegenseitig nicht erreichen.

Ich habe mich auch schon mal gefragt wie das eigentlich funktioniert, so weit kenne ich mich mit CISCO dann doch wiederum nicht aus.

Varity
09.06.15, 18:41
Zitat Zitat von LukasK
Ja die daten sind richtig. Mach die Installation von Debian ohne Netzwerkkonfiguration und ändere danach die entsprechenden Datein wie hier gezeigt:
http://hilfe.ovh.de/BridgeClient
Auch dir ein Dankeschön, warum ist das eigentlich so? Ich dachte dieser Fehler würde irgendwie mit meiner Konfiguration zusammen hängen und das obwohl mir soweit alles richtig schien. Ich werde nacher noch hier reinposten, wenn ich zuhause bin und die Sache zuende konfigurieren konnte.

LukasK
09.06.15, 18:37
Ja die daten sind richtig. Mach die Installation von Debian ohne Netzwerkkonfiguration und ändere danach die entsprechenden Datein wie hier gezeigt:
http://hilfe.ovh.de/BridgeClient

Varity
09.06.15, 18:19
Zitat Zitat von EvilMoe
Es sollte die virtIO genutzt werden da die die beste Performance erreicht. Nichts*des*to*trotz sollten die anderen genauso funktionieren.

Installiert das System erst so und ändere die Netzwerkkonfig manuell, das funktioniert.
Alles klar danke, die Daten sind aber so richtig, wie ich die aufgeschrieben habe, oder?

EvilMoe
09.06.15, 18:16
Es sollte die virtIO genutzt werden da die die beste Performance erreicht. Nichts*des*to*trotz sollten die anderen genauso funktionieren.

Installiert das System erst so und ändere die Netzwerkkonfig manuell, das funktioniert.

Varity
09.06.15, 17:40
Guten Tag,

leider habe ich Probleme. Auf meinem Server läuft aktuell Proxmox. (Mein Server hat die IP: 94.24.x.x)
Zusätzlich habe ich eine Failover IP bestellt(149.202.x.x).

Unter Proxmox habe ich die generierte Mac Adresse aus dem Manager in meinem debian clienten, welches virtualisiert werden soll eingefügt.
Hier besteht schon die erste Frage, die Netzwerkkarte muss ja im Bridged Mode sein. Wie schaut es mit den Netzwerkkartenmodellen aus? Ich habe folgende zur Auswahl:

  • intel e1000
  • virtIO (paravirtualized)
  • Realtec RTL8139
  • VMWare vmxnet3

Welches ist nun das eigentlich richtige, und woran erkennt man das?

Wenn ich dann unter Debian die Netzwerkkonfiguration vornehmen soll, gebe ich folgende Daten an:
  1. IP Adresse:149.202.x.x
  2. Netzmaske:255.255.255.255
  3. Gateway 94.24.x.254


Leider kriege ich die Fehlermeldung das dieser Gateway nicht erreichtbar ist, wo mache ich den Fehler? Best regards,