We are in the process of migrating this forum. A new space will be available soon. We are sorry for the inconvenience.

FreeBSD Netzwerk-Einstellungen


P. Bachus
30.04.15, 13:46
Kann dir gerne helfen, sofern noch Bedarf besteht.
Schreibe mir einfach eine PN.

Grüße

Pierre
21.04.15, 15:56
Guten Tag zusammen,

mir wurde nun heute seitens von OVH gesagt das ich nun eine Konfiguration in FreeBSD machen soll.
Ich verwende mittlerweile FreeBSD 10.1 und möchte aktuell immer nur probieren eine Verbindung herzustellen.

Verwendet jemand von euch zufälligerweise derzeit ebenfalls FreeBSD um mir bei der Konfiguration zu helfen, den die Konfiguration die auf hilfe.ovh.de/bridgeclient steht scheint keineswegs zu funktionieren.

Von FreeBSD 7-10 alles probiert und möchte lediglich FreeBSD 10.1 zum laufen bekommen oder gibt es einen externen Service der gegen eine Gebühr sowas macht?

Mit freundlichen Gruß
Pierre Neumann

P.s. Die Maschine läuft als VM auf dem Server

Pierre
11.04.15, 00:23
Da gebe ich dir wohl recht strex. Wie bereits von mir gesagt dient das ganze ja im Moment mit dem FreeBSD Server lediglich um mich einmal einzuarbeiten, was hierbei total schief läuft

Wenn ich dabla richtig versteh dient das dazu einen Alias auf dem Rootserver zu hinzufügen, dabei versuche ich mich an der Konfiguration auf einem vServer der durch Proxmox virtualisiert wird.
Ich muss wirklich zugeben das ich bei diesem System gar nicht mehr durchblicke, da ich nirgends eine komplexere Konfiguration als bei FreeBSD gefunden habe und nur scheitere.

strex
11.04.15, 00:05
Zitat Zitat von Pierre
Metin Server
Die lieben illegalen Metin Server, dass verschwindet auch nicht. Kommen ja immer wieder Anfragen wegen spezieller Konfiguration

dabla
10.04.15, 21:15
ich zitiere mal einfach aus der hilfeseite:
FreeBSD


Zuerst müssen Sie die Bezeichnung der Netzwerkkarte Ihres Systems kennen um die beschriebene Vorgehensweise nachvollziehen zu können. In diesem Beispiel re0.
nsXXX# ifconfig
re0: flags=8843 metric 0 mtu 1500
options=389b

Mit folgender Zeile wird die Fail-Over-IP 87.98.242.155 in die Netzwerkkonfiguration integriert:
ifconfig re0 87.98.242.155 netmask 255.255.255.255 broadcast 87.98.242.155 alias

Damit die Fail-Over-IP auch nach einem Reboot aktiv ist, muss folgende Zeile in /etc/rc.conf eingefügt werden:
ifconfig_re0_alias0="inet 87.98.242.155 netmask 255.255.255.255"

Die Konfiguration sollte dann etwa so aussehen:
nsXXX# ifconfig
re0: flags=8843 metric 0 mtu 1500
options=389b
ether 00:19:d1:8c:95:26
inet 91.121.XXX.XXX netmask 0xffffff00 broadcast 91.121.XXX.255
inet 87.98.242.155 netmask 0xffffffff broadcast 87.98.242.155
media: Ethernet autoselect (100baseTX )
status: active

uisge
10.04.15, 20:50
Zitat Zitat von Pierre
ifconfig_em0="inet FAILOVERIP netmask 255.255.255.0 broadcast FAILOVERIP"
defaultrouter="IP.DES.SERVERS.254"
ifconfig_em0_aliases="inet FAILOVERIP/32"

Bitte korrigiere mich falls ich falsch liege.
Du mußt auf em0 die Hardware-IP und *nicht* die FAILOVERIP anlegen, sofern ich nicht irre.
Ganz sicher falsch: die Broadcast-Adresse endet mit einem ".255"!

Also nochmal:

| ifconfig_em0="inet aaa.bbb.ccc.ddd netmask 255.255.255.0 broadcast aaa.bbb.ccc.255"
| defaultrouter="aaa.bbb.ccc.254"

Hierbei ist aaa.bbb.ccc.ddd deine IP.DES.SERVERS.

Viel Glück, aber bedenke bitte: FBSD 7.2 erfährt keine Security-Fixes mehr!

Pierre
10.04.15, 20:29
Hallo uisge und vielen Dank für deine Antwort

Also FreeBSD 7.2 soll für ein späteren Metin Server verwendet werden deswegen möchte ich mich erst einmal einarbeiten in Debian.

Also eingestellt habe ich nun folgendes in der /etc/rc.conf

ifconfig_em0="inet FAILOVERIP netmask 255.255.255.0 broadcast FAILOVERIP"
defaultrouter="IP.DES.SERVERS.254"
ifconfig_em0_aliases="inet FAILOVERIP/32"

Bitte korrigiere mich falls ich falsch liege.

uisge
10.04.15, 20:14
Zitat Zitat von Pierre
ifconfig_em0="inet IP.FA.IL.OVER netmask 255.255.255.255 broadcast IP.FA.IL.OVER

Das ist IMHO falsch, versuche einmal:

| ifconfig_em0=
"inet aaa.bbb.ccc.ddd netmask 255.255.255.0 broadcast aaa.bbb.ccc.255"

| defaultrouter="aaa.bbb.ccc.254"

Beachte die endständigen "0", "255" bzw "254"

Die IP.FA.IL.OVER dann als alias definieren a la:

| ifconfig_em0_aliases="inet 46.105.45.86/32"

Zitat Zitat von Pierre
Ich verwende FreeBSD 7.2
Diese Version ist steinzeitlich alt und wird längst nicht mehr unterstützt.

Zitat Zitat von Pierre
Eventuell kann mir jemand bei diesem Problem helfen.
Ich kann Dir nur dringend empfehlen, ein aktuelles FBSD (9 oder besser gleich 10) über den OVH-Manager zu installieren und an dessen Defaultkonfigurationen zu lernen. Ich bezweifele, daß ein veraltetes 7.2 zielführend ist, sich in FBSD einzuarbeiten. Alle aktuellen Anleitungen im Netz betreffen >= FBSD 9, sofern ich nicht irre ;-)

[edit: IP-Adresse korrigiert, automatische Rechtschreibkorrekturen sind ]

Pierre
10.04.15, 19:42
Niemand eine Idee?

Pierre
09.04.15, 13:32
Guten Tag zusammen ich nochmals

Ich versuche mich derzeit mit FreeBSD auseinanderzusetzen. Mein Problem fängt bereits da an, dass die Maschine kein Internet bekommt oder zumindest den host nicht auflösen kann.

meine rc.conf sieht folgendermaßen aus:

hostname="ks27.name.de"
ifconfig_em0="inet IP.FA.IL.OVER netmask 255.255.255.255 broadcast IP.FA.IL.OVER
static_routes="net1 net2"
route_net1="-net IP.DES.SERVERS.254/32 IP.FA.IL.OVER"
route_net2="default IP.DES.SERVER.254"
keymap="german.iso"
linux_enable="YES"
sshd_enable="YES"

resolv.conf

nameserver 213.186.33.99
nameserver 8.8.8.8

Ich verwende FreeBSD 7.2
Eventuell kann mir jemand bei diesem Problem helfen.