We are in the process of migrating this forum. A new space will be available soon. We are sorry for the inconvenience.

Failover IP Config Debian 7


maxs97
21.02.15, 23:37
Hey, tut mir leid. Aus irgend einem Grund hatte ich noch im Kopf das es um eine VM geht.

uid
21.02.15, 20:19
Warum sollte unter eth0 die Failover IP eingetragen werden?!

maxs97
21.02.15, 15:57
Naja, deine Netzwerkkonfiguration ist immer noch nicht korrekt.

auto eth0
iface eth0 inet static
address Failover.IP
netmask 255.255.255.255
broadcast Failover.IP
post-up route add Hauptip.254 dev eth0
post-up route add default gw Hauptip.254
post-down route del Hauptip.254 dev eth0
post-down route del default gw Hauptip.254

uid
21.02.15, 13:41
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

auto eth0
iface eth0 inet static
address HAUPT-IP
netmask 255.255.255.0
network HAUPT-IP.0
broadcast HAUPT-IP.255
gateway HAUPT-IP.254

iface eth0 inet6 static
address HAUPT-IPv6
netmask 64
post-up /sbin/ip -family inet6 route add HAUPT-IPv6 dev eth0
post-up /sbin/ip -family inet6 route add default via HAUPT-IPv6
pre-down /sbin/ip -family inet6 route del default via HAUPT-IPv6
pre-down /sbin/ip -family inet6 route del HAUPT-IPv6 dev eth0

auto eth0:0
iface eth0:0 inet static
address FAILOVER-IP1
netmask 255.255.255.255

auto eth0:1
iface eth0:1 inet static
address FAILOVER-IP2
netmask 255.255.255.255

auto eth0:2
iface eth0:2 inet static
address FAILOVER-IP3
netmask 255.255.255.255

auto eth0:3
iface eth0:3 inet static
address FAILOVER-IP4
netmask 255.255.255.255
Ein Neustart wurde bereits mehrmals in den letzten Tagen durchgeführt.

maxs97
21.02.15, 13:37
Schicke uns doch einfach nochmal deine komplette Konfiguration. Davon abgesehen solltest du versuchen den Server komplett neu zu starten, ich verweise mal auf folgendes:
running /etc/init.d/networking restart is deprecated because it may not r[warnble some interfaces ... (warning).

uid
21.02.15, 12:33
Ich verstehe es einfach nicht, auch damit nicht.

root@XXXXXXXX:~# service networking restart
[....] Running /etc/init.d/networking restart is deprecated because it may not r[warnble some interfaces ... (warning).
[....] Reconfiguring network interfaces...RTNETLINK answers: File exists
Failed to bring up eth0.
RTNETLINK answers: File exists
RTNETLINK answers: File exists
RTNETLINK answers: File exists
RTNETLINK answers: File exists
RTNETLINK answers: File exists
RTNETLINK answers: File exists
RTNETLINK answers: File exists
RTNETLINK answers: File exists
RTNETLINK answers: File exists
RTNETLINK answers: File exists
done.
IPs funktionieren weiterhin einwandfrei, trotz der Fehler.

dabla
20.02.15, 21:07
Zitat Zitat von Bluescreen
Also ich habe damals vom Support einen Schnipsel geschickt bekommen, da ich trotz funktionierender IP die Mails bekommen hatte, seit dem funktioniert das ganze ohne Probleme.

auto eth0:0
iface eth0:0 inet static
address Failover-IP
netmask 255.255.255.255
das sollte ausreichen wenn in eth0 alle werte richtig drinstehen... das sollte etwa so aussehen:

auto eth0
iface eth0 inet static
address Failover.IP
netmask 255.255.255.255
broadcast Failover.IP
# dns-* options are implemented by the resolvconf package, if installed
dns-nameservers 8.8.8.8 8.8.4.4
post-up route add Hauptip.254 dev eth0
post-up route add default gw Hauptip.254
post-down route del Hauptip.254 dev eth0
post-down route del default gw Hauptip.254

damit sollte es dann problemlos laufen

Bluescreen
20.02.15, 21:00
Also ich habe damals vom Support einen Schnipsel geschickt bekommen, da ich trotz funktionierender IP die Mails bekommen hatte, seit dem funktioniert das ganze ohne Probleme.

auto eth0:0
iface eth0:0 inet static
address Failover-IP
netmask 255.255.255.255

dabla
20.02.15, 17:58
probier es mit
ifdown eth0 && ifup eth0
und das ganze auch für deine anderen interfaces also 0:1 0:2 etc. dann sollte es keine PRobleme geben

uid
20.02.15, 15:01
Vielen Dank euch beiden.

mit meiner alten und auch mit denis' seiner Config kommt stets der selbe Fehler (ja, "network" wurde mit "netmask" ersetzt!):

root@XXXXXXXXX:~# service networking restart
[....] Running /etc/init.d/networking restart is deprecated because it may not r[warnble some interfaces ... (warning).
[....] Reconfiguring network interfaces...RTNETLINK answers: File exists
Failed to bring up eth0.
RTNETLINK answers: File exists
RTNETLINK answers: File exists
RTNETLINK answers: File exists
RTNETLINK answers: File exists
RTNETLINK answers: File exists
RTNETLINK answers: File exists
RTNETLINK answers: File exists
RTNETLINK answers: File exists
RTNETLINK answers: File exists
RTNETLINK answers: File exists
done.
Ich verzweifel langsam...

Lisa
20.02.15, 14:43
Hallo Uid,

in der entsprechenden Hilfe hat sich ein Fehler eingeschlichen.

Es muss einfach "netmask" statt "network" heißen.

Dann sollte alles problemlos funktionieren.

Liebe Grüße,
Lisa

denis
20.02.15, 14:20
So mache ich es seit Jahren problemlos:

auto eth0:1
iface eth0:1 inet static
address FAILOVERIP
netmask 255.255.255.0
network FAILOVERIP mit 0 am Ende
broadcast FAILOVERIP mit 255 am Ende

uid
20.02.15, 13:59
Hallo,

leider bekomme ich via Ticketsystem seit fast einer Woche (!) keine Antwort vom Support, daher versuche ich nun mein Glück hier im Forum.

Wie der Titel schon sagt, geht es um die Konfiguration mehrerer Failover IPs in der Network-Config. Ich habe es eigentlich gewissenhaft laut OVH Hilfe (http://hilfe.ovh.de/AdministrationIpAliasHinzufuegen - Punkt "Debian 6 & 7") konfiguriert, dennoch kommen Emails von OVH mit:

"Hallo, über die Failover-IP XX.XXX.XXX.XXX Ihres Servers nsXXXXXXX.ip-XXX-XXX-XXX.eu wird eine unverhältnismäßig große Anzahl an Suchanfragen auf dem Netzwerk ausgeführt. Dies hängt mit der Konfiguration Ihrer Failover-IP zusammen."
Die Konfiguration ist derzeit wie folgt:

auto eth0:0
allow-hotplug eth0:0
iface eth0:0 inet static
address XX.XXX.XXX.XXX
network 255.255.255.255

auto eth0:1
allow-hotplug eth0:1
iface eth0:1 inet static
address XX.XXX.XXX.XXX
network 255.255.255.255

auto eth0:2
allow-hotplug eth0:2
iface eth0:2 inet static
address XX.XXX.XXX.XXX
network 255.255.255.255

auto eth0:3
allow-hotplug eth0:3
iface eth0:3 inet static
address XX.XXX.XXX.XXX
network 255.255.255.255

---------------------


Beim Neustart des Services kommt zudem noch folgender Fehler:

root@nsXXXXXXX:~# service networking restart
[warn] Running /etc/init.d/networking restart is deprecated because it may not re-enable some interfaces ... (warning).
[....] Reconfiguring network interfaces...
RTNETLINK answers: File exists Failed to bring up eth0.
RTNETLINK answers: File exists
RTNETLINK answers: File exists
done.

Komischerweise funktionieren die IPs dennoch und sind via Webserver und Co. aufrufbar.

Danke schon mal im Voraus für eure Hilfe!