We are in the process of migrating this forum. A new space will be available soon. We are sorry for the inconvenience.

DHCP& Promox


DennisH
21.01.15, 00:36
Halli-Hallo,

wir haben es versucht und versucht und versucht..

Problem ist folgendes: Wir möchten die IPVergabe automatisch via DHCP lösen. Die MACs sind kein Problem, die ordnet unser Modul automatisch zu. Es geht nun nur um die reine Verbindung.

Wir bekommen inzwischen eine Verbindung zwischen VM (Windows Server 2008; KVM) und Node (Hostserver Proxmox) zustande. Pings sind auf beiden Seiten möglich.

Jedoch bekommen wir keine Verbindung nach Außen (Von der VM). Pings zu google o.Ä. -> Zeitüberschreitung.

Die VM bootet, DHCP weist die IP zu, MAC ist ebenfalls korrekt, jedoch scheint irgendetwas in der Konfiguration falsch zu sein.

dhcp.conf:

Code:
ddns-update-style none;
default-lease-time 600;
max-lease-time 7200;
log-facility local7;
option rfc3442-classless-static-routes code 121 = array of integer 8;
option ms-classless-static-routes code 249 = array of integer 8;
subnet 151.80.85.64 netmask 255.255.255.192 {

option routers 151.80.85.65;
 option broadcast-address 151.80.85.127;
 option ntp-servers 151.80.85.65;
 option domain-name-servers 213.186.33.99;
 option netbios-name-servers 213.186.33.99;
 option netbios-node-type 2;
 default-lease-time 86400;
 max-lease-time 86400;
option rfc3442-classless-static-routes 26, 151, 80, 85, 64, 0, 0, 0, 0, 0, 151, 80, 85, 65;
authoritative;
option ms-classless-static-routes 26, 151, 80, 85, 64, 0, 0, 0, 0, 0, 151, 80, 85, 65;
  #vmbr1ipv4
/network/interfaces:

Code:
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# for Routing
#auto vmbr1
#iface vmbr1 inet manual
#	post-up /etc/pve/kvm-networking.sh
#	bridge_ports dummy0
#	bridge_stp off
#bridge_fd 0


auto vmbr1
iface vmbr1 inet static
        address 151.80.85.65
        netmask 255.255.255.192
        bridge_ports none
        bridge_stp off
        bridge_fd 0

# vmbr0: Bridging. Make sure to use only MAC adresses that were assigned to you.
auto vmbr0
iface vmbr0 inet static
	address 178.33.226.54
	netmask 255.255.255.0
	network 178.33.226.0
	broadcast 178.33.226.255
	gateway 178.33.226.254
	bridge_ports eth0
	bridge_stp off
	bridge_fd 0
Wir verwenden vmbr1, sollte an sich ja kein Problem geben. Nur wo liegt das Problem??

Verwendung aus der Mail @OVH:

Code:
Guten Tag,

gemäß Ihrer Anfrage haben wir soeben einen Block von 64 IP-Adressen zugeteilt, die über 178.33.226.54 geroutet werden:

 151.80.85.64/26

Sie können die IP-Adressen dieses Blocks auf zwei verschiedene Arten verwenden:

1. Konfiguration auf einem Dedicated Server:

   Bei dieser Variante können alle IP-Adressen Ihres Blocks 151.80.85.64/26 verwendet werden.

   Für die Konfiguration können Sie folgende Hilfen zu Rate ziehen:

   - Wenn die IP-Adressen in Virtuellen Maschinen auf dem Server verwendet werden: http://hilfe.ovh.de/BridgeClient

   - Wenn die IP-Adressen auf dem Netzwerk-Interface Ihres Servers verwendet werden: http://hilfe.ovh.de/AdministrationIpAliasHinzufuegen

   Alle IP-Adressen müssen die Netzmaske (netmask) 255.255.255.255 und als Gateway die Haupt-IP-Adresse Ihres Servers mit .254 als letztem Oktett (xxx.xxx.xxx.254) verwenden!

2. Konfiguration in einem Virtual Rack oder einer Dedicated Cloud:

   Wenn Sie Ihren Block in einem Virtual Rack oder einer Dedicated Cloud verwenden, müssen folgende Adressen freigegeben werden:

   Netzwerk-IP     : 151.80.85.64 
   IP für den Router Nummer 1 : 151.80.85.124
   IP für den Router Nummer 2 : 151.80.85.125
   Gateway-IP      : 151.80.85.126 (nicht nutzbar)
   Broadcast-IP    : 151.80.85.127 

   Verwenden Sie in diesem Fall die Netzmaske 255.255.255.192.

Zur Information hier die detaillierten Angaben Ihres IP-Blocks:

   151.80.85.64/26
   Netzwerk-IP     : 151.80.85.64 
   Broadcast-IP    : 151.80.85.127 
   Gateway-IP      : 151.80.85.126
   Netmask         : 255.255.255.192
Ich hoffe ihr findet den Fehler, weshalb wir keine Verbindung nach außen zustande bekommen.

#Kleine Idee:

Würde es nicht bereits reichen, wenn DHCP nur das Gateway& die IP& co vergibt? Die IPs sind ja standardmäßig bereits auf dem Server geroutet, so spart man die Interfaces-config.
Einfach unter vmbr0. Wie ist das zu lösen??