We are in the process of migrating this forum. A new space will be available soon. We are sorry for the inconvenience.

FTP Server Problem


Magnus
16.12.14, 09:42
Danke für deinen Tipp leider werde ich nicht ganz schlau draus da mein Englisch nicht das beste ist.
noch zur info wenn ich eine Domain Benutzer über Plesk anlege geht alles.

Auszug aus der proftpd.conf

#
# To have more informations about Proftpd configuration
# look at : http://www.proftpd.org/
#

# This is a basic ProFTPD configuration file (rename it to
# 'proftpd.conf' for actual use. It establishes a single server
# and a single anonymous login. It assumes that you have a user/group
# "nobody" and "ftp" for normal operation and anon.

ServerName "ProFTPD"
#ServerType standalone
ServerType inetd
DefaultServer on


DefaultRoot ~
AllowOverwrite on

# common settings for all virtual hosts
TLSEngine on
TLSRequired on

TLSLog /var/log/plesk/ftp_tls.log

TLSRSACertificateFile /usr/local/psa/admin/conf/httpsd.pem
TLSRSACertificateKeyFile /usr/local/psa/admin/conf/httpsd.pem

# Authenticate clients that want to use FTP over TLS?
TLSVerifyClient off

# Allow SSL/TLS renegotiations when the client requests them, but
# do not force the renegotations. Some clients do not support
# SSL/TLS renegotiations; when mod_tls forces a renegotiation, these
# clients will close the data connection, or there will be a timeout
# on an idle data connection.
TLSRenegotiate none

# As of ProFTPD 1.3.3rc1, mod_tls only accepts SSL/TLS data connections
# that reuse the SSL session of the control connection, as a security measure.
# Unfortunately, there are some clients (e.g. curl) which do not reuse SSL sessions.
TLSOptions NoSessionReuseRequired



DefaultTransferMode binary
UseFtpUsers on

TimesGMT off
SetEnv TZ :/etc/localtime
# Port 21 is the standard FTP port.
Port 21
# Umask 022 is a good standard umask to prevent new dirs and files
# from being group and world writable.
Umask 022

# To prevent DoS attacks, set the maximum number of child processes
# to 30. If you need to allow more than 30 concurrent connections
# at once, simply increase this value. Note that this ONLY works
# in standalone mode, in inetd mode you should use an inetd server
# that allows you to limit maximum number of processes per service
# (such as xinetd)
MaxInstances 30

#Following part of this config file were generate by PSA automatically
#Any changes in this part will be overwritten by next manipulation
#with Anonymous FTP feature in PSA control panel.

#Include directive should point to place where FTP Virtual Hosts configurations
#preserved

ScoreboardFile /var/run/proftpd.scoreboard

# Primary log file mest be outside of system logrotate province

TransferLog /var/log/plesk/xferlog

#Change default group for new files and directories in vhosts dir to psacln


GroupOwner psacln


# Enable PAM authentication
AuthPAM on
AuthPAMConfig proftpd

IdentLookups off
UseReverseDNS off

AuthGroupFile /etc/group

Include /etc/proftpd.d/*.conf

0815-4711
16.12.14, 08:11
Hallo,

könnte helfen: https://forums.proftpd.org/smf/index.php?topic=11182.0

0

Magnus
11.12.14, 15:15
BS Cent OS 7
FTP Server ProFTPd Version 1.35

Ich habe Folgendes Problem und hoffe ihr könnt mir helfen.

Ich habe mit Webmin einen Benutzer XY Erstellt und die Gruppe root zugeordnet als Home Verzeichnis /1
Rchte des Ordner /1 ist 750 Benutzer XY und Gruppe root.

Problem ist ich kann mich mit meinem FTP Programm anmelden aber wenn ich eine Datei hochladen will passiert nichts wenn ich einen neuen Ordner erstellen will kommt die Meldung -140: remote mkdir failed

Hatte auch die Ordnerrechte mal auf 777 gesetzt und da ist das gleiche Problem.

Welches Problem kann da sein?