We are in the process of migrating this forum. A new space will be available soon. We are sorry for the inconvenience.

ks362639 login nach reboot nicht möglich


Isondolos
14.12.13, 16:12
Moin

1. in der auth.log sollte mehr als nur das Zeug von CRON stehen
2. sollten auch Einträge nach dem 8.12. in der auth.log sein, wenn der sshd deinen Loginversuch ablehnt.
grep -v CRON /mnt/var/log/auth.log|less (bei less kannste auch mit den hoch/runter tasten durch den Text scrollen)

Wenn echt keine Einträge nach dem 8. in der Datei stehn is irgendwas ernsthaft kaputt

weitere Ideen hatte ich auch noch gepostet aber du bist nicht drauf eingegangen:
- in der /mnt/etc/ssh/sshd_config checken welche Benutzer sich einloggen dürfen und ggf. anpassen
- sicher stellen, dass das getippte Passwort korrekt ankommt und nicht Sonderzeichen z.B. duch ein Tastaturlayout problem nicht wie erwartet übertragen werden

Wenn du es absolut nicht hin bekommst, sichere die wichtigen Daten von der Kiste und reinstallier

Dyyce
14.12.13, 14:59
Zitat Zitat von Isondolos
Moin,

sieht grundsätzlich ma OK aus. Wenn du jetz von Festplatte startest und dich einloggen willst, sollte das gesetzte Passwort funktionieren.

Wenn nicht, wieder Rescue, mounten und less /mnt/var/log/auth.log um zu sehen was da notiert wurde als du versucht hast einzuloggen.
Ist rootlogin überhaupt erlaubt oder evtl. per sshd config geblockt?
Ist das Passwort, was du bei passwd eintippst auch das, was du denkst, dass du eintippst? Tastaturlayout vermurkst? (=>Passwort mal einfach im normalen Promt tippen um zu sehen ob alle Sonderzeichen auch richtig angenommen werden)
habe das nun getestet und das steht drin:
root@rescue:~# mount /dev/sda1 /mnt/
root@rescue:~# mount /dev/sda2 /mnt/home/
root@rescue:~# less /mnt/var/log/auth.log
Dec 8 06:37:27 ks362639 CRON[9181]: pam_unix(cron:session): session closed for user root
Dec 8 06:38:01 ks362639 CRON[9989]: pam_unix(cron:session): session opened for user root by (uid=0)
Dec 8 06:38:01 ks362639 CRON[9989]: pam_unix(cron:session): session closed for user root
Dec 8 06:39:01 ks362639 CRON[10035]: pam_unix(cron:session): session opened for user root by (uid=0)
Dec 8 06:39:01 ks362639 CRON[10034]: pam_unix(cron:session): session opened for user root by (uid=0)
Dec 8 06:39:02 ks362639 CRON[10034]: pam_unix(cron:session): session closed for user root
Dec 8 06:39:02 ks362639 CRON[10035]: pam_unix(cron:session): session closed for user root
Dec 8 06:40:01 ks362639 CRON[10093]: pam_unix(cron:session): session opened for user root by (uid=0)
Dec 8 06:40:02 ks362639 CRON[10093]: pam_unix(cron:session): session closed for user root
Dec 8 06:41:01 ks362639 CRON[10140]: pam_unix(cron:session): session opened for user root by (uid=0)
Dec 8 06:41:01 ks362639 CRON[10140]: pam_unix(cron:session): session closed for user root
Dec 8 06:42:01 ks362639 CRON[10187]: pam_unix(cron:session): session opened for/mnt/var/log/auth.log




wie bereits erwähnt, vor ein paar Tagen noch hat alles wunderbar funktioniert. Konnte mich schon immer mit root einloggen. Erst nachdem ich einen Reboot gestartet habe, kann ich mich nicht mehr einloggen.
Mittlerweile wähle ich einfache Passwörter wie 111, jedoch ändert er es selbst mit chroot nur für den Rescue Modus

Beim Mounten und ändern des Passworts werden keine Fehlermeldungen angezeigt. Also gehe ich davon aus dass alles passt.
Noch jemand evtl eine Idee was man da sonst noch probieren könnte?
Danke!


Gruß

Isondolos
13.12.13, 19:46
Moin,

sieht grundsätzlich ma OK aus. Wenn du jetz von Festplatte startest und dich einloggen willst, sollte das gesetzte Passwort funktionieren.

Wenn nicht, wieder Rescue, mounten und less /mnt/var/log/auth.log um zu sehen was da notiert wurde als du versucht hast einzuloggen.
Ist rootlogin überhaupt erlaubt oder evtl. per sshd config geblockt?
Ist das Passwort, was du bei passwd eintippst auch das, was du denkst, dass du eintippst? Tastaturlayout vermurkst? (=>Passwort mal einfach im normalen Promt tippen um zu sehen ob alle Sonderzeichen auch richtig angenommen werden)

Dyyce
13.12.13, 19:22
So, hab es nun noch einmal ausprobiert.


root@rescue:~# fdisk -l

Disk /dev/sda: 1000.2 GB, 1000204886016 bytes
255 heads, 63 sectors/track, 121601 cylinders, total 1953525168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disk identifier: 0x000b30a0

Device Boot Start End Blocks Id System
/dev/sda1 * 4096 41947135 20971520 83 Linux
/dev/sda2 41947136 1952468991 955260928 83 Linux
/dev/sda3 1952468992 1953519615 525312 82 Linux swap / Solaris
root@rescue:~# mount /dev/sda1 /mnt
root@rescue:~# mount /dev/sda2 /mnt/home
root@rescue:~# chroot /mnt/
root@rescue:/# passwd
Enter new UNIX password:
Retype new UNIX password:
passwd: password updated successfully
root@rescue:/# exit
exit
root@rescue:~# restart
-bash: restart: command not found
root@rescue:~# /sbin/reboot
root@rescue:~#
The system is going down for reboot NOW!et (pts/0) (Fri Dec 13 18:22:07 2013)


Gruß

Felix
13.12.13, 11:05
Zitat Zitat von Dyyce
> chroot /mnt/ ausgeführt
> mit passwd Passwort geändert
> Sitzung beendet und wieder gestartet um das neue Passwort zu testen --> ich kann mich einloggen OK
Deutet dennoch stark darauf hin, das nur das passwort im rescue-modus geändert wurde - nicht das deiner eigenen installation. Probier's nochmal aus und achte auf eventuelle Fehlermeldungen beim mount oder chroot.

Felix

Dyyce
13.12.13, 10:05
Zitat Zitat von marco
mount /dev/sda1 /mnt
mount /dev/sda2 /mnt
chroot /mnt
passwd
exit
restart

sollte eigentlich gehen
Hallo marco,

ich führe es genau in dieser Reihenfolge aus, außer dass ich vor dem chroot /mnt noch ein mount -a mache (wie in der Anleitung beschrieben) und anstatt restart verwende ich /sbin/reboot (ist es das Selbe?)
Nachdem ich exit verwende, ändere ich noch den Netboot Modus auf HD
Nach dem reboot geht das Passwort, das ich nachdem chroot /mnt geändert habe, leider nicht


Gruß

KS16G
12.12.13, 21:55
Ist das ein Server mit RAID ?
Wenn ja, dann musst du
mount /dev/md1 /mnt
chroot /mnt
passwd
exit
- Boot-modus im Manager auf HD umstellen-
reboot

machen.
Aber vorher überprüfe bitte mal deine sshd-config, ob da ein root-login (mit passwort) überhaupt erlaubt ist. (root-device mounten nach /mnt, chroot /mnt, dann /mnt/etc/ssh/sshd_config überprüfen.)

marco
12.12.13, 21:00
mount /dev/sda1 /mnt
mount /dev/sda2 /mnt
chroot /mnt
passwd
exit
restart

sollte eigentlich gehen

Dyyce
12.12.13, 20:53
hey,

danke für den Tipp.
Hab allerdings alles nach Anleitung gemacht und /dev/sda1 auf /mnt und /dev/sda2 auf /mnt/home gemacht. Anschließend chroot /mnt und dass Passwort geändert. Dann exit und /sbin/reboot.


Gruß

marco
12.12.13, 20:30
hast wahrscheinlich das rescue pw geändert mit passwd. Da du dich mit dem geändert pw ja wie du sagst im rescue neuangemeldet hast.
Hast du mal fdisk -l ausgeführt um zu sehen was du überhaupt mounten musst? Könnte ja auch sein das du evtl /dev/sda1 /dev/sda2 usw mounten musst.
Wenn das der fall ist sollte es klar sein woran es liegt.

Dyyce
12.12.13, 19:35
Hallo mathias,

habe gerade versucht mich einzuloggen. Das Passwort wird nach wie vor geändert und ich kann mich nicht mehr einloggen. Es geschieht wenn ich vom Rescue Modus wieder in den HD Modus wechsle.

Habe die Anleitung des Rescue Modus befolgt
> im OVH Manager den Netboot auf Rescue gewechselt
> Hardware-Reboot aus dem OVH Manager
> login mit Passwort des Rescue Modus (per Email erhalten)
> Partitionen gemountet (/mnt und /mnt/home)
> chroot /mnt/ ausgeführt
> mit passwd Passwort geändert
> Sitzung beendet und wieder gestartet um das neue Passwort zu testen --> ich kann mich einloggen OK
> im OVH Manager den Netboot wieder auf HD
> Soft-Reboot
> nach dem Reboot versucht einzuloggen --> Login nicht möglich, weder mit neuem Passwort noch mit dem Passwort des Rescue Modus.

Habe ich etwas übersehen/falsch gemacht?


Gruß

Dyyce
12.12.13, 09:08
Hi Mathias,

Danke! Werde es später gleich mal testen.


Gruß

mathias
12.12.13, 08:40
Hallo,

damit ein Soft Reboot möglich ist, muss man mit "exit" aus dem chroot raus. Vor dem letzten Hard Reboot scheint der Netboot auch noch nicht gewechselt worden zu sein.
Ich habe den Neustart jetzt veranlasst und Ubuntu scheint wieder zu laufen (?).

Mathias

Dyyce
11.12.13, 21:19
hier nochmal ein Auszug:

Report bugs to
root@rescue:/sbin# reboot
shutdown: Unable to shutdown system

Dyyce
11.12.13, 20:04
Hallo Sebastian,

ich habe den Server im Rescue Modus gestartet, die Partitionen gemountet und dass Passwort geändert. Allerdings hat der Soft-Reboot nicht geklappt. Daraufhin habe ich erneut den Hard-Reboot im OVH Manager verwendet. Nun geht das Passwort wieder nicht
Was könnte man machen?


Gruß

hemmerseb
10.12.13, 13:51
Hallo Dyyce,

der Server antwortet momentan auf Ping-Anfragen und ist via SSH erreichbar. Falls das Passwort nicht angenommen wird, bitte den Server im Rescue-Modus starten, die Systempartition mounten und ein neues Passwort festlegen.

Eine kleine Hilfestellung zum Rescue-Modus gibts hier:
http://hilfe.ovh.de/AdministrationRescueModus

Sebastian

Misterplay
10.12.13, 09:12
Guten Morgen

Ich komme zurzeit auch nicht drauf. Weder mit Putty noch über FileZilla.
Auch kein plan warum.

Mfg

Dyyce
10.12.13, 08:44
Hallo,

gestern habe ich einen Reboot über den OVH Manager durchgeführt.
Seit dem kann ich mich als root weder mit dem neuen Passwort, noch mit dem Initialpasswort einloggen. Für den Zugriff verwende ich Putty.

Danke schon mal!