We are in the process of migrating this forum. A new space will be available soon. We are sorry for the inconvenience.

Domain A-Record


Der_Sascha
16.09.13, 09:52
Na siehe da ... hab zwar noch keinen Antwort auf mein Ticket aber jetzt klappt es auf einmal.

Danke für die Mithilfe.

Der_Sascha
16.09.13, 08:29
Also ich habe jetzt noch einen anderen Test gemacht. Dem Kimsufi habe ich von Namecheap.com eine Billig-Domain verpasst (auch gleichzeitig der Hostname vom Server). Wenn ich bei Namecheap dann eine Subdomain anlege und Apache auf diese Subdomain lauschen lasse lande ich da wo ich soll.

Vllt. sollte ich erwähnen, dass ich meine Domains und Webspace bei 1blu liegen habe. Ja ich weiss ... vermutlich ein Fehler zu diesem Schrotthoster zu gehen. Habe jetzt aber 1 Jahr den Vertrag an der Backe.

Ich muss auf dem Kimsufi aber nichts in die Hosts-Datei schreiben bzgl. meiner Domain bei 1blu oder?

Und was ist mit dem OVH Kundencenter. Muss ich diese Domain da hinterlegen oder nicht?

EDIT:
Gerade ein Ticket bei denen aufgemacht. Mal sehen was sie sagen.

Altenholzer
16.09.13, 07:37
Wenn du mehr Webspace verwalten willst warum nutzt du nicht i-mscp oder easyscp?

Taiga-san
16.09.13, 02:55
Zitat Zitat von MDX
Mach doch nen Ping, dann siehst du wo die Domain hinpointed...
Zitat Zitat von Der_Sascha
[...]
http://my-addr.com pointed die Adresse auch schon auf meinen Server. [...]
Zitat Zitat von Der_Sascha
[...]
Wenn ich die Domain anpinge kriege ich auch die korrekte IP zurück. [...]
Hat er doch o_O

MDX
16.09.13, 02:40
Mach doch nen Ping, dann siehst du wo die Domain hinpointed...

Taiga-san
16.09.13, 01:17
Hast du es denn schon mit einem anderen Browser versucht? Im Übrigen werden DNS-Updates für gewöhnlich in (nahezu) Echtzeit durchgeführt. Es sind die Caches, weshalb die Änderungen bis zu 24 Stunden brauchen.

Den vHost hast du mittlerweile korrigiert?

Der_Sascha
16.09.13, 01:11
Kriege es einfach nicht zum laufen. ich habe gerade aber mal einen Test gemacht. Ich habe Apache beendet und dann nochmal versucht die Domain im Browser aufzurufen. Sie ist immer noch online. Also kann sie nicht auf meinem Kimsufi liegen weil da is der Apache ja aus.

Ich warte einfach mal noch ein wenig ab. Vllt. braucht das bei meinem Webhoster einfach noch ein bisschen bis alles durch ist. Habe vorhin erst umgestellt. Halt nur komisch da die Domain schon auf die korrekte IP pointed. Aber vllt. fehlt ja noch was was etwas zeit braucht.

Taiga-san
16.09.13, 00:57
Zitat Zitat von Der_Sascha
Standard Server: Definiert die Standard-Einstellungen für alle anderen virtuellen Server und beantwortet alle unbehandelten Anfragen.
Wäre bei OpenSUSE in der Datei /etc/apache2/default-server.conf und unter Debian in /etc/apache2/sites-enabled/default

Größere Änderungen sind da normal nicht erwünscht. In deinem Fall hat der Server ja bereits 3 Adressen (die IP, ksXXXXXX.kimsufi.com und meinedomain.de) und normal möchte man, dass nur Leute, die meinedomain.de aufrufen, auch auf meinedomain.de landen und nicht auch die ganzen Bots etc. die es auf der IP versuchen.

Taiga-san
16.09.13, 00:53
Das wäre dann auch das Problem, das müsste so aussehen:
Code:

	ServerName meinedomain.de
	DocumentRoot /var/www/ziel

	...
Wobei *:80 mit dem zu ersetzen ist, was auch immer hinter NameVirtualHost steht, bei mir wird das in /etc/apache2/listen.conf definiert (OpenSUSE).

Der Domain-Name wird innerhalb des VirtualHosts dann als ServerName definiert.

Auch nachzulesen im Manual unter https://httpd.apache.org/docs/2.2/de...ml#virtualhost

Der_Sascha
16.09.13, 00:40
ich habe im sites-available ordner eine extra datei die auch in sites-enabled verlinkt ist. Inhalt:


DocumentRoot "/var/www/ziel"

allow from all
Options +Indexes



EDIT:
Wenn ich meine IP im Browser aufrufe lande ich auf der selben "It works" Seite wie wenn ich meine Domain aufrufe. Nur wo kommt die It works her? Ich habe mit "find" den ganzen Server abgesucht. Ist zwar eine in /var/www aber die ist es nicht. Habe den Inhalt da geändert. Zeigt er mir aber nicht an. Also muss es noch eine andere Quelle geben.

Bzw ... da fällt mir ein ... beim Apache heissts doch:

Standard Server: Definiert die Standard-Einstellungen für alle anderen virtuellen Server und beantwortet alle unbehandelten Anfragen.

Taiga-san
16.09.13, 00:28
Ein A-Rekord reicht aus. Wie du schon sagtest, muss dann nur noch ein Apache-vHost erstellt werden. Wenn dieser nicht oder falsch konfiguriert wurde, landet man logischerweise nicht auf diesem. Du kannst ja testweise mal deine IP direkt aufrufen.

Sollte also nicht der Browser-Cache schuld sein (Firefox z.B. scheint einen eigenen DNS-Cache zu haben), liegt es wohl an der Apache-Konfiguration. Hast du NameVirtualHost konfiguriert, einen VirtualHost mit entsprechendem ServerName im richtigen Verzeichnis erstellt und dann Apache2 über /etc/init.d/apache2 force-reload (oder reload oder restart) aktualisiert?

Der Pfad für vHosts ist unter OpenSUSE /etc/apache2/vhosts.d und unter Debian /etc/apache2/sites-enabled

Der_Sascha
16.09.13, 00:14
Ja die Pfade kenne ich alle. Das ist nicht das Prob. Laufen tut auch alles benötigte drauf.

Wenn ich die Domain anpinge kriege ich auch die korrekte IP zurück. Nur sobald ich die Seite im Browser aufrufen will lande ich nicht da wo ich soll. Sprich scheinbar nirgends auf meinem Kimsufi.

Muss man sich für einen A-Record auf dem Zielserver evtl. zwingend eine Zone einrichten?

Dachte A-Record reicht aus. Ok den vHost in Apache noch erzeugen. Aber mehr brauchts doch nicht oder?

Muss die Domain auch in den Secundary DNS om OVH-Kundencenter rein oder hat die da nichts zu suchen?

Taiga-san
15.09.13, 23:49
Wo diese Datei liegt, hängt normal von den Pfaden deines Systems ab. Gängig wäre beispielsweise /srv/www/htdocs. Die Apache2-Konfigurationsdateien findest du unter /etc/apache2.

Bei den Isgenug handelt es sich um einen Root-Server, dessen Betriebssystem je nach Wahl nur das nötigste enthält und im textmodus läuft. Demnach musst du alles an Software manuell installieren und verwalten, wenn du dir nicht etwas wie ispCP installierst.

Der_Sascha
15.09.13, 21:50
Hi Leute.

Ich habe bei einem Webhoster eine Domain. Dort habe ich im A-Record jetzt die IP meines 4G Kimsufi-Servers eingetragen. Ich möchte auf diesem den Webspace verwalten.

http://my-addr.com pointed die Adresse auch schon auf meinen Server. Im DNS Manager des OVH-Kundencenters habe ich die Domain auch bereits hinterlegt.

Gebe ich im Browser nun die Domain (ohne www) davor ein kriege ich auch eine "It works!" Seite. Allerdings finde ich dieses html Dokument nicht bei mir auf dem Server. Mit wget lässt sich die Datei ohne Probleme runterladen und kommt auch von der IP meines Servers.

Irgendwie verstehe ich grad nur Bahnhof.