We are in the process of migrating this forum. A new space will be available soon. We are sorry for the inconvenience.

ESXi + IPv6


Stefan
02.09.13, 16:57
Als Alternative mit einer IPv4 die vMAC erstellen und diese vMAC dann für alle VM's "only" IPv6 nutzen.
Wann vMAC's für IPv6 verfügbar sein werden, kann ich so aktuell nicht sagen.

coresec
01.09.13, 17:17
Noch keine Antwort des Supports. Nun bereits eine Woche bezahlt und nicht nutzbar. Diese Woche noch abwarten, sonst geht es zu Hetzner.

mgn-schenke
28.08.13, 12:22
Danke für den Tip. Das werde ich heute Abend mal testen.

coresec
28.08.13, 10:01
@mgn-schenke:

Die Lösung hierfür ist, im ESXi unter den Einstellung für den Host hierbei kein /64 sondern ein /56 anzugeben. Dann funktioniert das auch mit dem Host und IPv6. Ich habe dir das ganze mal hier aufgezeigt anhand einer nicht existierenden IPv6:

http://i42.tinypic.com/8zmjur.png

Wenn Du also als Subnet z.B. 2001:41d0:a:b1234 hast, dann gibst Du dem Host daraus eine feste IPv6 mit dem Subnetz /56 (da der Gateway ja außerhalb dessen liegt).

Den Gateway kannst Du dann eintragen entsprechend dem Muster (die ersten 3 1/2 Nibble + FF). Hier also 2001:41d0:a:b1ff:ff:ff:ff:ff

mgn-schenke
28.08.13, 02:03
Hi,

wir haben zwar nicht dasselbe Problem, aber ein ähnlich gelagertes mit unseren ESXi Servern bei OVH. Unsere VMs sind mit IPv4 & IPv6 IPs im Netz, weshalb wir keinerlei Problem mit diesem Routing haben, aber wir wollten unseren ESXi auch per IPv6 ans Netz bringen und das funktioniert leider nicht.

Bei OVH ist die IPv6 Gateway-Adresse leider nicht im selben Subnetz wie die IPs aus dem zugewiesenen /64 Subnetz. Und genau das unterstützt der ESXi 5.x nicht. Versuche das Gateway für IPv6 per CLI zu setzen funktioniert leider auch nicht, da der ESXi erkennt, dass wir versuchen ein Default-Gateway zu konfigurieren und unsere Eingabe deshalb blockt.

Wir haben deshalb nun diverse VMs per IPv4&6 im Netz, aber unsere ESXi sind nur mit IPv4 im Netz erreichbar. Das ist sehr schade.

coresec
27.08.13, 09:03
Nach 3 Abstürzen gestern wird sich auf französischer Seite dem Problem nun angenommen:

von : Zied
Für: sf17689-ovh
Datum: 2013-08-27 04:53:53
Dear customer,

Your issue is being handled.
I will keep you informed, please wait.

Kind regards,
Zied.

Eine Lösung wäre es noch eine Router-VM einzusetzen, davon wollte ich aber eigentlich absehen. Teste gerade die UTM von Sophos, welche ich auch privat einsetze.

tester
27.08.13, 00:01
womöglich lässt sich da ja ne lösung finden, wenns flott gehen muss würd ich anrufen
scheint ja kein isgenug zu sein...
da ipv6 langsam aber doch kommt würde mich die lösung des problems interessieren
(professionelle Nutzung und ipv4's kaufen ist keine Lösung...)

coresec
26.08.13, 20:22
Das ist mir ja rille ob das was kostet oder nicht. Nirgends in der Produktbeschreibung stand: "Tjoa, wenn Sie die Kiste virtualsieren wollen, tjooooa .. dann haben Sie halt nur die Möglichkeit soviele VMs zu erstellen wie Sie vMACS haben ... und das sind halt soviele wie IPv4-Adressen".

tester
26.08.13, 20:03
weil v6 adressen nichts kosten

und v6 im home bereich noch nicht sehr verbreitet ist, wer ruft schon seine http seiten via v6 auf?

die Telekom austria spielt wohl gerade mit ipv6 herum, hatte mal Dual Stack, allerdings nur für ein paar wochen...

coresec
26.08.13, 19:53
Ja fahren denn alle nur Dualstack? Das ist doch total sinnfrei das man nur für IPv4 vMACs erstellen kann. Das heisst um Umkehrschluss,
dass ich nur SOVIELE VMs ans Netz bringen kann, wie ich IPv4-Addressen habe. Wofür habe ich dann bitte ein komplettes /64 Subnet?

Wie kann es sein das ein derartig banales Problem bei "europas größtem" Hoster noch nie in Betracht gezogen wurde?

tester
26.08.13, 19:49
wurde wohl bisher noch nicht gewünscht, das feature für ipv6 only...

coresec
26.08.13, 19:34
FINAL NOTE - OVH + IPv6 = WTF

I'll write this part in english so people from other countries are able to understand it:

If you're up to use a VM inside ESXi (bridged network ofcourse) with just IPv6, you have to use an assigned vMAC for an IPv4 (where you only have 3 Failovers available).

THEN and ONLY THEN the IPv6-Only-VM will be able to communicate to the network.

@OVH: ARE YOU KIDDING ME? Where is the option to get enough vMACS for my IPv6-VMs? I can just create 3 vMACS for my IPv4-Failover but i need about 20 vMACs for my IPv6-VMs.

So i am not limited by:

- Hardware (32 GB Ram, XEON 4C + HT, 4 TB HDD)
- Networking (1 Gbit, 200 mbit garuanteed)

But this all is completely useless if i'm limited in the number of my VMs by the numbers of IPv4-Addresses i've got assigned to my Server (1+3 Failover ATM). So i can just use 3 VMs overall instead of 25 i've planned to run.

Expecting a short term answer from either Oles (Twitter) or OVH.


TL;DR

You can only use as much VMs as you've got vMACs - even with IPv6 only you need an IPv4-assigned vMAC - period!

coresec
26.08.13, 18:41
Update:

Jetzt war ein Techniker an meiner Kiste, ich mache es kurz - Resultat: Misconfiguration by the customer.

Seriously? Die Konfiguration stimmt.

Hier mal 2 VMs, eine mit IPv4+IPv6 und eine nur IPv6


1.) IPv4+IPv6 (funktioniert)

http://i41.tinypic.com/211v51f.png

2.) IPv6-Only (funktioniert nicht!)

http://i44.tinypic.com/3euix.png


Untereinander können sich die VMs pingen, da sie am ESXi natürlich an einem vSwitch hängen. Also die Config läuft wunderbar.

coresec
25.08.13, 21:01
Servus,

leider kann ich meine ESXi-IPv6-VMs (NUR IPv6 - OHNE IPv4!) nicht ans Netz bringen. Ich habe alle Einstellungen so vorgenommen, wie Ihre Hilfe es vorschreibt. Eine IPv6 aus meinem zugewiesenen /64 vergeben und als Gateway die ersten 3 1/2 Nibble + FF, siehe angehängtem Screenshot.

Trotzdem kann ich mit der VM nicht ans Netz, geschweige denn den Gateway pingen. Ebenfalls kann ich für IPv6 keine "virtuellen MACs" freischalten. Sind per Default alle MACs von IPv6-Hosts erlaubt? Wenn nein - wie soll ich diese bitte freischalten?

Mit einer VM im Dualstack Modus (mit vMAC) funktioniert es tadellos, mit IPv6-Only hingegen nicht. Anzumerken ist hierbei, dass bei der Dualstack-VM als Default-Gateway eine fe80:: Adresse genutzt wird, nicht die 2001...:XXFF:FF:FF:FF:FF

Zur Info: http://hilfe.ovh.de/AdministrationIpv4Ipv6 funktioniert nicht! Es wurden natürlich 2 Routes eingetragen (default via etc..)

Um eine Antwort wird mit Dringlichkeit gebeten.

Florian Strankowski

Update: Genau das gleiche Problem hatte dieser User (http://forum.ovh.co.uk/showthread.php?t=6435) aber die Lösung funktioniert ebenfalls nicht. Warum komme ich aus einer ESXi-VM nicht per IPv6 raus?!?