We are in the process of migrating this forum. A new space will be available soon. We are sorry for the inconvenience.

Proxmox - KVM - Win7 - Networkbridge


Domilein
04.09.13, 17:25
Problem gelöst.


Debian Suqeeze neu installiert und Proxmox manuell installiert.

Funktioniert nun 1a (Ganz geschweige, dass seit gestern meine Verbindung zum Server desöfteren abkackt)

Domilein
01.09.13, 21:21
So...


Wollte es heute nochmals versuchen und siehe da, es hat auf Anhieb funktioniert. (Netzwerkkarte ist die Virtio)

Leider ist nun kein Ping von der KVM Maschine zum Host und umgekehrt möglich, leider brauche ich jedoch eine Kommunikation zwischen den beiden.

Meine Netzwerkkonfiguration am Host ist wie folgt:

Code:
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback
auto vmbr1
iface vmbr1 inet static
address 10.0.0.1
netmask 255.255.255.0
bridge_ports none
bridge_stp off
bridge_fd 0
post-up echo 1 > /proc/sys/net/ipv4/ip_forward
post-up iptables -t nat -A POSTROUTING -s '10.0.0.0/24' -o vmbr0 -j MASQUERADE
post-down iptables -t nat -D POSTROUTING -s '10.0.0.0/24' -o vmbr0 -j MASQUERADE


# vmbr0: Bridging. Make sure to use only MAC adresses that were assigned to you.
auto vmbr0
iface vmbr0 inet static
	address 91.121.158.xxx
	netmask 255.255.255.0
	network 91.121.158.0
	broadcast 91.121.158.255
	gateway 91.121.158.254
	bridge_ports eth0
	bridge_stp off
	bridge_fd 0

iface vmbr0 inet6 static
	address xxxxx
	netmask 64
	post-up /sbin/ip -f inet6 route add xxxx dev vmbr0
	post-up /sbin/ip -f inet6 route add default via xxx
	pre-down /sbin/ip -f inet6 route del default via xxx
	pre-down /sbin/ip -f inet6 route del xxx dev vmbr0

auto vmbr2
iface vmbr2 inet static
    address 192.168.0.254
    netmask 255.255.255.0
    bridge_ports none
    bridge_stp off
    bridge_fd 0
    post-up echo 1 > /proc/sys/net/ipv4/ip_forward
    post-up iptables -t nat -A POSTROUTING -s '192.168.0.0/24' -o vmbr0 -j MASQUERADE
    post-down iptables -t nat -D POSTROUTING -s '192.168.0.0/24' -o vmbr0 -j MASQUERADE
IP's durch xxx ersetzt.


Würde mich auf eine Antwort freuen. (Bin neu im Thema Virtualiesierung, da ich immer mit Virtualbox gearbeitet habe.)

Und nein, die VM wird für Private Zwecke genutzt.

Arne
22.08.13, 14:45
Also bei mir hat das alles Funktioniert mit Proxmox... Bei mir allerdings WinXP.
Weiß nicht inwiefern das was zur Sache tut, aber hast du auch diesen "Trick"? mit der Registry gemacht, wo die Subnetzmaske "unauffällig" geändert wird?

Stefan
22.08.13, 14:39
@TheDanny: dies kann viele Gründe haben, aber du kannst mir mal die Konfiguration per Email (an Kundendienst mit dem Betreff "Für Stefan") zusenden.

1. die vMAC in Promox hinterlegt
2. ipconfig /all in cmd von Windows

TheDanny
22.08.13, 10:58
Hallo Zusammen,

ich bin nun am selben Problem wie der der Beitragsstarter.
Leider funktionierts bei mir einfach nicht.
Kann mir bitte jemand sagen, was genau eingestellt werden soll muss?
Meine Config sieht wie folgt aus:
IP-Adresse: Fail-Over-IP
Subnet: 255.255.255.255
GW: Haupt-IP.254
DNS: 213.186.33.99
Die vMAC ist ebenfalls eingetragen.

Vielen Dank schon einmal für eure Hilfe

Kann es an Teamviewer liegen?

keving
20.08.13, 22:16
Zitat Zitat von Stefan
Dies ist so leider nicht mehr möglich.

Stefan
Und während die Bestellung noch läuft?
Laut Support ist dies nicht mehr möglich, dies zurück zu ändern?

Stefan
20.08.13, 21:49
Zitat Zitat von Domilein
@ Stefan: Gehört hier zwar nicht dazu, aber ist es möglich während der Laufzeit den Server ins Datacenter Straßburg umzusiedeln?
Dies ist so leider nicht mehr möglich.

Stefan

Domilein
20.08.13, 21:45
Zitat Zitat von keving

btw: Einfach ganz normales Win 7 installiert?

In proxmox ne KVM Maschine erstellt und eine Win7 .iso herunter geladen -> google.de

keving
20.08.13, 21:34
@Stefan: Es war möglich den mSP von SBG nach RBX zu ändern, aber jetzt laut Support nicht mehr zurück. Obwohl sich der Bestell Status 0 verändert hat?

btw: Einfach ganz normales Win 7 installiert?

EvilMoe
20.08.13, 21:00
Zitat Zitat von Domilein
@ Stefan: Gehört hier zwar nicht dazu, aber ist es möglich während der Laufzeit den Server ins Datacenter Straßburg umzusiedeln? Quasi, dass ein Server in Straßburg aufgesetzt wird?
Miete Dir doch einfach einen neuen in SBG. Solange kannst du den alten behalten (ggf. immer nur ein paar Tage verlängern).

Domilein
20.08.13, 19:46
Danke Stefan und eddi96,
HAbe auf diesen Therad voll vergessen und habe es selbst hinbekommen (Habe nun Routed statt Bridged)

@Alex007:
Bestellt wurde am 02.08.2013 über einen Reseller, bezahlt hat dieser per Überweißung.

Eigentlich wollte ich in Straßburg sein, jedoch war er in Roubaix früher da.

@ Stefan: Gehört hier zwar nicht dazu, aber ist es möglich während der Laufzeit den Server ins Datacenter Straßburg umzusiedeln? Quasi, dass ein Server in Straßburg aufgesetzt wird? Und dieser für einen anderen Kunden frei gemacht wird? ( Ich kann auf den Server in Straßburg auch länger warten bzw. bin auch mit 100 Mbit (Sogar 50Mbit) zufrieden.)
Die meisten Spieler(Gameserver..) kommen aus Deutschland / Österreich und ich z.B habe einen Ping von 50-60ms, was bei CS:S nicht so dolle ist.

Falls gebraucht:
Hostname: ns202675.ovh.net

Stefan
20.08.13, 14:51
Für die VM: Win7 (KVM) musst du folgende IP-Konfiguration in der VM vornehmen:
http://hilfe.ovh.de/BridgeClient

Stefan

ALEX007
20.08.13, 11:38
wann hast du dein msp Server bezahlt?

eddi96
20.08.13, 11:34
Hallo,
anstatt die Netzwerkkarten vollständig zu virtualisieren (wie mit der Intel E1000 oder der von Realtek), nutze doch die Paravirtualisierung. Diese erfordert lediglich die Installation eines zusätzlichen Treibers in Windows und die Konfiguration der Netzwerkkarte in Proxmox auf "VirtIO (paravirtualized)". Dies sollte stabiler funktionieren und Du hast auch eine bessere Performance.

Nähere Infos dazu und wie das eingerichtet wird, findest Du auf der Wiki-Seite von Proxmox VE: http://pve.proxmox.com/wiki/Paravirt...rs_for_Windows

Domilein
18.08.13, 17:07
Hat sich wohl erledigt.

Statt der Virtuellen Intel Netzwerkkarte die Realtek ausprobiert und nun gehts.

Edit: Hat 10 Minuten funktioniert, danach das gleiche -> Netzwerk "tot"

Domilein
18.08.13, 15:51
Guten Nachmittag,

Ich habe nun endlich meinen mSP (Statt SBG in RBX), hat aber nix zur Sache..


Folgendes Szenario:

mSP mit proxmox Image von OVH.

1 OpenVZ Server(Container) mit Debian 6 (OpenVZ Template) funkt tadellos.

Dazu möchte ich nun noch mit KVM(Xen?!) ein kleines schlankes Win 7 System aufsetzen.(Für kleine Private Dinge) aufsetzen.




Beim OpenVZ Server wurde folgendes gemacht:
Netzwerktyp als Routed und als Netzinterface vmbr1 ausgewählt.


Win7 (KVM) hat folgendes:
Netzwerktyp als Bridged und als Interface vmbr0 (Wiki Seite von OVH - http://hilfe.ovh.com/Proxmox)
Dazu wurde im Manager eine virtuelle MAC Adresse für die IP erzeugt und bei der erstellung eingetragen.

Danach Win7 über die .iso installiert und es wird mir angezeigt, dass kein Internet verfügbar sein.(Auf Deppendeutsch)

Leider, habe ich mit Virtualiesierung noch nicht so ganz beschäftigt(Außer, Virtualbox, dass aber sehr Ressourcenhungrig is)



Auf meinem Host wurde nichts geändert.



Hoffe, dass sich jemand für eine Lösung finden kann.


Freundliche Grüße
Domi