We are in the process of migrating this forum. A new space will be available soon. We are sorry for the inconvenience.

Ubuntu 12.04 LTS x64 - mysqld hohe Last im Leelauf?


Caddy
02.07.12, 15:17
Zitat Zitat von thy
Ja, das ist das Schaltsekunden-Problem, hatte ich auf meinen Proxmox-Systemen auch.
Das hier: http://blog.mozilla.org/it/2012/06/3...u-and-the-fix/ bringts auch ohne Neustart wieder ins Lot.
Zu spät ;-) Der Ausweg "Reboot" hatte schon zugeschlagen :-)

Auf jeden Fall erklärt das exakt das Problem und hätte es womöglich auch gelöst. Danke für die Info, ich bin normalerweise nicht so schnell mit einem Reboot, sondern eher daran interessiert, sowas auf einem laufenden Ding wieder in Gang zu bekommen, sofern sich das irgendwie regeln lässt. Ich denke, bis zur nächsten Schaltsekunde wird's dann einen Patch geben.

Danke und Gruß, Klaus

thy
02.07.12, 14:43
Ja, das ist das Schaltsekunden-Problem, hatte ich auf meinen Proxmox-Systemen auch.
Das hier: http://blog.mozilla.org/it/2012/06/3...u-and-the-fix/ bringts auch ohne Neustart wieder ins Lot.

bjo
02.07.12, 12:54
Hatte das Problem auf nem Debian wheezy auch, mysql rannte auf 80% obwohl laut mytop nix los war. Nach einem Reboot war's weg.

Caddy
01.07.12, 22:58
Hi,

das hatten wir uns zwar auch schon gedacht, aber das Problem sollte eigentlich "nur" Deadlocks im Zusammenhang mit syslogd geben, wenn ich das richtig gelesen habe (obwohl das auch schon ziemlich crazy ist), wir haben noch einen 10.04 LTS, bei dem das z.B. nicht war. Schade, dass wir ihn schon neu gestartet haben, sonst hätten wir mal die Arie mit ntpd stoppen und Schaltsekunde zurücksetzen probiert. Seit dem Reboot läuft das Ding auch wieder völlig problemlos.

Gruß, Klaus

kiwee
01.07.12, 22:44
Hallo,
klingt nach dem Phänomen mit der Schaltsekunde:
serverfault.com/questions/403732/anyone-else-experiencing-high-rates-of-linux-server-crashes-during-a-leap-second

Caddy
01.07.12, 22:37
Wir haben gestern ein interessantes Phänomen beobachtet: An jedem 1. Sonntag im Monat wird bei Servern mit Raid ab 1:00 Uhr ein raidcheck ausgeführt (checkarray). Das kenne ich zwar schon jahrelang, letzte Nacht kam dazu aber, dass mysqld plötzlich zur selben Zeit jeweils sehr gleichmäßig 45% auf allen 2 cores der DualCore cpu beansprucht hat. Mit service mysql stop war's weg, nach dem Starten mit service mysql start wieder da.

Wir haben das zunächst auf's checkarray geschoben, obwohl das eigentlich nicht so logisch erscheint. Heute morgen um 9 Uhr war die Last noch immer da, wir haben daraufhin einige "Experimente" gemacht: Webserver gestoppt, mit mysqladmin -i2 processlist nachgesehen, ob irgendwelche Verbindungen drauf sind - Nix. Das Ding war augenscheinlich nur mit sich selbst beschäftigt. Das Problem liess sich letztendlich nur durch den Reboot des Servers lösen. Hat vielleicht irgendjemand etwas ähnliches beobachtet?

Patchstand ist und war aktuell, Kernel 3.2.13-grsec-xxxx-grs-ipv6-64

Gruß, Klaus