We are in the process of migrating this forum. A new space will be available soon. We are sorry for the inconvenience.

Proxmox (kvm) und vlan Probleme


dimon
06.05.12, 22:40
Hallo liebe Community,

ich möchte gerne meiner virtuellen Maschine einen vlan-Tag vergeben.

Dieses kann man ja in der Proxmox-Oberfläche (V. 2.1) unter Hardware->edit Network Device einfach einen vlan-Tag eingeben.

Nach dem Zuweisen wird der Start-Vorgang mit folgendem Fehler abgebrochen:

Code:
no physical interface on bridge 'vmbr2'
/var/lib/qemu-server/pve-bridge: could not launch network script
kvm: -netdev type=tap,id=net1,ifname=tap103i1,script=/var/lib/qemu-server/pve-bridge: Device 'tap' could not be initialized
TASK ERROR: start failed: command '/usr/bin/kvm -id 103 -chardev 'socket,id=monitor,path=/var/run/qemu-server/103.mon,server,nowait' -mon 'chardev=monitor,mode=readline' -vnc unix:/var/run/qemu-server/103.vnc,x509,password -pidfile /var/run/qemu-server/103.pid -daemonize -usbdevice tablet -name Win2003 -smp 'sockets=1,cores=1' -nodefaults -boot 'menu=on' -vga cirrus -localtime -rtc-td-hack -k de -drive 'file=/var/lib/vz/template/iso/winakt.iso,if=none,id=drive-ide2,media=cdrom,aio=native' -device 'ide-cd,bus=ide.1,unit=0,drive=drive-ide2,id=ide2,bootindex=200' -drive 'file=/var/lib/vz/images/103/vm-103-disk-1.vmdk,if=none,id=drive-ide0,aio=native' -device 'ide-hd,bus=ide.0,unit=0,drive=drive-ide0,id=ide0,bootindex=100' -m 1024 -netdev 'type=tap,id=net0,ifname=tap103i0,script=/var/lib/qemu-server/pve-bridge' -device 'rtl8139,mac=C6:9E:F7:5A:C5:AB,netdev=net0,bus=pci.0,addr=0x12,id=net0,bootindex=300' -netdev 'type=tap,id=net1,ifname=tap103i1,script=/var/lib/qemu-server/pve-bridge' -device 'e1000,mac=32:1E:51:0E:BA:D1,netdev=net1,bus=pci.0,addr=0x13,id=net1,bootindex=301' -cpuunits 1000' failed: exit code 1
Nach löschen der vLan-Tags läuft die virtuelle Maschine an.

Hat einer zufällig eine Idee? Würde mich freuen!