We are in the process of migrating this forum. A new space will be available soon. We are sorry for the inconvenience.

RIPE Failover nicht erreichbar


strex
26.11.11, 12:01
Für Virtualisierung ist es das Beste. Einfach Standard Networking mit Bridging nutzen und schon passt alles. Du kannst nämlich ein IP Subnet ins vRack routen lassen und erhältst dann ein Gateway mit einer IP in dem Subnet. VMACs sind ebenfalls hier nicht nötig, da keine Prüfung stattfindet.

Ohne das würde ich keine vServer bei OVH hosten.

whyte
26.11.11, 10:38
rentiert sich denn ein vrack für einen einzelnen server?
Ich muss mir das mal genauer anschauen ... noch nicht mit beschäftigt

kikei
25.11.11, 18:22
Habe gerade einmal geschaut, wenn ich vom internen OVH Netz ein traceroute auf eine der RIPE IP's mache, wird auf den Server geroutet, dieser geht allerdings wieder auf das Switch, wo der Traceroute durch ging. In meinem Server sind jedoch keinerlei Routen aktiviert. Auch IPTABLES Rejecten nichts.

Jemand eine Idee?

strex
25.11.11, 16:18
Zitat Zitat von whyte
strex, was zahlst du im Monat für dein vRack?
Kann ich das von meinem Monatsgehalt tragen?
Eigentlich nicht viel, kommt auf die Anzahl der Server an. Hat sich jetzt aber geändert. So viele Server wie man will für 36€.

Stefan
25.11.11, 15:22
kikei du kannst dich ruhig an den Kundendienst wenden, der Block muss nicht zwingend aufgeteilt werden.
Wenn du eine vMAC erstellst, werden die IPs auch als /32 behandelt und die Config (Bridgeclient) ist dann weiterhin richtig.

Stefan

whyte
25.11.11, 14:29
strex, was zahlst du im Monat für dein vRack?
Kann ich das von meinem Monatsgehalt tragen?

kikei
25.11.11, 13:34
Ich betreibe nur für mich privat vServer zum Entwickeln und brauch von daher kein vRack oder ähnliches.

Habe nun die IP's gesplittet, seitdem routet OVH nicht mehr zum Server durch, obwohl eingestellt ist, dass zum Server geroutet wird. Mal gucken, dauert eventuell ne halbe Stunde bis das Routing wieder hinhaut.

Trotzdem vielen Dank für die Hilfe, dass der Block != einzelner IP ist und ich diesen erst splitten muss, war mir nicht wirklich bewusst.

strex
25.11.11, 12:36
Kauft euch einen wirklichen Server und ein vRack und dann gibt´s die Probleme nicht. Denn dann ist Bridging ohne vMAC oder Routing möglich. Manchmal spart man wirklich am falschen Ende.

kikei
25.11.11, 12:33
Der RIPE Block ist nicht gesplittet und als Anleitung wurde ich auch von OVH nur auf folgenden Eintrag verwießen, welcher bei einer einzelnen Failover funktioniert.

http://hilfe.ovh.de/BridgeClient

PS: Was meinst du eigentlich genau mit gesplittet? Was hat dies für Auswirkungen? Aktuell kann ich ja bei einem 4er Block nur 2 IP's nutzen, wäre das beim splitten anders?

MfG und Danke

0815-4711
25.11.11, 09:52
Zitat Zitat von kikei
Die VM's sind alle gleich Konfiguriert
Vielleicht ist das schon das Problem. Wenn der Block nicht gesplittet ist, dürfen die Ripe IPs nicht so konfiguriert oder behandelt werden wie Failover IPs.
Welche Subnetzmaske und welcher Gateway verwendet werden muss, steht in der Installationsmail des RIPE Blocks.

NULL

kikei
24.11.11, 22:28
Ich verstehe gerade absolut garnichts mehr.

Die VM's sind wieder erreichbar, jedoch nur wenn ich beim Host folgende Route setze:

ip route add 176.31.VM.IP dev vmbr0

Dies ist allerdings nur bei RIPE IP's der Fall!

Die VM welche eine normale Failover IP nutzt ist ohne Route beim Host erreichbar. Der Host hat auch IP Forwarding aktiviert.

Gibt es hierfür irgend eine Erklärung?
VM's mit RIPE Failover nur mit Route im Host erreichbar.
VM's mit normaler Failover ohne Route im Host erreichbar.

Die VM's sind alle gleich Konfiguriert
- feste IP
- Subnetzmaske auf 255.255.255.255 (bei Windows mit Registry Hack)
- Gateway der gleiche wie Hostserver also Hostserver IP, letzte Stelle 254
- DNS 213.186.33.99

strex
24.11.11, 22:11
Wenn der tracert bis zum host kommt und dann nichts mehr erreicht ist das in der Regel ein Konfigurationsproblem. Egal ob du was geänderst hast oder nicht.

Wie sieht den der tracert von den vms nach draußen aus, da lässt sich doch am meisten erkennen.

kikei
24.11.11, 21:57
Hallo,

folgendes Szenario, ich setze seit ca. 1 Monat einen Isgenug 16G mit einem 4er Block Ripe IP's ein. Die VM's konnten ohne Probleme angesprochen werden und funktionierten, bis heute gegen ca. 15:00 Uhr. Ich habe noch eine einzelne Failover IP welche ohne Probleme funktioniert.

An den Einstellungen wurde nichts verändert, ich habe mir lediglich nachdem schon keine RIPE IP mehr funktionierte neue virtuelle Mac Adressen generieren lassen. Im Manager sind diese zugewiesen. Die IP's stehen alle auf aktiv, also ist auch keine gesperrt. Die Konfiguration sind wie bei der normalen Fail-Over IP, welche ohne Probleme funktioniert, also denke ich hier gibt es ein Problem in den Switchen von OVH, bezüglich der vMac.

Das Routing läuft ganz normal auf den Hostserver - mit einem Tracert geprüft.

Wie gesagt, ich habe an den VM's nichts verändert. Sowohl Windows VM's als auch Linux VM's haben ohne mir ersichtlichen Grund keine Netzverbindung mehr. Die normale einzelne Failover IP funktioniert ohne Probleme.

Vor ca. 2 Stunden war dieses Forum auch von Vodafone UMTS und von Versatel nicht erreichbar. Ebenso nicht direkt aus dem OVH Netz (von der funktionierenden Failover und vom Hostserver).

MfG