We are in the process of migrating this forum. A new space will be available soon. We are sorry for the inconvenience.

Subdoamin mit Plesk 10.2 einrichten


Atomic
16.07.11, 12:07
So ich habe es hin bekommen. Beides läuft jetzt.

Atomic
15.07.11, 23:14
So ich habe noch mal weiter gemacht.
Habe jetzt vom conf Ordner der Subdomain eine vhost.conf erstellt. nach Anleitung:


http://ubuntublog.ch/applikationen/s...plesk-erzeugen


jetzt habe ich auch im Ordner conf der hauptdomain in der conf datei folgenden Eintrag:





ServerName "shop.elbschrauber.de:80"
<------>UseCanonicalName Off


SuexecUserGroup "elbschrauber_hp" "psacln"


ServerAdmin "support@elbschrauber.de"

<------>DocumentRoot "/var/www/vhosts/elbschrauber.de/httpdocs"
CustomLog /var/www/vhosts/elbschrauber.de/statistics/logs/access_log plesklog
ErrorLog "/var/www/vhosts/elbschrauber.de/statistics/logs/error_log"



ScriptAlias /cgi-bin/ "/var/www/vhosts/elbschrauber.de/subdomains/shop/cgi-bin/"



SSLEngine off






SetHandler perl-script
PerlHandler ModPerl::Registry
Options ExecCGI
allow from all
PerlSendHeader On



php_admin_flag engine on
php_admin_flag safe_mode off
php_admin_value open_basedir /var/www/vhosts/elbschrauber.de/httpdocs/:/tmp/



php_admin_flag engine on
php_admin_flag safe_mode off
php_admin_value open_basedir /var/www/vhosts/elbschrauber.de/httpdocs/:/tmp/



SetHandler python-program
PythonHandler mod_python.cgihandler




SetHandler fcgid-script
Options +FollowSymLinks +ExecCGI




Options -Includes +ExecCGI



Alias "/error_docs" "/var/www/vhosts/elbschrauber.de/error_docs"
ErrorDocument 400 "/error_docs/bad_request.html"
ErrorDocument 401 "/error_docs/unauthorized.html"
ErrorDocument 403 "/error_docs/forbidden.html"
ErrorDocument 404 "/error_docs/not_found.html"
ErrorDocument 500 "/error_docs/internal_server_error.html"
ErrorDocument 405 "/error_docs/method_not_allowed.html"
ErrorDocument 406 "/error_docs/not_acceptable.html"
ErrorDocument 407 "/error_docs/proxy_authentication_required.html"
ErrorDocument 412 "/error_docs/precondition_failed.html"
ErrorDocument 415 "/error_docs/unsupported_media_type.html"
ErrorDocument 501 "/error_docs/not_implemented.html"
ErrorDocument 502 "/error_docs/bad_gateway.html"
ErrorDocument 503 "/error_docs/maintenance.html"


Include "/var/www/vhosts/elbschrauber.de/subdomains/shop/conf/vhost.conf"





Das ist ja schon mal gut.
Wie komme ich jetzt aber weiter?
Dazu kommt jetzt noch, das eine weitere Domain auf dem Server nicht auf www.domain.de hört, sondern nur ohne. Hat das auch was damit zu tun?
Bei zwei anderen geht das.

Atomic
13.07.11, 14:50
Könntest du mir vielleicht noch weiter Helfen?
Ich komme einfach nicht weiter.

Danke

Atomic
11.07.11, 12:42
Danke Thomas, da find ich die Datei Datei: 000-default mit folgenden Inhalt:


Datei: 000-default Zeile 1 Spalte 0 948 Bytes 51%

ServerAdmin webmaster@localhost

DocumentRoot /var/www

Options FollowSymLinks
AllowOverride None


Options Indexes FollowSymLinks MultiViews
AllowOverride None
Order allow,deny
allow from all


ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/

AllowOverride None
Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
Order allow,deny
Allow from all


Tommi
11.07.11, 09:24
# Include the virtual host configurations:
Include /etc/apache2/sites-enabled/


das sagt, dass die zugehörige vHostkonfiguration in den Dateien unter /etc/apache2/sites-enabled/ zu finden ist.

Thomas

Atomic
11.07.11, 06:02
Kann mir dann jemand weiter helfen?
So langsam bräuchte ich die Subdomain

Danke

Atomic
07.07.11, 20:21
Also eine .htaccess gibt es, aber beim löschen der Datei, gabs keine änderung.

hier nun der Auszug aus der apache2.conf


HostnameLookups Off

# ErrorLog: The location of the error log file.
# If you do not specify an ErrorLog directive within a
# container, error messages relating to that virtual host will be
# logged here. If you *do* define an error logfile for a
# container, that host's errors will be logged there and not here.
#
ErrorLog /var/log/apache2/error.log

#
# LogLevel: Control the number of messages logged to the error_log.
# Possible values include: debug, info, notice, warn, error, crit,
# alert, emerg.
#
LogLevel warn

# Include module configuration:
Include /etc/apache2/mods-enabled/*.load
Include /etc/apache2/mods-enabled/*.conf

# Include all the user configurations:
Include /etc/apache2/httpd.conf

# Include ports listing
Include /etc/apache2/ports.conf

#
# The following directives define some format nicknames for use with
# a CustomLog directive (see below).
# If you are behind a reverse proxy, you might want to change %h into %{X-Forwarded-For}i
#
LogFormat "%v:%p %h %l %u %t \"%r\" %>s %O \"%{Referer}i\" \"%{User-Agent}i\"" vhost_combined
LogFormat "%h %l %u %t \"%r\" %>s %O \"%{Referer}i\" \"%{User-Agent}i\"" combined
LogFormat "%h %l %u %t \"%r\" %>s %O" common
LogFormat "%{Referer}i -> %U" referer
LogFormat "%{User-agent}i" agent

#
# Define an access log for VirtualHosts that don't define their own logfile
CustomLog /var/log/apache2/other_vhosts_access.log vhost_combined


# Include of directories ignores editors' and dpkg's backup files,
# see README.Debian for details.

# Include generic snippets of statements
Include /etc/apache2/conf.d/

# Include the virtual host configurations:
Include /etc/apache2/sites-enabled/
AddOutputFilter INCLUDES .shtml
AddType text/html .shtml
AddType application/x-httpd-php .php
AddType application/x-httpd-php-source .phps
sagt mir jetzt aber nicht wirklich viel.
eine httpd.conf habe ich, aber diese ist leer.

mein System ist, wenn das vielleicht hilft: Ubuntu 10.04.2 LTS

Tommi
07.07.11, 15:59
also mein Wetteinsatz* ist immernoch auf die vhost Konfiguration gesetzt. Wenn du die entsprechende Datei findest könntest du mal per Texteditor drüber gucken oder sie hier posten.

vhost.conf, apache.conf httpd.conf (je nach System heißt die anders) wenn es die komlette apache .conf is nur den vhost teil zitieren (übersichtlichkeitshalber)

EDIT: hatte grad noch eine Idee. Hast du vieleicht irgend eine rewrite rule definiert Stichwort: .htaccess?

Thomas

*Mein Wetteinsatz ist ein Eis und mein Wettpartner bin ich. Vorteil: egal ob ich gewinne oder verliere, ich bekomm ein Eis

Atomic
07.07.11, 15:12
Ja, der Server wurde neu gestartet. Keine Änderung

0815-4711
07.07.11, 14:00
Apache, Plesk oder gleich den Server mal neu gestartet?

Atomic
07.07.11, 13:05
so ich habe jetzt heute noch mal gesucht aber nichts gefunden. Auch bei einer weiteren neu eingerichteten subdomain tritt der selbe fehler auf. was kann das denn jetzt noch sein?

Atomic
06.07.11, 15:02
Es ist ein Tippfehler von mir gewesen, vom Handy aus geschrieben, also der genaue weg ist : var/www/vhosts/elbschrauber.de/subdomains/shop/httpdocs

der sollte auch richtig sein.

jetzt habe ich den Ordner über Putty von der sub auf httpdoc geändert, ging natürlich auch nicht. Nur jetzt kann ich ihn auch nicht wieder zurück ändern.

Tommi
06.07.11, 13:03
Wie vorhin vermutet: die DNS ist richtig eingestellt.
Der Fehler liegt also in der vhost konfiguration.

ich weiß nicht, ob du dich jetzt hier vertippt hast, oder aus der vHost-Konfiguration copy/pasted hast.

im Falle von copy/paste, prüf nochmal ob dein Pfad tatsächlich
var/www/vhosts/elbschrauber.de/subdomaims/Shop/httpdocs
lautet.

Thomas

Atomic
06.07.11, 12:32
Okt danke, dann werden ich noch mal, wenn ich zu hause bin nach gucken.
Also ist ist so wenn ich die Domain www.elbschrauber.de aufrufe, komme ich auch auf die Homepage. Wenn ich jetzt die Domain Shop.elbschrauber.de aufrufe, komme ich auch auf die Homepage und nicht in den Shop.
Die Daten für die Homepage liegen im Verzeichnisse var/www/vhosts/elbschrauber.de/httpdocs. Unsere der Shop in var/www/vhosts/elbschrauber.de/subdomaims/Shop/httpdocs so wurde es von Plesk angelegt und ist ja auch richtig.

@saschilys: ja richtig habe ich.

Tommi
06.07.11, 09:18
Hallo,

geht es hier tatsächlich um ein DNS problem?
Ich hab die Problembeschreibung so verstanden, dass bei Aufruf der Subdomain der korrekte Server angesprochen wird aber der falsche Inhalt dargestellt ist.

Klingt mir also eher nach vHost konfiguration.

Mit Plesk am besten bei der Doku nach sehen wo der Menüpunkt bei der aktuellen Pleskversion zu finden ist und über das menü nochmal sicher gehen, dass der vHost richtig eingestellt ist.

Mit ohne Plesk würd ich empfehlen /etc/apache2/apache2.conf (oder die entsprechend verlinkte Datei) zu prüfen.

Thomas

Saschilys
06.07.11, 08:47
Achso, dann hast du als Namedserver deinen eigenen eingetragen?
Also nsxxxxxx.ovh.net sowie sdns?

Atomic
06.07.11, 06:22
Hmm ich habe keine Möglichkeit an der dns-zone vor zu nehmen., genau so wenig an den subdomains. Die sind alle rot durchgestrichen.

Saschilys
06.07.11, 04:48
Dann musst du in der dns-Zone im manager einen neuen cname-Eintrag mit der Subdomain machen, die auf deine hauptdomain verweist. Nach kurzer Zeit wird dann auch auf die Subdomain geleitet.

Atomic
05.07.11, 20:31
Naja, die Domain ist über OVH bestellt und wird über den Manager auf meinen Root weitergeleitet.
Dort wird sie dann über Plesk verwaltet. Unter anderem auch die Subdomain.

Saschilys
05.07.11, 19:45
Wird die Domain von OVH verwaltet, oder vom Server?

Atomic
05.07.11, 17:42
Hallo,
ich habe heute unter Plesk eine Subdomain eingerichtet.
als Dokumentstamm habe ich den Ordner httpdocs angegeben in den auch die Daten liegen. Wenn ich jetzt die Domain aufrufen möchte, komme ich immer nur zur Hauptdomain und nicht zur Subdomain.

Wenn ich jetzt de Dokumentstamm mit /subdomains/shop/httpdocs angebe, bekomme ich die Meldung: Das angegebene Verzeichnis enthält ein Dienst-Verzeichnis.

Was mache ich da falsch?