We are in the process of migrating this forum. A new space will be available soon. We are sorry for the inconvenience.

hostname ändern geht nicht :(


glabs
03.03.11, 14:34
Zitat Zitat von campo
Hallo zusammen...
folgendes Problem habe ich beim Ändern meines Servernamens.. damit das "kimsufi" nicht immer in den Mailheadern steht usw.
Ich habe demnächst vor, für einen Kunden Newsletter zu versenden von meinem Rootserver aus. Derzeit benutze ich die mail-Funktion von php. Meine Empfängeradresse ist bei freenet. In den Mailheadern steht dort:

X-Warning: ksxxxxxx.kimsufi.com is listed at abuse.rfc-ignorant.org

Ich habe recherchiert und bin auf diese Webseiten gestoßen:

http://www.rfc-ignorant.org/tools/lo...in=kimsufi.com

http://rbls.org/kimsufi.com


Liegt es daran, dass die eMail abuse@kimsufi.com nicht eingerichtet ist ?
Ich meine ich persönlich habe da leider keinen Einfluss. Und wenn ich für einen Kunden Newsletter versenden möchte, dann möchte ich natürlich, dass alles RFC-konform ist und die Mails nicht von den Anbietern als Spam markiert werden - schließlich bezahlt er ja dafür.

Danke im voraus für Ihre Hilfe.

Laubie
19.11.10, 19:35
Zitat Zitat von campo
Danke dir,
aus deinem ersten Link hatte ich den Tip mit dem "umbenennen"
höh... das is wohl mein Thread

Vor dem neu aufsetzen schrecke ich momentan noch etwas zurück... zu wenig Ahnung und auch ein Zeitproblem.
Wobei das zeitlich wohl schneller gehen würde als das suchen nach Lösungen
Das glaub ich auch. Das Image mit ISPConfig ist nicht mehr optimal aufgesetzt. Häufig stimmen auch PAsswörter nicht.
Ich würde es auf dem vorhanden Debian-Image aufsetzen.

Dieses Handbuch gibt es aber momentan nur in english oder ?
Jupp

Würde es etws helfen wenn ich über ispconfig ein OS ubdate laufen lasse ?
Naja, dein System sollte schon auf dem neusten STand sein.
Zeigt dir ISPConfig auf der Startseite auch an.
Das OS-Update macht nix anderes als ein aptitude -y upgrade

campo
19.11.10, 14:24
Danke dir,
aus deinem ersten Link hatte ich den Tip mit dem "umbenennen"

Vor dem neu aufsetzen schrecke ich momentan noch etwas zurück... zu wenig Ahnung und auch ein Zeitproblem.
Wobei das zeitlich wohl schneller gehen würde als das suchen nach Lösungen

Dieses Handbuch gibt es aber momentan nur in english oder ?

Würde es etws helfen wenn ich über ispconfig ein OS ubdate laufen lasse ?

F4RR3LL
19.11.10, 13:38
Damit du genaueres zu dem Fehler hast sofern es Dich interessiert:


http://www.howtoforge.de/forum/showthread.php?t=3563

Dann muss ichs nicht nochmal tippen.
Alle anderen Probleme die Du da hast liegen ja nicht an ISPConfig.
Wenn Du es von Anfang an sauber haben willst mit deinen Hostnames und etwaigen anderen Einstellungen. Installiere Lenny from scratch und Ispconfig anschließend von Hand.
Howtos sind hier:
http://wiki.nixhelp.de/ovh-spezifisc...y-from-scratch

Ispconfig3 mit mydns und courier:
http://wiki.nixhelp.de/howto/ispconfig3
Ispconfig3 mit bind und dovecot:
http://wiki.nixhelp.de/howto/ispconfig3_bind_dovecot

Und du wirst keines deiner oben angesprochenen Probleme haben.
Gruß Sven

//Edit: Es gibt ein knapp 400 seitiges Handbuch für ispconfig zu kaufen für 5€. Da ist alles was man mal nicht so kapiert erklärt.

campo
19.11.10, 13:30
nja... ich habe mir den (test)Server ja gerade geholt weil ich mir das ISPConfig mal anschauen wollte
Aber nach dem Update sind soooo viele Baustellen entstanden.......

@F4RR3LL
meinst du ich sollte die mptctl besser wieder ins original umbenennen ?
Ich hoffe mal das beim nächsten Update nicht wieder das cert Problem oder andere auftauchen... bis ich da die Lösung hatte ginegen auch sStunden fürs googeln drauf

F4RR3LL
19.11.10, 13:29
Zitat Zitat von campo
Nach dem Update kam übrigends folgende Fehlermeldung in den Logs:
Failed to load mptctl
FATAL: Could not load /lib/modules/2.6.34.6-xxxx-grs-ipv6-32/modules.dep: No such file or directory
Ist im SVN schon gefixt und beim nächsten update von ispconfig kommts auch nimmer. Das kannste getrost ignorieren. Nix wildes.

bb21
19.11.10, 13:20
Standardmäßig sind glaub ich die Kernel von OVH ohne Modulsupport gebaut... ich kenne aber nur das Debian Image

ISPConfig hab ich mir mal die Demo angeschaut und mir wars "zu aufregend"
Ich bevorzuge IspCP das ist Recht einfach und erfüllt seinen Zweck sehr gut
Vielleicht ist das ja auch was für dich

campo
19.11.10, 12:50
ja ... networking restart hatte ich auch gemacht. (ohne Fehlermeldung)
Habs gerade nochmal ausgeführt und bekomme diese Fehlermeldungen

Reconfiguring network interfaces... SIOCDELRT: no such process ... 3 mal
if-up.d/mountnfs(eth0): waiting for interface eth0:0 before doing NTF mounts (warning)
Dieses dann auch für 0:1 0:2 (habe 3 Failover IP drauf)

wenn ich den Indianer neu starte bekome ich jetzt folgende Fehlermeldungen

Name virtualHost xxx.xxx.xxx.xxx has no virtualHosts
das dann ebenfalls für jede der 4 IP´s und jede Meldung 2x


Also irgendwie ist das ISPConfig nix für mich befürchte ich... bzw. das update auf 3.0.3 hätte ich mal besser sein lassen sollen.

Domains, Mail usw. laufen aber alle

Nach dem Update kam übrigends folgende Fehlermeldung in den Logs:
Failed to load mptctl
FATAL: Could not load /lib/modules/2.6.34.6-xxxx-grs-ipv6-32/modules.dep: No such file or directory

In einem anderen Forum habe ich gelesen das das dieser Dienst bereits im OVH Kernel integriert ist bzw. in meinem system nicht gebraucht wird. (kein Raid)
Habe die Datei mptctl einfach umbennant in mptctl.bak
Kann das vieleicht damit zu tun haben ?

Sorry wenn ich hier so "nerve" ISP ist leider neuland für mich und falls es inzwischen ein Handbuch in deutsch geben sollte oder ein spez. Forum usw... bin für jeden Tip dankbar

bb21
18.11.10, 23:34
Zitat Zitat von fs80
Der neue Hostname wird normal erst nach einem Reboot oder einem neuen hochfahren der Netzwerkschnittstelle übernommen.
Ein Shutdown der Netzwerkkarte kommt aber bei einem Server ohne Fernwartungskarte etwas ungünstig
/etc/init.d/networking restart
oder eben rebbot / shutdown -r now
bin davon ausgegangen das wäre schon mal gemacht

fs80
18.11.10, 23:30
Zitat Zitat von campo

Einträge bleiben auch schön brav alle nach neustart vom Indianer bestehen... aber...
Der neue Hostname wird normal erst nach einem Reboot oder einem neuen hochfahren der Netzwerkschnittstelle übernommen.
Ein Shutdown der Netzwerkkarte kommt aber bei einem Server ohne Fernwartungskarte etwas ungünstig

campo
18.11.10, 21:08
bei myorigin habe ich /etc/mailname stehen
Hab irgendwo gelesen das das so sein muss und er dann eben den eintrag bei mailname nimmt
myhostname ist geändert
mydomain ... diesen Eintrag finde ich nirgends

Was ich eben gar nicht verstehe:
wenn ich mich über Konsole anmelde begrüsste der mich mit
Hostname :ksxxxx.kimsufi

in der eingabezeile steht aber username und "nur" srv1:
(srv1 ist das was vorm Punkt mein gewollten hostnamen steht)

wenn ich jetzt den hostnamen abrufe kommt der gewollte:
srv1.xxxxxxx.com

wenn ich im ispconfig zum Beilsiep den serverstatud ansehe: srv.xxxx.com
wenn ich die logs ansehe als Überschrift "srv1.xxxx.com"
aber in den logs dann wieder ksxxxxx

Alles sehr verwirrend für mich.

Ist mein erster lenny und auch mein erstes ISPconfig.
Bisher hatte ich immer CentOS und directadmin bzw. auch plesk
Hatte ein solches Problem noch nie

bb21
18.11.10, 20:52
Wenn amavis & co sich mit ks... melden haste sicher dein mailserver noch nicht angepasst.

z.b. bei postfix: /etc/poistfix/main.conf
myhostname = ks0123456.kimsufi.com
mydomain = ks0123456.kimsufi.com.local
myorigin = $myhostname

campo
18.11.10, 20:06
Hallo zusammen...
folgendes Problem habe ich beim Ändern meines Servernamens.. damit das "kimsufi" nicht immer in den Mailheadern steht usw.

A Eintrag bzw. subdomain für den neuen servernamen eingetragen und dann reverse im ovh-manager gemacht.
Klappt auch ( denke das ist normal das da nach meinem neuen Namen /ksxxxx.kimsufi weiterhin stehen bleibt)

hostname geändert
mailname geändert
hosts geändert
im ISPconfig3 servername geändert

Einträge bleiben auch schön brav alle nach neustart vom Indianer bestehen... aber...

Die Kiste nennt sich weiterhin ksxxxx.kimsufi
Im Mailheader steht bei X-UIDL weiterhin kimsufi
auch als received wird weiter localhost Kimsufi angegeben
und auch x-virus -amavisd gibt kimsufi im header aus

Auch mein MX Eintrag meckert (mails gehen aber) da der Eintrag zwar richtig auf domain und mailserver verweisst, der aber dann an Kimsufi... weitergibt
hier wird dann ein A eintrag für kimsufi angemahnt ??

Ich habe jetzt stundenlang in Netz gesucht und auch auf den supportseiten bei ovh sowie hier im Forum...
ich komme einfach nicht darauf wo der Wurm versteckt ist.

irgendwo muss ich einen Eintag vergessen haben, oder ?
Wieso gibt mir lenny weiter als hostnamen den kimsufi trotz richtigen eintrag bei hostname

Ich hoffe jemand kann mir helfen ??


gerade in den mail-Logs gesehen ... die Russen kommen
warning: 92.241.190.43: address not listed for hostname heihachi.net
IP und Domain sind nicht von mir... aus Russland
Kann mich da jemand aufklären was mir das zu sagen hat?