Partner
Vorteile der OVH Partnerprogramme:
Sichtbarkeit, Marketing-Werkzeuge, exklusive Angebote, Glaubwürdigkeit, privilegierte Beziehung.
Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 13

Thema: kein default gateway für ipv6

  1. #1

    Standard kein default gateway für ipv6

    Hallo,

    ich hab nen ca. 1 jahr alten isgenug root server mit freebsd, vor nem halben jahr hab ich ipv6 laut http://hilfe.ovh.de/AdministrationIpv4Ipv6 eingerichtet. Funktionierte bis anfang diesen monats auch wunderbar, seitdem krieg ich aber kein ipv6 default gateway mehr über rtsol. Kann mir wer sagen wie ich das default gateway raus krieg? Der OVH "Kundendienst" mag mir nicht helfen da sie der meinung sind ich hätte was kaputt gefummelt bei mir, komisch dann nur das ich seit nem monat vor dem ausfall nixmehr an der konfiguration geändert hatte und das es plötzlich nachts um 2uhr kaputt geht...

    ich poste mal hier noch meine konfigurations dateien:

    /etc/sysctl.conf
    net.inet6.ip6.accept_rtadv=1

    /etc/rc.conf
    ipv6_enable="YES"
    ipv6_network_interface="sis0"
    ipv6_ifconfig_sis0="2001:41D0:1:9395::1 prefixlen 64"

    rtsol sagt:
    # rtsol -d sis0
    checking if sis0 is ready...
    sis0 is ready
    send RS on sis0, whose state is 2
    send RS on sis0, whose state is 2
    send RS on sis0, whose state is 2
    No answer after sending 3 RSs
    stop timer for sis0
    there is no timer

    # ping6 www.six.heise.de
    ping6: UDP connect: No route to host

    # ping6 -I sis0 www.six.heise.de
    PING6(56=40+8+8 bytes) 2001:41d0:1:9395::1 --> 2a02:2e0:3fe:100::6
    ping6: sendmsg: No route to host


    # ping6 -I sis0 ff02::1
    PING6(56=40+8+8 bytes) fe80::219:d1ff:fe86:d4f3%sis0 --> ff02::1
    16 bytes from fe80::219:d1ff:fe86:d4f3%sis0, icmp_seq=0 hlim=64 time=0.220 ms
    16 bytes from fe80::21e:79ff:fe1e:d400%sis0, icmp_seq=0 hlim=64 time=5.547 ms(DUP!)

    # ping6 -I sis0 fe80::21e:79ff:fe1e:d400
    PING6(56=40+8+8 bytes) fe80::219:d1ff:fe86:d4f3%sis0 --> fe80::21e:79ff:fe1e:d400
    16 bytes from fe80::21e:79ff:fe1e:d400%sis0, icmp_seq=0 hlim=64 time=0.625 ms
    16 bytes from fe80::21e:79ff:fe1e:d400%sis0, icmp_seq=1 hlim=64 time=0.486 ms

    (fe80::21e:79ff:fe1e:d400 gehört NICHT zu mir, die fe80::219:d1ff:fe86:d4f3 schon)

    also scheint zumindest ipv6 erstmal grundlegend zu funktionieren.

    Jemand noch nen tipp für mich?

    Grüße
    Daniel

  2. #2

    Standard AW: kein default gateway für ipv6

    (sorry, meine info war falsch)
    Geändert von gerry (18.02.10 um 09:34 Uhr)

  3. #3
    OVH Team Avatar von mathias
    Registriert seit
    Jan 2007
    Ort
    Germany, Illingen
    Beiträge
    2.552

    Standard AW: kein default gateway für ipv6

    Hallo,

    das Ticket #365271 ist noch offen. Grundsätzlich gilt das Prinzip: Kein Supportschlüssel -> keine Hilfe. Aber Du hast das Problem eingegrenzt und ich hoffe, dass die Rückmeldung des Admins dadurch zur Lösung des Problems beitragen wird.

    Mathias

  4. #4

    Standard AW: kein default gateway für ipv6

    Hallo,

    ja, das ticket ist noch offen ... und das scheinbar noch ne weile wenn ich weiter solche antworten bekomme:

    I won't be able to do more tests if you don't remove this configuration.
    gemeint sind meine freebsd jails und mein openvpn server (der nichmal irgendwas forwarded sondern einfach nur dummer endpunkt is)

    langsam gehen mir echt die ideen aus ... und nein, ich werde meinen mail + web server nich ausschalten weil ovh scheinbar keine ahnung hat was freebsd jails sind. auf die glorreiche idee das openvpn auszuschalten bin ich selber schon gekommen, behebt nur leider nich das problem.

    grüße
    Daniel

  5. #5

    Standard AW: kein default gateway für ipv6

    so, nachdem mich die antwort:

    i would like to be able to establish with actual configuration there is a problem by our side, but i need this configuration resetted
    auch nich befriedigt werde ich zeitnah zu einem anderen anbieter wechseln. solange alles läuft gut und schön, aber beim support hab ich so langsam meine zweifel.

    mal schauen wies montag aussieht, nu is wochenende.

    -
    daniel

  6. #6

    Standard AW: kein default gateway für ipv6

    Hallo,

    noch eine kurze info:

    # tcpdump -i sis0 ip6
    tcpdump: verbose output suppressed, use -v or -vv for full protocol decode
    listening on sis0, link-type EN10MB (Ethernet), capture size 96 bytes
    09:30:54.589277 IP6 fe80::219:d1ff:fe86:d4f3 > ff02::2: ICMP6, router solicitation, length 16
    09:30:58.589493 IP6 fe80::219:d1ff:fe86:d4f3 > ff02::2: ICMP6, router solicitation, length 16
    09:31:02.590429 IP6 fe80::219:d1ff:fe86:d4f3 > ff02::2: ICMP6, router solicitation, length 16
    die router solicitation pakete gehen raus, aber es kommt nie nen router advertisment zurück.

    ich würde die route auch statisch konfigurieren nur leider wurde die frage nach dem entsprechenden gateway bereits 3x vom "support" ignoriert.

    grüße
    daniel
    Geändert von des_dichters_beinkleid (20.02.10 um 08:45 Uhr)

  7. #7

    Standard AW: kein default gateway für ipv6

    Zitat Zitat von des_dichters_beinkleid Beitrag anzeigen
    ich würde die route auch statisch konfigurieren nur leider wurde die frage nach dem entsprechenden gateway bereits 3x vom "support" ignoriert.
    zumindest unter Debian habe ich kein Gateway angeben müssen:
    Code:
    /sbin/ifconfig eth0 inet6 add 2001:41d0:x:xxxx::1/64
    sobald der Rechner eine IPv6 adresse hat, funktioniert auch ein traceroute:

    Code:
    traceroute to www.ipv6.t-online.de (2003:2:0:f302::1:1) from 2001:41d0:2:3548::1, 30 hops max, 16 byte packets
     1  2001:41d0:2:35ff:ff:ff:ff:ff (2001:41d0:2:35ff:ff:ff:ff:ff)  0.503 ms *  1.566 ms
     2  * * *
     3  ix-12-2.har1.PV0-Paris.ipv6.as6453.net (2001:5a0:1900::9)  4.143 ms  4.07 ms  4.034 ms
     4  if-10-0-0.core1.PYE-Paris.ipv6.as6453.net (2001:5a0:1900::39)  4.729 ms  4.626 ms  4.503 ms
     5  2001:5a0:600:100::31 (2001:5a0:600:100::31)  87.122 ms  87.027 ms  87.04 ms
     6  Vlan22.icore1.AEQ-Ashburn.ipv6.as6453.net (2001:5a0:600:300::1)  94.335 ms  97.794 ms  89.917 ms
     7  equi6ix-ash.t-systems.com (2001:504:0:2::3320:1)  87.913 ms  88.247 ms  88.842 ms
     8  2003:0:10:1::1 (2003:0:10:1::1)  182.617 ms  182.01 ms  182.894 ms
     9  2003:0:10:2::2:2 (2003:0:10:2::2:2)  182.432 ms !S  182.073 ms !S  182.411 ms !S
    PS: Schönes Beispiel für den Optimierungbedarf unter IPv6 - Routing zur Deutschen Telekom über USA...

    Vielleicht hilft Dir noch die Routingtabelle weiter:
    Code:
    netstat -6 -r
    Kernel IPv6 routing table
    Destination                    Next Hop                   Flag Met Ref Use If
    2001:41d0:x:xxxx::/64          ::                         U    256 0     0 eth0
    fe80::/64                      ::                         U    256 0     0 eth0
    ::/0                           fe80::222:91ff:fe08:400    UGDAe 1024 0  5908 eth0
    ::/0                           ::                         !n   -1  1222852 lo
    ::1/128                        ::                         Un   0   1427137 lo
    2001:41d0:x:xxxx::1/128        ::                         Un   0   1177003 lo
    fe80::21c:c0ff:feb3:9cfe/128   ::                         Un   0   1 74641 lo
    ff00::/8                       ::                         U    256 0     0 eth0
    ::/0                           ::                         !n   -1  1222852 lo
    Woher die default route (::/0) kommt ist mir nicht ganz klar, fe80::222:91ff:fe08:400 kann ich jedenfalls nicht anpingen ("unkown host") - trotzdem ist der Rechner per IPv6 einwandfrei erreichbar.

  8. #8

    Standard AW: kein default gateway für ipv6

    Es gibt ein IPv6 default GW, auch wenn OVH das nicht weiss oder das als Betriebsgeheimnis führt. Im Fall des Vorposters ist es die '2001:41d0:2:35ff:ff:ff:ff:ff'. Vorgehensweise: von der /64 Adresse den /56 Teil ausschneiden und auf die letzten fünf 16bit Anteile jeweils 256 (0xff) addieren.

    Das Router-Advertisement scheint bei OVH zeitweise nicht gut zu funktionieren. Bei meinem lokalen V6 Netz habe ich dagegen damit keine Probleme. Bei OVH habe ich daher das GW direkt konfiguriert. IPv6 wird sowieso mit geringer Prio behandelt - ich sehe in den letzten Wochen immer mal wieder Ausfälle wobei die V4 Verbindungen nicht betroffen sind. Dummerweise bevorzugen meine Services inzwischen V6...

  9. #9

    Standard AW: kein default gateway für ipv6

    Hallo,

    vielen dank, u338457, das is doch mal ne ansage. ich werd das mal so konfigurieren wenn ich zeit hab, die woche hab ich noch mit der vorbereitung meiner verteidigung zu tun.

    grüße
    daniel

  10. #10

    Standard AW: kein default gateway für ipv6

    Zitat Zitat von u338457 Beitrag anzeigen
    Es gibt ein IPv6 default GW, auch wenn OVH das nicht weiss oder das als Betriebsgeheimnis führt. Im Fall des Vorposters ist es die '2001:41d0:2:35ff:ff:ff:ff:ff'. Vorgehensweise: von der /64 Adresse den /56 Teil ausschneiden und auf die letzten fünf 16bit Anteile jeweils 256 (0xff) addieren.

    Das Router-Advertisement scheint bei OVH zeitweise nicht gut zu funktionieren. Bei meinem lokalen V6 Netz habe ich dagegen damit keine Probleme. Bei OVH habe ich daher das GW direkt konfiguriert. IPv6 wird sowieso mit geringer Prio behandelt - ich sehe in den letzten Wochen immer mal wieder Ausfälle wobei die V4 Verbindungen nicht betroffen sind. Dummerweise bevorzugen meine Services inzwischen V6...
    Hi,

    hab nun mal die 2001:41D0:1:93ff:ff:ff:ff:ff als default router konfiguriert, keine besserung.

    Der support von ovh meint immernoch ich solle meine privaten ip adressen vom loopback device entfernen und somit mein freebsd jails setup zerschießen was schon lange bevor ich ipv6 eingerichtet hab funktioniert hat.

    Am beeindruckendsten find ich ja die die nachricht von meinem bearbeiter das an folgendem traceroute auszug was nich stimmt:

    traceroute to 2001:41d0:1:9395::1 (2001:41d0:1:9395::1), 30
    hops max, 40 byte packets
    1 2a01:e35:2ef1:1f50::1 (2a01:e35:2ef1:1f50::1) 1.461 ms
    1.841 ms 2.204 ms
    2 6to4-1-th2-e3.intf.routers.proxad.net (2a01:e00:2:a::2)
    27.405 ms 28.087 ms 30.090 ms
    3 th2-crs16-1-te1-4-0-2.intf.routers.proxad.net
    (2a01:e00:2:a::1) 32.062 ms 33.013 ms 35.031 ms
    4 * * *
    5 ipv6.th1-1-6k.routers.net (2001:41d0::521) 40.812 ms *
    *
    6 ipv6.rbx-1-6k.routers.net (2001:41d0::591) 62.513 ms
    32.626 ms 34.954 ms
    7 ipv6.rbx-1-6k.routers.net (2001:41d0::591) 3046.419 ms
    !H * *
    3 exakt ähnliche traceroutes hab ich vorher ins ticket gepostet und die wurden mit dem kommentar "damit is alles inordnung" abgeschmettert. AHA!

    Nun kam wieder ne mail das er keine weiteren tests machen kann wenn ich nich alles auf urzusprung zurück versetze ...

    ehrlich gesagt kann ich mir gleich nen neuen anbieter suchen, ich meine wenn ich mir das setup zerschießen soll um es hinterher wieder zu konfigurieren ...

    naja ich hör nu auf zu schreiben bevor ich ausfallend werde...

    grüße
    daniel

Seite 1 von 2 12 LetzteLetzte

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •